New MSI 290 Gaming, cannot boot into Windows 8

Discussion in 'Videocards - AMD Radeon' started by prof72, Mar 8, 2014.

  1. prof72

    prof72 Master Guru

    Messages:
    219
    Likes Received:
    0
    GPU:
    Gigabyte GTX 670 OC
    Just bought a new MSI 290 Gaming today, replacing my GTX 670.

    Before installing I completely uninstalled Nvidia software.

    Fitted the new card and proceeded to boot up and enter windows (8.1).

    However after the windows logo the screen goes black and locks up the PC forcing a hard reset or power off.

    Tried everything I can think of (safe mode, reinstalling windows, etc...)

    Anyone have any suggestions? The card can't be dead as the PC boots and I can enter the bios and install windows etc.

    *edit* plugged it into an older pc and it works fine, really head scratching now as to why it wont work with current PC
     
    Last edited: Mar 8, 2014
  2. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,340
    Likes Received:
    475
    GPU:
    MSI 2070S X-Trio
    Check to see if your running the latest BIOS for your motherboard, as may need updating if not.

    Could also try flicking the BIOS switch on the card to the other position as well.
     
    Last edited: Mar 8, 2014
  3. prof72

    prof72 Master Guru

    Messages:
    219
    Likes Received:
    0
    GPU:
    Gigabyte GTX 670 OC
    Definitely the latest bios, have tried both PCI-E slots as well.

    tried various setting for the iGPU, which my gut is telling me is the amd doesn't like it.

    Will try the bios switch, thanks.
     
  4. Pill Monster

    Pill Monster Banned

    Messages:
    25,216
    Likes Received:
    7
    GPU:
    7950 Vapor-X 1100/1500
    Do u have an option to disable PCI 3.0 in the bios?
     

  5. roki977

    roki977 Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    Asus gtx 670 dc2 TOP
    That sounds to me like windows 8 black screen issue after installing graphics drivers. It was fairly common issue when 8 was out. Google it and try some of soulutions you find. I had it to but i dont remember how I sorted that..
     
  6. jaju123

    jaju123 Master Guru

    Messages:
    356
    Likes Received:
    3
    GPU:
    2x AMD R9 290 Crossfire
    Try an ubuntu live disk or something!
     
  7. seaplane pilot

    seaplane pilot Maha Guru

    Messages:
    1,295
    Likes Received:
    2
    GPU:
    2080Ti Strix
    Did you disable the iGPU? Maybe try reseting the mainboard BIOS to optimized default.
    Try installing the Nvidia and AMD GPU together and see if Windows is seeing the AMD GPU in device manager.

    Also use DDU in safe mode select the option that shut down without restarting, then pop in the AMD GPU, good luck.
     
    Last edited: Mar 9, 2014
  8. prof72

    prof72 Master Guru

    Messages:
    219
    Likes Received:
    0
    GPU:
    Gigabyte GTX 670 OC
    *SOLVED*

    Posting how I solved in case it might help someone else.

    There was an option to force gen3 instead of Auto for the PCI-E bus.

    This seemed to have worked ok on a fresh install (still didn't work on the old Win8.1 install)
     
  9. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,340
    Likes Received:
    475
    GPU:
    MSI 2070S X-Trio
    Glad you sorted it :)
     

Share This Page