[New Bios] ASUS ROG Radeon RX 470 Strix Gaming OC 4GB

Discussion in 'Videocards - AMD Radeon' started by KissSh0t, Jun 16, 2017.

  1. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    5,185
    Likes Received:
    28
    GPU:
    ASUS RX 470 Strix Gaming
    I just thought I would mention that the ASUS ROG Radeon RX 470 Strix Gaming OC 4GB has received a new bios on the Asus website.

    [​IMG]

    This is what the bios looks like now for those with this card to compare against.

    [​IMG]

    I haven't tested it enough to see if it has fixed the screen losing connection when playing video games... guess I'll find out in the coming days.

    *Fingers crossed this makes the card stable at default clocks*

    *edit*

    After about 2 hours of using the card no black screens at default clocks...

    *Fingers crossed this is really really fixed for real*

    xD
     
    Last edited: Jun 16, 2017
  2. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    531
    Likes Received:
    14
    GPU:
    HD 7950 Vapor-X 3GB Boost
    It took them long enough, but you can rejoice that it's fixed now! Enjoy gaming, my friend. You've suffered enough.
     
  3. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    5,185
    Likes Received:
    28
    GPU:
    ASUS RX 470 Strix Gaming
    It looks like it's ok.. I've tried Space Engineers & Dishonored 2 & Prey so far and it has not black screened once when before it would have in that time period at the default clocks.

    I still feel like at any moment the screen is going to go black and my eye is twitching xD

    Could anyone tell me how would I see what it is they changed with the bios?

    I tried opening the new bios and comparing it to the previous one that I had backed up with gpu-z using Polaris Bios Editor, but all the settings are identical.. at least what the editor shows is identical, maybe there are other values that the editor does not show?
     
    Last edited: Jun 16, 2017
  4. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    531
    Likes Received:
    14
    GPU:
    HD 7950 Vapor-X 3GB Boost
    My guess is that a portion of the UEFI GOP of the VBbios was messed up. I am guesstimating. Does your GPU maintain better boost/base clocks now, btw?
     

  5. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    5,185
    Likes Received:
    28
    GPU:
    ASUS RX 470 Strix Gaming
    I haven't checked that yet actually.. the main issue for this specific card model is it losing connection to the monitor resulting in the screen turning off like when you unplug the monitor cable from the video card then the monitor just says no signal.. that's what it was doing when playing video games, sometimes after a few seconds, sometimes after half an hour to an hour.

    Before this new bios I was having to undervolt and underclock the two upper states to make the card stable, now it's just default everything, fresh crimson install and it seems to be running as intended.
     
    Last edited: Jun 16, 2017
  6. INJ3CT8R

    INJ3CT8R New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ASUS STRIX RX470 OC
    Hey man I really need your help. I have exactly a same issue with my Asus RX 470 Strix from two month ago. I did a lot of things from increasing power limit in wattman to changing many drivers with stick voltage and frequency but no signal issue is remain. Maybe the card run fine for many hours maybe get no signal in 5 minutes of gaming. Also my psu is 700 watt and is enough

    This is also 2 different topic one is mine with the same problem as you can see


    https://community.amd.com/message/2802610
    https://community.amd.com/thread/204905


    I will be very appreciate if you give me the guide step by step to fix this nightmare problem. How I can change bios and where is that bios to download? Ia the risk to breaking my card?

    Thanks a lot man...
     
  7. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    5,185
    Likes Received:
    28
    GPU:
    ASUS RX 470 Strix Gaming
    Do you have the overclocked model of the asus rx 470? the product model is ROG STRIX-RX470-O4G-GAMING

    The bios is available on the support page on the asus website, here are two links for the same card.

    US webpage https://www.asus.com/Graphics-Cards/ROG-STRIX-RX470-O4G-GAMING/HelpDesk_Download/

    Australian webpage https://www.asus.com/au/Graphics-Cards/ROG-STRIX-RX470-O4G-GAMING/HelpDesk_Download/

    Under driver and tools tab > Windows 10 > bios.

    And I have uploaded a copy of the file available on the asus website to my mediafire account http://www.mediafire.com/file/tjos9cyrn3w24s3/STRIX_RX470_OC.rar

    Basically extract the file and run it as administrator, you don't need to be on Windows 10, for example I am on Windows 8.1.

    It will then apply the new bios to the card and ask that you reset once it is applied and that is all you do and then it has the new bios.

    Hope that helps.
     
  8. INJ3CT8R

    INJ3CT8R New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ASUS STRIX RX470 OC

    Yes man exactly I have that same model... Thank you very much I flashed new bios and checked also in gpu-z to make sure it is flashed properly. Me also From 2 hours of gaming I didn't had problem hopefully and I hope never get no signal anymore later... Unfortunately we never knew when gpu loses signal maybe one week gpu run fine but I think and new bios really fixed that because asus was aware of it but If the problem come back I will post here.. Again thanks for this useful topic..
     
  9. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    5,185
    Likes Received:
    28
    GPU:
    ASUS RX 470 Strix Gaming
    Very good to hear, hopefully this bios fixes it 100%

    Before this bios update I was underclocking and undervolting the card with wattman to make it not black screen when gaming.

    Just in case this card ever does have that terrible black screen again I will put a screenshot of those wattman settings here, hopefully wont ever have to use them.

    [​IMG]
     
  10. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    5,185
    Likes Received:
    28
    GPU:
    ASUS RX 470 Strix Gaming
    Well I had another screen losing connection when gaming crash... So it seems it's still possible for this card to have this annoying crash even with the new bios, although it is much much more stable than before.... before it was guaranteed to do it within 10 minutes to an hour of playing any video game, now it's very very rare.

    Ive reported it again, hopefully they release a new bios that 100% fixes it :<

    *crosses fingers*
     
    Last edited: Jul 11, 2017

  11. INJ3CT8R

    INJ3CT8R New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ASUS STRIX RX470 OC
    Very sad to hear that man So yes I can confirm also that another user in amd forum had this problem again even with this new bios however I sold out my card and got a gtx 1060 6gb finally. This was my first experience with an buggy amd product and I became very frustrated
     

Share This Page