New ATI Windows 7 WHQL cert. Drivers ver 8.612!!!

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Shinshin, May 6, 2009.

  1. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,709
    Likes Received:
    680
    GPU:
    MSI 2070S X-Trio
    It doesn't matter what it says in the Catalyst version, as its the driver that has been updated, and the Direct 3D Version (8.612 & 8.14).
     
  2. Lozeritis

    Lozeritis Member Guru

    Messages:
    148
    Likes Received:
    0
    GPU:
    (2x) ATI 4870 1GB XFire
    Valid point; I just saw that some peeps CCC's were showing 9.3 or nothing at all. No biggie.
     
  3. Funky Doodle

    Funky Doodle Master Guru

    Messages:
    792
    Likes Received:
    0
    GPU:
    Gigabyte ATI HD 5830 1GB
    are u sure?
     
  4. darrenj

    darrenj Ancient Guru

    Messages:
    1,747
    Likes Received:
    99
    GPU:
    EVGA 3080
    These drivers work superb so far. Hawx, Burnout Paradis and FEAR 2 are very smooth.
    by the way talking about idle, my Powercolor 4870 1gig idles at 53-54 with the factory zerotherm fan at 50 percent. It only set to 100 percent for gaming.
    I did have an issue when I exited Fear 2 after an hour of playing. The desktop was visible with icons, but no taskbar or gadgets and no left click (never happened before). Had to eventually restart. Will try another session later today-

    Win 7 RC 64
     

  5. mwpeck

    mwpeck Active Member

    Messages:
    87
    Likes Received:
    0
    GPU:
    EVGA GTX 295
    Not 100%, but according to: http://twitter.com/CatalystMaker

    His response:
    That was on May 6th......he has been pretty accurate on release schedules (he does work at AMD/ATI afterall) so I would say it can be expected next week, but there always could be delays that push it back.
     
  6. UncleGuito

    UncleGuito Active Member

    Messages:
    90
    Likes Received:
    0
    GPU:
    Radeon HD 4850
    I'm getting stuttering in Dead Space on Windows 7 x64, wasn't like this on the default Win7 drivers.
     
  7. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,709
    Likes Received:
    680
    GPU:
    MSI 2070S X-Trio
    They always release them around the 18th of the month, on a Wednesday, and the closest Wednesday to that if the 18th doesn't fall on a Wednesday, so id guess the 9.5's will be on the 20th.
     
    Last edited: May 10, 2009
  8. Funky Doodle

    Funky Doodle Master Guru

    Messages:
    792
    Likes Received:
    0
    GPU:
    Gigabyte ATI HD 5830 1GB
    not always!
     
  9. KillerSneak

    KillerSneak Banned

    Messages:
    1,126
    Likes Received:
    0
    GPU:
    2x HD 3870's CrossFireX
    The Cat 9.4 is a left over from your previous drivers. These drivers don't come with a Catalyst version. This is one of the strings I added with the uninstall of the DNA-ATi drivers as ATi/AMD doesn't delete this string by default.
     
  10. KillerSneak

    KillerSneak Banned

    Messages:
    1,126
    Likes Received:
    0
    GPU:
    2x HD 3870's CrossFireX
    I got some requestes from people if i could release this build to the public. I want to give these people the opportunity to give them a spin

    Note that these drivers are still in Beta testing. The drivers are how ever in a near final stage and should work normally if not i would be glad to hear any feedback so i can get into the "problems" asap.

    DNA-ATi Vista & Win7 8.612 Open beta

    Hope you guys enjoy this release.

    EDIT:
    Download link fixed
     
    Last edited: May 10, 2009

  11. cvvt20

    cvvt20 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    2 x Gainward HD 4850 GS
    I have to try the DNAs because after installing the official 8.612 my monitor, HP W2207h, went to sleep mode for forever.
    SafeMode with VGA does the same thing and only W7 system restore fixes the problem.
    I read somewhere that some earlier driver versions did the same thing with two 4850 in CF?
     
  12. Rich_Guy

    Rich_Guy Ancient Guru

    Messages:
    12,709
    Likes Received:
    680
    GPU:
    MSI 2070S X-Trio
    yeah mine shows 9.3 as i never bothered with the 9.4's, as they were only for the 4890's. :)
     
  13. xeo5

    xeo5 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ATI Radeon 4670 512mb
    Video conversion using AVIVO codecs takes longer with these drivers. Using A's Video Converter and my usual DVD settings I was getting around 310 fps with GPU usage around 25% with the Vista 9.4's. Now the GPU usage is going up past 30% but the fps, using the same settings, is down to 200fps.
     
  14. KillerSneak

    KillerSneak Banned

    Messages:
    1,126
    Likes Received:
    0
    GPU:
    2x HD 3870's CrossFireX
    I got some requestes from people if i could release this build to the public. I want to give these people the opportunity to give them a spin

    Note that these drivers are still in Beta testing. The drivers are how ever in a near final stage and should work normally if not i would be glad to hear any feedback so i can get into the "problems" asap.

    DNA-ATi Vista & Win7 8.612 Open beta (UPDATED)

    Hope you guys enjoy this updated release. This will be the last open beta before the set goes final as allot has changed in this release already.
     
  15. eRa`

    eRa` Ancient Guru

    Messages:
    1,825
    Likes Received:
    1
    GPU:
    Palit GeForce GTX 570
    I just upgraded to a 4870X2 and did a clean install of the W7 RC using these drivers. Just fired up WoW + RivaTuner and noticed that the second GPU is not working (usage is almost zero).

    Anyone else with the same problem around?

    Edit: Nevermind, this just happens when I play in Window Mode, Full Screen works fine.
     
    Last edited: May 14, 2009

  16. PearlChoco

    PearlChoco Master Guru

    Messages:
    240
    Likes Received:
    5
    GPU:
    ASUS GTX 570 DirectCU II
    Cats 9.5 should be here tomorrow...
     
  17. EddieZ

    EddieZ New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    MSI x1950 PRO
    x1950 "hideously outdated"? It runs games like HAWX perfectly on 1650x1050 with 2xAA perfectly. So why even bother to spend a lousy $60 for another card? This is exectly the marketing tactics the manufacturers want you to believe in. Not everyone wants to play Crysis with all specs enabled.

    So putting the x1950 back as legacy is forcing the public the buy new stuff that from a useability point of view need no replacement.
     
  18. Wolfskin07

    Wolfskin07 Member Guru

    Messages:
    161
    Likes Received:
    9
    GPU:
    GTX 1080Ti
    Hello dear gurus,

    So I installed the 9.5's from the download section in the site and the weirdest thing happened...I have an Asus VH226H 22" 1080p monitor and i always used the DVI-to-HDMI dongle to connect my HD4870x2 to the HDMI port on the monitor, but ever since this morning, when i installed the 9.5's if i have the monitor connected like this the image goes crazy; I get the flickering between a very faint desktop image and a black screen...I tried connecting the monitor via DVI cable and it works 100%.
    So i installed my monitor on my home theater setup via HDMI and it works 100% as well.
    The problem also happens when you boot up so I kinda doubt it's a software related problem... Can it be the GFX? or can it be that the DVI-to-HDMI dongle malfunctioned??
    I'd really appreciate some insight on this matter!

    Thx in advance,

    Wolfskin07

    EDIT #1

    Aftertesting the monitor in the home theater and connecting it to the PC via DVI-To-HDMI dongle it worked for some brief moments just to start doing the same thing after like 15 secs on the desktop =S
     
    Last edited: May 17, 2009
  19. Lutfi

    Lutfi Master Guru

    Messages:
    428
    Likes Received:
    0
    GPU:
    Asus EAH4870X2 Trifan
    this driver is a bad for my video playback..

    seems to be not smooth as before.. even on the HD or bluray video..

    please help me.. :D
     

Share This Page