new 7790 has strange artifacting in firefox

Discussion in 'Videocards - AMD Radeon' started by Dave-oh, Aug 28, 2013.

  1. Dave-oh

    Dave-oh New Member

    Messages:
    3
    Likes Received:
    0
    Graphics Card::
    Powercolor 7790
    Hi guys, I just bought a Sapphire HD7790 to replace my old card. But now when I open firefox I get this odd affect happening.

    http://postimg.org/image/n9hicozbh/full/


    I thought it might be driver related. I had initially installed the 13.8 beta drivers but I uninstalled them and have since installed the latest 7790 driver version 12.101.2.1000 (from April 16) as AMD listed separate drivers for the 7790

    GPU-Z shows the temp to be 42C after about 4 hours use (no games running though I do play CS:S now and then.

    http://postimg.org/image/h3le0jmhx

    Is the card faulty? Is 42C an ok temp? thanks
     
  2. PNeV

    PNeV Ancient Guru

    Messages:
    2,072
    Likes Received:
    0
    Graphics Card::
    MSI GTX 1070 Armor OC
    Is that 42c Load or Idle? Also try underclocking the memory a little bit just to see if that fixes it.
     
  3. IcE

    IcE Don Snow Staff Member

    Messages:
    10,646
    Likes Received:
    0
    Graphics Card::
    Gigabyte 970 G1
    Disable HW acceleration in Firefox and see if it goes away.
     
  4. Dave-oh

    Dave-oh New Member

    Messages:
    3
    Likes Received:
    0
    Graphics Card::
    Powercolor 7790
    Disabling the hardware acceleration in Firefox seems to have fixed the problem. I'll monitor it over the next day or so to be sure. If the problem comes back I'll try to underclock the memory at that point. I'm assuming I'll need to use the overdrive feature in CCC to do that.

    thanks again.
     

  5. Athlonite

    Athlonite Maha Guru

    Messages:
    1,119
    Likes Received:
    0
    Graphics Card::
    Nitro+RX580 8GB OC
    Pale Moon had the same problem random black squares they fixed it with an update try updating your FF version
     
  6. Dave-oh

    Dave-oh New Member

    Messages:
    3
    Likes Received:
    0
    Graphics Card::
    Powercolor 7790
    Hi Athlonite

    I have Firefox set to check for updates and install them automatically. I'm currently using version 23.01

    The problem seems to have resolved itself since I disabled hardware acceleration in Firefox.

    thanks to everyone for the suggestions
     
  7. airbud7

    airbud7 Ancient Guru

    Messages:
    4,286
    Likes Received:
    2
    Graphics Card::
    MSI RX 480 ARMOR 4G OC

    IcE^ ftw...:thumbup:
     
  8. jazzie

    jazzie Active Member

    Messages:
    99
    Likes Received:
    0
    Graphics Card::
    powercolor hd7790 turbodu
    may i ask you dave?

    do you have a Driver Stop working problem???

    i'm using pwc hd7790 and i suffer this problem so hard

    -_- just askk....i tried to underclock ,,, plus powerconsumption whatever

    it ' stilll the same .... problem still occur..
     

Share This Page