Need some help with Freesync on Nvidia

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Smough, Oct 23, 2021.

  1. Smough

    Smough Master Guru

    Messages:
    687
    Likes Received:
    120
    GPU:
    GTX 1060 3GB
    So I now have a really nice monitor with Freesync, 75 Hz, I used a DisplayPort cable so my nvidia GPU recognizes it as G-Sync and works perfect. But I have some concerns. The way I have been using this is turning off v-sync off in any game and then cap the fps with Rivatuner, generally I limit them to 60 so I can benefit from the Freesync range, which generally is 42 to 75, I see no tearing at all, ever. But when I limit the fps to purely 60, I see some odd judders and halts that are not registered by MSI Afterburner frametime graph. If I limit them to say, 65-70, then this seems to be diminished, but still there, the good thing is that fps drops are very hard to notice. But what can I do about the other stuff I mentioned? Do I need to enable ultra low latency mode or something?

    Also some games just go insane with G-Sync mode active and stutter a lot, but only some. Resident Evil 2 seems not to like it, Kingdom Come Deliverance became a mess as well, I tried 48 fps, 50, 60 and these games didn't like that, so for some games I just set them to "Fixed refreshrate" in NVCP, enable v-sync in the game options and they run fine. Any ideas about this?

    Thanks.
     
  2. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,265
    Likes Received:
    182
    GPU:
    RTX 3090 ROG Strix
    Hm, odd.

    Which monitor model is it anyway? If a FreeSync monitor validated for G-Sync compatible, it may have problems using G-Sync compatible in general, in which case there probably isn't much you can do. Not all VRR monitors work nicely with G-Sync compatible.

    If you haven't tried already, try to enable Vsync in the Nvidia Control Panel and see if that helps. You can also try to enable Vsync in certain games to see if that works better, but for most games Vsync on in the Nvidia Control Panel and off in the game settings with G-Sync will work best.

    It could also be that the game drops to below the Freesync range for a very short spike (too short for the frametime graph to notice), which could cause the stutter. At 60Hz the GPU could clock down due to less load, too, which could cause such spikes. You could also try to adjust your VRR floor down a bit with CRU (if your monitor allows it, so be careful!) and see if that helps.

    Do you have G-Sync enabled for both Windowed and Full Screen mode? Otherwise G-Sync will only work in games that are running in real full screen mode, but not fake/borderless full screen as that's really windowed (Keep in mind that Windows 10/11 will try to fake the full screen in many games even if proper full screen is selected unless you disable full screen optimizations).
    You can also try to turn Variable Refresh Rate on or off in the Windows Graphics settings to see if that helps.
     
    Last edited: Oct 27, 2021
    akbaar and Smough like this.
  3. Smough

    Smough Master Guru

    Messages:
    687
    Likes Received:
    120
    GPU:
    GTX 1060 3GB
    Ok so I enabled the option so Freesync works on Fullscreen and Windowed, that seems to fix the issue, but i'll test more to see.
     
    Cave Waverider likes this.
  4. Mineria

    Mineria Ancient Guru

    Messages:
    4,996
    Likes Received:
    421
    GPU:
    Asus RTX 3080 Ti
    As for FSO.

    Windows Registry Editor Version 5.00
    [HKEY_CURRENT_USER\System\GameConfigStore]
    "GameDVR_FSEBehavior"=dword:00000002

    2 = disabled
    0 = enabled

    Be aware that it messes up alt + tab for some games.
     
    Last edited: Oct 23, 2021
    akbaar likes this.

  5. NingNangNong

    NingNangNong Member

    Messages:
    18
    Likes Received:
    1
    GPU:
    RTX 3070
    I have "GameDVR_FSEBehaviorMode"=dword:00000002 and no "GameDVR_FSEBehavior" in reg. Is that a Windows version (10/11) thing, the same thing or something to add on top of the "mode"?

    My 144hz monitor is "non" g-sync compatible in the sense that it's not listed anywhere [even models that are very similar from the same manufacturer]. It works fine for me. I only have full-screen checked, not windowed, and I've made sure to add that into the default profile in NV Inspector as well as per profile [I mainly play 2-3 games and I have them set the same - except for NULL, which changes depending on Reflex and need).

    The v3 limiter is actually pretty great imo, so I'd recommend using that over RTSS in most instances as I've found RTSS adds a sizeable delay in games with Reflex - games where input lag isn't a concern, then RTSS for the probably better frametime results may be best, up to you!

    [Open the G-Sync page in NVCP and then hit Display at the top and turn the indictor on to help check - also, unchecking and checking the "Enable settings..." thing seemed to help me when it played up a while ago]
     

    Attached Files:

    • nv.png
      nv.png
      File size:
      12.5 KB
      Views:
      11
  6. Blanky

    Blanky Member

    Messages:
    28
    Likes Received:
    8
    GPU:
    RTX 2070 SUPERXTrio
    I have an AOC monitor with freesync 75Hz, although according to the nvidia panel is not validated if I work G-sync Compatible, in many games if I limit the fps for example to 60,50,40 ... I get these sudden vibrations, like micro stutters, when I move the camera smoothly I notice that it moves like little jumps, it is not something smooth, I have used both the nvidia limiter, RTSS, game limiter and in my monitor panel it indicates that freesync is enabled.

    However testing I found a solution for me, if I limit the game to 75 fps with RTSS or Nvidia Control Panel, as my screen is 75Hz I get a smoothness that solves everything I mentioned I suffered from, everything is perfect with no vibrations or micro stutters , even if I do what many people indicate to limit below 2 or 3 fps to be in the Freesync range I also get the micro stutters, I always thought that having a monitor with variable frequency would make me not notice when you are below the frequency, I am forced to play at 75 fps, I am disappointed that I can't play at lower fps when I want to stream. I would like to limit myself to 60 so as not to saturate the GPU when playing and encoding the stream and reduce some load.

    I've always thought it's a problem that my monitor isn't validated and that it's not a good panel. If I disable G-sync Compatible it's all unplayable no matter if I limit it to 75,60,50, everything moves in jumps, I'm forced to play with it and with the flaw of not being able to play below 75 to be fluid.

    try to limit to the same frequency as your monitor, if you have latest version of Windows10, in configuration / system / graphics settings will put you exact frequency at which you are with decimals, in my case is 74.986Hz as that number I write it in RTSS and for me it is night and day to play like this, I do not know if you solve this to you, but my monitor at fps 50,60 does not work smoothly, at low fps I am disappointed my monitor when by range should work smoothly between 38-75Hz according to the manufacturer.

    PS: Sorry about this bible, I found it interesting to see that someone with freesync also suffers from something similar. (Sorry for my bad English)
     
  7. Mineria

    Mineria Ancient Guru

    Messages:
    4,996
    Likes Received:
    421
    GPU:
    Asus RTX 3080 Ti
    Odd that Mode was missing when I looked it up, seeing that they have both entries though, (scroll down a bit):
    Disable Fullscreen Optimizations in Windows 10 (winaero.com)


    Anyway, default values for it should be like this I suppose?
     
    Last edited: Oct 25, 2021
  8. Terepin

    Terepin Master Guru

    Messages:
    802
    Likes Received:
    77
    GPU:
    ASUS RTX 3070 Ti
    And this is why V-Sync is recommended together with FreeSync/G-Sync.
     
    Mineria and Mufflore like this.
  9. Mufflore

    Mufflore Ancient Guru

    Messages:
    13,137
    Likes Received:
    1,525
    GPU:
    Aorus 3090 Xtreme
    Was about to say the same, my CRG9 is perfect in Gsync compatible use, there is no reason for me to think about getting another display other than the HDR black level. But even that isnt a show stopper because it can go so damn bright!
    I dont mess with frame limits etc, it works great just with vsync enabled.
     
  10. Mineria

    Mineria Ancient Guru

    Messages:
    4,996
    Likes Received:
    421
    GPU:
    Asus RTX 3080 Ti
    Yup, because V-Sync becomes Free-Sync/G-Sync aware.
     

  11. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,465
    Likes Received:
    964
    GPU:
    3080Ti Strix H20
    Here's what you need to do.

    1. Enable Vsync in NVCPL per game.
    2. Set Low Latency mode to ultra in NVCPL per game.

    That's it. Using ultra mode sets a cap automatically, probably around 72fps for your refresh rate which ensures you are in the freesync range.
    You don't need to use RTSS frame cap with the above setup but it depends on the circumstances

    Vsync enabled with gsync ensures that the monitor is synced perfectly by using frame time compensation.
     
  12. bensmooth

    bensmooth Member Guru

    Messages:
    178
    Likes Received:
    31
    GPU:
    3060Ti Elite Rev2

    Thats very true but i will say that the low latency mode does not need put to ultra, as this add's delay than take it away. Ie. "he will expecience more hitching". This was reproduced many time's by "battlesense" on youtube. Low latency ultra mode is fine for the standard monitor's on 60 to 75hz but when you're using G-sync / free-sync basic#premium it just cause delay. Which can be noticed on the frametime's itself. If i recall i also think theres a article on blurbusters about this too.

    What i use on my 165hz lg ultragear g-sync compatible monitor, is vsync enabled (or adaptive within nvidia inspector profiling) and fullscreen g-sync option checked. plus on the monitor with enabling the freesync/premium option. All vsync options ingame's turned off and a fps limiter -3 on riva/game config etc. (remember to test you're monitor's refresh rate on blurbusters browser source "special tools section refresh rate @ https://www.testufo.com/refreshrate- as this will give you a more accurate refresh rate reading than some other application's.) And it will be a longer refresh number as it's in decimal's than you would expect, ie mine read 164.868Hz.

    So that's a 165hz monitor on stock running @ 164.868 , so -3 of that i would input 161.868. So it's correctly set.

    I find no stutter in games and delay is very minimal on mousemovement/clicks to screen response time's.


    Correct me if im wrong as im happy to be corrected.
     
  13. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,465
    Likes Received:
    964
    GPU:
    3080Ti Strix H20
    Additional delay is added if there is low GPU utilization yes.

    But the delay added is very small, maybe a couple ms on average which is inconsequential.
    The delay added shrinks with higher refresh rates so that delay would be worse on 60-75hz screens, but again it won't be noticeable.

    In titles that GPU utilization is maxed out(say game fps is around high 70s) then ultra mode will reduce latency by a significant amount.
    Another benefit is that it automatically enables an FPS limit built into the NVIDIA driver which is very good and consistent.

    If you only enable Low latency to ON, you will have to use an external frame limiter.

    I have a 240hzG7 and I pretty much use ultra low latency for every game I play minus those that have NVIDIA reflex built in.
    In those games I simply set low latency to on and reflex mode automatically caps the frame rate.

    So to recap, yes there's a delay added depending on circumstances(low GPU usage) but it's not a noticeable delay.
    You will not experience hitching either
     
    bensmooth likes this.
  14. bensmooth

    bensmooth Member Guru

    Messages:
    178
    Likes Received:
    31
    GPU:
    3060Ti Elite Rev2

    Thanks for clearing that up for us! lord palpatine, as alway's you're padawans are still learning the way of the ge...force
     
    mbk1969 likes this.
  15. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,465
    Likes Received:
    964
    GPU:
    3080Ti Strix H20
    [​IMG]
     

  16. bensmooth

    bensmooth Member Guru

    Messages:
    178
    Likes Received:
    31
    GPU:
    3060Ti Elite Rev2
  17. mbk1969

    mbk1969 Ancient Guru

    Messages:
    11,500
    Likes Received:
    9,235
    GPU:
    GF RTX 2070 Super
    Smough, Mineria and Agent-A01 like this.
  18. Mineria

    Mineria Ancient Guru

    Messages:
    4,996
    Likes Received:
    421
    GPU:
    Asus RTX 3080 Ti
     
  19. Smough

    Smough Master Guru

    Messages:
    687
    Likes Received:
    120
    GPU:
    GTX 1060 3GB
    Well, this thread turned out to some good info and some funny stuff, nice stuff.
     
    bensmooth likes this.
  20. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,465
    Likes Received:
    964
    GPU:
    3080Ti Strix H20
    Did you buy a new PSU yet? I assume you were the one who made the thread recently about poor performance
     

Share This Page