Need help with Witcher 3 and RivaTuner config (Already solved)

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by Smough, Apr 27, 2018.

  1. Smough

    Smough Master Guru

    Messages:
    639
    Likes Received:
    112
    GPU:
    GTX 1060 3GB
    Edit: Solved the issue completely, installed nVidia driver 390.77 and the game is very stable now, with or without RivaTuner, as I suspected, it was a driver problem.

    So I need some help here. Witcher 3 despite being my favorite game of all time, specially now that I found a mod that makes the combat a lot deadlier, looks like it always had itching or stutter issues in one way or another, even at 60 fps, with or without Windows 10 full screen optimizations, with or with RivaTuner. That always seemed to be my case after having played the game in three different system configurations and three different versions for Windows, long time ago on a Core 2 Quad (Windows 7), then on a i5 2400 (Windows 10 Anniversary update) and now with an i7 4770. (Windows 10 Creators Update)

    I can play the game locked at 60 fps without a problem and without any stutter, I have another problem, you could call it "hitching" or very small jumps the game makes from time to time, some call it frame skipping, it literally looks like when you are playing an online game with lag, the classical "jumps" that the screen makes while you keep moving. My problem with the game is very similar to this:

    Now on my RivaTuner issue: The program does eliminate this hitching issue, completely and the game is very smooth in small sections, but then I get stutter with the frame limiter, small stutters. The frame decimal goes like 5999, 5980, 5960, 5970 and will keep doing this sometimes until I set the frame rate limiter to zero, then I get the hitching problem again. Tried all prerendered frames on the nVidia control panel and most other options.

    My screen is 60 Hz, confirmed with vsynctester.com so I figured 5599 would be a good number to limit the fps. And indeed it is since for all other games, does wonders for me, from Fallout 4, which eliminates the judder or "jitter" issue on this game to RainbowSix: Siege, that made the game a lot smoother and also much more easier to see stuff online. Witcher 3 does not seem to respond properly to the program.

    Can anyone help me?

    My Witcher 3.cfg looks like this right now:

    [Framerate]
    LimitDenominator=100
    Limit=5999


    RivaTuner gives me stutter on this game even at 5593, 5992, 6000, 6001 and so on. Happens at any resolution. Don't think is the fault of the program, since RivaTuner does wonders when it comes to frame time at any game.

    No problems with other games at all. Seems like a straight up driver issue. No idea.

    My PC just to show that its not a hardware limitation:

    i7 4770
    GTX 1060
    8GB RAM 1600
    EVGA 600 watt
    2x 128 GBSSD
    1x 500 GB HDD
     
    Last edited: Apr 29, 2018
  2. RealNC

    RealNC Ancient Guru

    Messages:
    3,498
    Likes Received:
    1,660
    GPU:
    EVGA GTX 980 Ti FTW
    Try to disable vsync in the in-game settings and force it to "on" in the nvidia control panel.
     
  3. SpajdrEX

    SpajdrEX AMD Vanguard

    Messages:
    2,837
    Likes Received:
    1,111
    GPU:
    Sapphire RX 6800XT
    How can you set frame limit to decimal value like 59.60 etc?
     
  4. RealNC

    RealNC Ancient Guru

    Messages:
    3,498
    Likes Received:
    1,660
    GPU:
    EVGA GTX 980 Ti FTW
    SpajdrEX likes this.

  5. SpajdrEX

    SpajdrEX AMD Vanguard

    Messages:
    2,837
    Likes Received:
    1,111
    GPU:
    Sapphire RX 6800XT
    Danke sir :)
     
  6. Smough

    Smough Master Guru

    Messages:
    639
    Likes Received:
    112
    GPU:
    GTX 1060 3GB
    Already tried that too. Not much difference. :(
     

Share This Page