Need Driver for my old AGP card. HD 3650 Sapphire...

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by rhisendark, Jun 5, 2013.

  1. rhisendark

    rhisendark Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    512 Sapphire HD3850 AGP
    i use a very old gpu thats an agp hd 3650 sapphire ddr3 512mb graphics card. latest offical driver i use is 12.3 and after that none of them is working. btw i use 32bit win7. i downloaded several legacy drivers from here but none of them are working. i can give every info you need. i need new drivers 12.3 seems buggy to me.
     
  2. m00nlighter

    m00nlighter Member

    Messages:
    45
    Likes Received:
    0
    GPU:
    HD 4670 AGP 800GPU/800MEM
    Check this thread for "stable" legacy drivers. I use AGP Hotfix v 12.3 (driver only), and ATI Tray Tools — instead of ATI's own bloatware. Never had any problems with this version — what game / app is not working as it should on your rig?
     
    Last edited: Jun 5, 2013
  3. rhisendark

    rhisendark Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    512 Sapphire HD3850 AGP
    nope. that threat is too old. i use 12.3 but i need legacy or at least latest drivers to work.
     
  4. m00nlighter

    m00nlighter Member

    Messages:
    45
    Likes Received:
    0
    GPU:
    HD 4670 AGP 800GPU/800MEM
    Well the latest working (sorta) version is 12.4 but AFAIK everyone reverted to 12.3, too many glitches in 12.4. Again, what game / app is not working as it should on your rig?
     

  5. m00nlighter

    m00nlighter Member

    Messages:
    45
    Likes Received:
    0
    GPU:
    HD 4670 AGP 800GPU/800MEM
    P.S. Running a HD 3650 AGP card with a 300W PSU - this may cause problems. What's the external power connector on your card - 6-pin or Molex?
     
  6. rhisendark

    rhisendark Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    512 Sapphire HD3850 AGP
    well i've been using it with 300watt psu for years and its connected with molex:/ i played dmc, cod, torchlight 1-2, starcraft II flawlessly. of course i tuned down some settings. but now it started to act weird... there are lots of legacy drivers in this forum but none of them are working :(
     
  7. m00nlighter

    m00nlighter Member

    Messages:
    45
    Likes Received:
    0
    GPU:
    HD 4670 AGP 800GPU/800MEM
    First of all, "started to act weird' is not a very informative description, you know. What exactly is wrong with your system?
    I'll make an educated guess ;) and say that you may have a hardware problem - with the PSU (most probable cause) or with the card itself.
    I have some time available, so here's a more or less detailed description of the above.
    PSU performance tends to degrade over time. Moreover, Sapphire recommends a 450W (AFAIR) PSU for 36xx / 46xx AGP cards - check the official Sapphire site for your card if you don't believe me.
    With an old 300W PSU, it's absolutely effing possible that the card just doesn't get enough current over the single power rail to operate normally all the time.
    If you haven't done that already, start with using two separate power rails: find a Y-shaped 2 Molex male > 1 Molex female adapter, and power your card through this adapter.
    If this doesn't help - get a decent 450W+ PSU (I'd recommend FSP or Seasonic) and see if this solves your problem.
    And finally, if I were you, and the rest of the system was stable, I'd buy a new PSU AND a new AGP card like Radeon HD 4670 AGP.

    I used to have the card you do (same model, that is) - it's good but nothing to write home about. With HD 4670 and a little bit of overclocking, I can play Crysis on medium with 40+ FPS and World of Tanks on custom with 45+fps @1280x1024x32 bit.
     
  8. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    When using the 12.11 Legacy Driver what symptoms do you experience when attempting to install the driver? Please provide an image of the bug if possible BTW the 12.11 Drivers has an installation Guide you must follow when installing the driver for Windows 8.
     
  9. rhisendark

    rhisendark Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    512 Sapphire HD3850 AGP
    it just skips the graphic driver installation, I can't install 12.11 legacy... it finishes in a second. btw I modified inf of the 12.6 driver but nothing has changed. really its just this winter I played DMC and starcraft II without anyproblems.. but now even pes 13 gets sloppy... here an image of gpu-z

    oh and i can't find ccc :/ and don't mind the name its "ATI Radeon HD 3600 Series"

    [​IMG]
     
    Last edited: Jun 6, 2013
  10. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
     

  11. rhisendark

    rhisendark Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    512 Sapphire HD3850 AGP
    I tried installing 12.11 legacy drivers I presume its yours :) and here ss and the log of installation.

    1
    [​IMG]
    2
    [​IMG]
    3
    [​IMG]
    4
    [​IMG]



     
  12. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
     
  13. rhisendark

    rhisendark Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    512 Sapphire HD3850 AGP
    selected custom install. same errors. can't select display driver in custom install because there is none. and display driver installation skips instantly.

    removed the driver through device manager and it failed to find the driver itself... says standard vga now...

    [​IMG]
     
    Last edited: Jun 6, 2013
  14. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
     
    Last edited: Jun 6, 2013
  15. rhisendark

    rhisendark Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    512 Sapphire HD3850 AGP
    downloading.. will try in a minute and report back.
     
    Last edited: Jun 6, 2013

  16. rhisendark

    rhisendark Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    512 Sapphire HD3850 AGP
    now installation completed. but no driver installation no CCC nothing. it just finishes :/

     
  17. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Do you by chance install drivers on top of each other?
     
  18. rhisendark

    rhisendark Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    512 Sapphire HD3850 AGP
    how :/ i used driver sweeper so many times. how do i fully remove all things related to the AGP card drivers?

    used driver sweeper and uninstalled then rebooted and installed but nope. still the same...



     
    Last edited: Jun 6, 2013
  19. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Before using Driver Sweeper you need to manually uninstall the driver in Control Panel. After attempting to uninstall it will ask you if you want to Express Uninstall or Custom Uninstall.

    No, it wasn't meant to do anything. I'm just preaching while I upload another driver.
     
    Last edited: Jun 6, 2013
  20. rhisendark

    rhisendark Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    512 Sapphire HD3850 AGP
    yeah I did it like that. btw I have "ATI Catalyst Legacy 12.11 B11 HotFix 4 Signed" my card is AGP not to be rude but are you sure you have support for AGP?
     

Share This Page