N.Sane Trilogy on PC suddenly started behaving weirdly

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Terepin, Nov 11, 2020.

  1. Terepin

    Terepin Master Guru

    Messages:
    756
    Likes Received:
    48
    GPU:
    MSI 2070S GAMING X
    Out of nowhere there is frame skipping, you cannot disable VSync or change frame limit. They only way to fix frame skipping is to force Fast Sync. There were no game updates, so my guess is something must have changed in drivers. Is anyone else experiencing the same issues?
     
    fluidz and BlindBison like this.
  2. BlindBison

    BlindBison Master Guru

    Messages:
    450
    Likes Received:
    73
    GPU:
    RTX 2080 Super
    @Terepin It's been sometime since I played it, but my recollection is that I got some bafflingly terrible performance on the PC version of NSane Trilogy a few months back on my rig (1440p / G-sync / 3900X / 2080S). I was sort of shocked by how poorly it performed as I wasn't able to get a 60 FPS lock even after tweaking settings.

    I'd have to boot the game up again on the latest driver and game patch to check, but I'm pretty sure I had the same issue you're describing where the game would bizarrely stutter a lot. I sorta just chalked it up to being a shoddy port.

    The only things I can think of to try would be trying to limit fps aggressively with RTSS and maybe trying to force alternate V-Sync methods or forcing V-Sync OFF in the nvidia control panel. If you've already tried that though, I'm sorry I'm not sure how to resolve the problem.

    I suppose we could check if it's driver related with a rollback -- I wonder, is this one of those games that lacks a true exclusive fullscreen mode? If so that'd explain why it's so stuttery since windowed mode forces that fast sync like triple buffering behavior.
     
  3. Terepin

    Terepin Master Guru

    Messages:
    756
    Likes Received:
    48
    GPU:
    MSI 2070S GAMING X
    But the thing is the game was fine for 2 years. But now it suddenly doesn't work properly. Changing in-game VSync settings and frame limiter does absolutely nothing. Since the game was never updated since release, I can only blame drivers for it.
     
    BlindBison likes this.
  4. Spanishgamer87

    Spanishgamer87 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Zotac RTX 3080
    I have been experiencing what you mentioned. The one thing I tried which seems to help is go to your Nvidia control panel (that is if you have an Nvidia rig), change the Low Latency mode to Ultra and also make sure you turn on Vsync driver level (leave Vsync off in game). This seems to have got rid of the issue for me.
     

  5. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,000
    Likes Received:
    76
    GPU:
    RTX 3090 ROG Strix
  6. H3llF1re2005

    H3llF1re2005 Member

    Messages:
    44
    Likes Received:
    2
    GPU:
    Titan X Pascal SLi
    Ultra Low Latency mode in the driver may help, but I found the best solution to this issue a while back: Install SpecialK into the game's directory, launch the game once (to create the dxgi.ini file) and then set SleeplessWindowThread=true in the [Render.FrameRate] section. Completely solves this issue.
     
  7. Terepin

    Terepin Master Guru

    Messages:
    756
    Likes Received:
    48
    GPU:
    MSI 2070S GAMING X
    That didn't help me. What did help me was to use NVCP frame limiter. Even RTSS was no good.
    All of them I assume. I tried 430.00 and still had it.
     

Share This Page