Multimonitor 144Hz / 60Hz stutter problem

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by _cTn_, Oct 15, 2015.

  1. DAOWAce

    DAOWAce Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    GTX 1080 Ti
    From my testing (on Win7), that just worsens the problem, makes refreshes slower and causes DWM to eat tons of memory. You need two dedicated GPUs each being accelerated, like this: http://i.imgur.com/4zjEeM5.png

    Again, I only have experience with Win7, so this might not apply to 8/8.1/10. (I'll probably only try 10 after it's less beta status.. 10.1 anyone?)

    And, does setting the game to windowed or borderless with your desktop at 120Hz really not work? That should override anything the game sets, unless it literally forces your resolution/refresh rate to max on startup.
     
  2. dabrooks

    dabrooks Master Guru

    Messages:
    351
    Likes Received:
    0
    GPU:
    SLI EVGA GTX 980Ti Gaming
    So no SLI. Why would you run that way?
     
  3. DAOWAce

    DAOWAce Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    GTX 1080 Ti
    I SLI when I play a game that requires the performance.. or when I try to play something that's developed poorly and doesn't constrain the cursor in fullscreen.
     
  4. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,849
    Likes Received:
    244
    GPU:
    EVGA GTX 1080Ti SC
    You're basing that on mere conjecture. The Windows compositor, in certain cases, does bug out when running multiple monitors at different refresh rates and I've faced the issue myself running the Qnix at 110Hz with other 60Hz displays in extended mode.

    It would make sense for the stutter to be fixed once he runs the primary at 120Hz since 120Hz is an integer multiple of 60Hz and any compositing going on at 60Hz / 120Hz would not cause any issues.
     

  5. dabrooks

    dabrooks Master Guru

    Messages:
    351
    Likes Received:
    0
    GPU:
    SLI EVGA GTX 980Ti Gaming
    And yet others of us have NEVER experienced this issue.
    Now it doesn't make sense.
     
  6. beseitfia

    beseitfia Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    SLI x2 MSI Gtx980 Gaming
    i have noticed something..If i set gsync on and v sync off (or application controlled but off ingame) and monitors are extended i get 2fps if i launch battlefield 4 in loading screen and is unplayable..If i disable gsync, or let gsync on but enable vsync, the stutters goes away and plays smooth..
     
  7. _cTn_

    _cTn_ Master Guru

    Messages:
    571
    Likes Received:
    0
    GPU:
    ASUS STRIX 980TI
    Finally someone that encountered the exact same issues as i do.
    Exactly: multi monitor with different refresh rate while using extended desktop = kaboom, as you mentioned, when one screen is running at 120Hz and second one at 60Hz it really eliminates the issue (well more or less eliminates it).
    Sadly the game i am running (Trove) still seems to have problems even when i use it as borderless, in full screen it defaults to 144Hz and windowed mode, well i don't wanna play my game in a window :/
     
  8. Baldassano

    Baldassano Member Guru

    Messages:
    169
    Likes Received:
    7
    GPU:
    2x MSI 1080ti SHWK
    I have had this issue.. Running SLI 980s 1 144hz 27" and 1 60hz 24".. Only true solution is to make both 144hz screens has fixed it 100%.. It seems the edge of screen #2 bleeds into screen #1, so if a window is close to its edge, it drops the frame rate of monitor #1. I had this for over 2 years. Now that there both 144, buttery smooth on both monitors and not 1 issue.
     
  9. DAOWAce

    DAOWAce Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    GTX 1080 Ti
  10. Zl4T

    Zl4T Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Hey guys,

    I signed in this forum especially for this thread (english isn't even my native).

    So i have exactly the SAME issue than the author.

    I have an Asus VG248QE 144hz as main monitor on an asus classic 60 hz 24" monitor as secondary.

    And when i play some video content on my second screen or anything that need a "refresh" like teamspeak or some performances graphs my main monitor seem to switch on 60hz or maybe lower ... It causes crappy stuttering and lags.

    It's mainly hapenning when i'm playing some games like hearthstone but i even can feel it in CS:GO or Rust ... (full screen games)

    So the only issue that i found yet is to minimize my windows as much as possible but ofc every multiple screen users knows that it's not what they pay for.

    So i saw that nobody replied on this subject since 2 months, did anybody found a fix ?

    Regards,

    Zl4T
     

  11. _cTn_

    _cTn_ Master Guru

    Messages:
    571
    Likes Received:
    0
    GPU:
    ASUS STRIX 980TI
    Hi Zl4T, sadly i haven't found a solution :( the "best" thing you could do is to run game in full screen (not full screen borderless), this seems to help a bit, but its still far from perfect :(
     
  12. Denial

    Denial Ancient Guru

    Messages:
    13,357
    Likes Received:
    2,860
    GPU:
    EVGA RTX 3080
    I also have this problem. It started with some driver like 3-4 months ago (may have even been a windows build). If I have R6 Siege minimized on my main monitor or in windowed mode, windows on my secondary monitor tear/stutter as they are moved or refreshed.

    It doesn't bother me too much but it definitely didn't use to happen.

    I run 2x Dell u2715, 1x XB270HU and 1 Samsung 48" 8500 series. So 3 60hz displays and 1 144hz display, the XB has G-Sync enabled, seems to happen regardless to whether G-Sync is full screen or windowed enabled.
     
  13. Zl4T

    Zl4T Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Thanks for your replies.

    I'm currently in relation with nvidia USA support.

    I'll post here if i have some news.

    If the problem isn't fixed i'll probably sell my second monitor and buy a new 144hz cause i really didn't paid to see those crappy 60hz on my smoothie asus vg248 ...
     
  14. Zl4T

    Zl4T Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Just a question guys, have you tried to do a windows clean install ?

    Just in case the issue would be due to a ****ty driver hidden somewhere ?
     
  15. Zl4T

    Zl4T Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Hey guys,

    My ticket has just been escalated :

    Hope they will find something, I will keep you informed.

    Regards,

    Zl4T
     

  16. Geicher

    Geicher Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    4x4GB DDR4
    Same issue here aswell running an Acer 144hz panel in combination with a 60hz.

    The issue has been around since I got my 144 hz screen. (Probably around 10 months)

    My setup:
    5820k
    SLI 980
    Win 10 x64
    16 GB DDR4
     
  17. Zl4T

    Zl4T Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Sometimes i'm wondering if i haven't made a mistake during the assembly of my pc ^^

    I don't think cause i built 3 pc recently for friends who all have a 144hz/60hz setup and they have no issue but i'm still wondering ...
     
  18. RealNC

    RealNC Ancient Guru

    Messages:
    3,379
    Likes Received:
    1,576
    GPU:
    EVGA GTX 980 Ti FTW
    No fix, but a workaround if all else fails: use CRU (custom resolution utility) to make the 120Hz mode (or another mode you want) the primary one so that everything defaults to that instead of to 144Hz.

    Still not guaranteed to work, but worth a try.
     
  19. Zl4T

    Zl4T Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Hi,

    Thanks for your reply, do you have a good tutorial for CRU ?
     
  20. RealNC

    RealNC Ancient Guru

    Messages:
    3,379
    Likes Received:
    1,576
    GPU:
    EVGA GTX 980 Ti FTW
    You just run it, select the resolution/mode you want to be the primary one, and click the "up" icon until it's first on the list, then click "OK".

    You then simply reboot or just run the "restart64.exe" to apply the changes (if you're on 64-bit Windows).
     
    Last edited: Dec 30, 2015

Share This Page