Multimonitor 144Hz / 60Hz stutter problem

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by _cTn_, Oct 15, 2015.

  1. _cTn_

    _cTn_ Master Guru

    Messages:
    571
    Likes Received:
    0
    GPU:
    ASUS STRIX 980TI
    Hi guys, i am guessing that when you run the primary monitor on 144Hz and something is rendering/updating on the secondary lcd which is 60Hz, the primary monitor stutters quite a bit.

    The way i went around this problem so far, i set the primary monitor to 120Hz on desktop, and usually the games default to this settings, which runs reasonably well.

    But the problem that i am facing right now is that the game that i am playing doesn't have frequency setting in options and it default to 144Hz, which leaves everything stuttering.

    Do you guys have any idea how could i tackle this problem?

    Basically i run the game on the primary LCD and the secondary screen is usually used for chat and OBS preview window (which is updating at about 30fps).

    Thanks for any ideas you guys might have.
     
  2. DAOWAce

    DAOWAce Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    GTX 1080 Ti
    Assuming you're using Vista/7:

    Set the game to windowed/borderless?

    Disable DWM (Aero)?

    Get 2 GPUs and run each display off its own GPU?

    Upgrade to 8/8.1/10 which doesn't use Aero so multi-monitor usage isn't abysmal anymore?


    I've had nothing but pain using multi-monitors on Vista/7 (or even straight Windowed mode, compared to XP). As much as I want to use 8/10 for its performance improvements and Aero removal, I can't subject myself to its awful UI (and numerous other issues, especially with 10). I went SLI to try and workaround the issue, but I still have performance degradation in multiple applications regardless of anything I do. Disabling Aero stops the sluggishness, but it also removes vsync and makes the windows ugly; the former being completely unacceptable.

    If only companies didn't decide to do pointless UI revamps every 'major' release of their software..

    Times like this make me wish I could go back to XP; identical fullscreen/windowed performance and hardware audio.. *sigh*
     
  3. _cTn_

    _cTn_ Master Guru

    Messages:
    571
    Likes Received:
    0
    GPU:
    ASUS STRIX 980TI
    Thanks for the suggestion man, i am on Win10 x64, i actually tried to usu 2 gpus, one gpu for each monitor, it didn't help, (that was gtx 760 for the main lcd, and the gpu integrated into the cpu for the second 60 hz lcd), didn't help.

    I know that its not a performance problem, as long something renders on the second screen (may it be a simple taskbar animation) or literally anything that is animating, will make the main screen stutter.

    I can say that the problem isn't as terrible on win10 as it was on win7, but its still awful, the only way i was able to fight it was using the 120hz on the main lcd instead of 144, that seemed to work really well on the desktop and even in games, but when it comes to this game, which doesn't have frequency settings its awful, i can have it in full screen, or windowed/borderless, it stutters like nuts.
    When i remove anything that is being refreshed on the second screen, everything becomes buttery smooth :/
     
  4. bishi

    bishi Master Guru

    Messages:
    560
    Likes Received:
    10
    GPU:
    GTX 1080 SLI
    Does this happen only when the window on the second monitor is full screen? Also check with a maximised window no pixels are getting rendered on the other screen, sometimes don't quite spam the monitor they are on properly and can cause rendering issues.
     

  5. _cTn_

    _cTn_ Master Guru

    Messages:
    571
    Likes Received:
    0
    GPU:
    ASUS STRIX 980TI
    Nope, It happens at all times as long there is something being updated on the second monitor, being that a window in full screen, small window, or no window at all.
    You know the orange "breathing" animation you see in the taskbar (on win10) when certain app requires your attention?
    Even that is enough to trigger the stuttering.
    In other words, as long the content that's being rendered on the second screen is static, things run just fine, if anything starts animating, being that a text in a browser or anything else, kaboom :(
     
  6. dabrooks

    dabrooks Master Guru

    Messages:
    351
    Likes Received:
    0
    GPU:
    SLI EVGA GTX 980Ti Gaming
    I have been running a 144Hz primary and 60Hz secondary for quite some time and have never experienced what you are reporting. I always have windows open on the secondary monitor, I launch Steam games from there, for example. I run any game that will allow it at 144Hz on the primary display.
     
  7. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,183
    Likes Received:
    165
    GPU:
    MSI RTX 2080
  8. GPUSMUG

    GPUSMUG Active Member

    Messages:
    54
    Likes Received:
    0
    GPU:
    980 Ti SLI
    I can't stand that you can't run the second monitor off a second GPU in SLI. I could have sworn we were able to in the past. Might have to get a cheapo 750.
     
  9. _cTn_

    _cTn_ Master Guru

    Messages:
    571
    Likes Received:
    0
    GPU:
    ASUS STRIX 980TI
    Interesting, i guess you are one of the lucky ones.
    When it comes to my problem, i think i am gonna look around to see if i could hide the 144Hz mode, so the game just defaults to 120Hz and be done with it :/
     
  10. beseitfia

    beseitfia Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    SLI x2 MSI Gtx980 Gaming
    I have the exactly same problem as you described...An Asus Rog Swift 144hz 1440p with g sync enabled and an IPS PB278QR 60hz 1440p in extended mode. If i play in single screen on the ROG it's smooyh as butter, but if i play with extended mode with the Swift as primary display, i have to take care to idle the second one, even if open gpu z on second monitor i stutter badly in a game....It's seems by the way that is gsync related, because if i play at 144hz without gsync i can do a lot of things on second screen without stutter..Do you have a g sync monitor dude?
     

  11. _cTn_

    _cTn_ Master Guru

    Messages:
    571
    Likes Received:
    0
    GPU:
    ASUS STRIX 980TI
    Nope, well, i have the version of Asus VG248QE that is without the g-sync module.
     
  12. dabrooks

    dabrooks Master Guru

    Messages:
    351
    Likes Received:
    0
    GPU:
    SLI EVGA GTX 980Ti Gaming
    I have the Rog Swift, second monitor is a 4k Asus. Yes, G-SYNC is enabled. Can't imagine what the difference is, why I have no issues and you both do. I do have a triple monitor setup, though all games are played on my primary, the 1440p 144Hz Rog Swift.
     
  13. beseitfia

    beseitfia Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    SLI x2 MSI Gtx980 Gaming
    I dont's know maybe it's a sort of bad setting, or software related ...I'm pretty sure that the monitors are perfectly working alone, so i guess it's not an hardware issue...But if u go to nvidia forum you can find a lot of threads about this problem...I am on windows 10 x64 and never tried this setup with my previous os (8.1), are you guys running same os?
     
  14. dabrooks

    dabrooks Master Guru

    Messages:
    351
    Likes Received:
    0
    GPU:
    SLI EVGA GTX 980Ti Gaming
    I've had the same setup on both 8.1 and Win10 x64.
     
  15. beseitfia

    beseitfia Active Member

    Messages:
    79
    Likes Received:
    0
    GPU:
    SLI x2 MSI Gtx980 Gaming
    Can you tell us your nvidia control panel settings please? You have vsync off ? Do you cap your fps with riva tuner/nspector? I ve heard that geforce experience also may cause the issue (shadowplay) i don't know it's really weird
     

  16. Cyberdyne

    Cyberdyne Ancient Guru

    Messages:
    3,581
    Likes Received:
    297
    GPU:
    2080 Ti FTW3 Ultra
    I think OP is misdiagnosing his issue. Is makes absolutely no sense that having a 144hz primary monitor with a 60hz secondary would have stuttering ingame... which he claims is fixed by running the primary at 120hz.
     
  17. dabrooks

    dabrooks Master Guru

    Messages:
    351
    Likes Received:
    0
    GPU:
    SLI EVGA GTX 980Ti Gaming
    Vsync uses the application's settings. I have MSI Afterburner installed for on-screen display capabilities but that's it. Everything else is vanilla. ShadowPlay is off.
     
  18. SemperFi1981

    SemperFi1981 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX 970
    Similar issues here, main screen is 144hz gsync (Acer XB240HA), 2nd screen is 60hz (HP LP2475w).

    I figured ShadowPlay was responsible for making my 2nd screen stutter like crazy... when I turn off SP I behaves as expected.

    I do encounter other problems as well; I lose video signal on both screens when gaming after X amount of time - have not figured out yet what's causing it; suspect is has something to do with gsync, since SP is off here for now...
     
  19. Margusx

    Margusx Active Member

    Messages:
    52
    Likes Received:
    0
    GPU:
    Msi GTX970 gaming 4g
    If 120Hz is native you never get 60Hz smooth i have same problem, If windows think native is 120 then 60 run bad. Its probably weird issue.
    Even vga or hdmi DP run bad because not native. these all 60Hz.

    If someone know way how to fix it i super happy,
     
    Last edited: Oct 17, 2015
  20. _cTn_

    _cTn_ Master Guru

    Messages:
    571
    Likes Received:
    0
    GPU:
    ASUS STRIX 980TI
    Ok, since we are having really mixed results in this thread, let me try some unconventional.

    Any of you guys tried http://testufo.com/#test=framerates on the primary (high frequency lcd)?
    Have you noticed what happened to the test when something ends up animating on the second (low frequency lcd) ?

    Please keep in mind that i don't really have any actual "evidence" or benchmark that would demonstrate the problem.

    For example, if i play BF4, at 144hz and i am running OBS on my second screen (in a window) the game just stutters, its definitely not smooth, setting the frequency in BF4 to 120hz magically fixes the stuttering.
     
    Last edited: Oct 17, 2015

Share This Page