MSI Afterburner hotkey startup issue - fixed

Discussion in 'MSI AfterBurner Application Development Forum' started by Chrysalis, Apr 2, 2021.

  1. Chrysalis

    Chrysalis Master Guru

    Messages:
    217
    Likes Received:
    23
    GPU:
    RTX 3080 FE
    Hi

    I recognise the way the last time I posted this was done the wrong way so I will post a summary of my issue and what I did to fix it. If its a thought that this is unique to my system I am happy to provide information on my system.

    So a summary is that with afterburner 4.6.3.16053 on a windows reboot, afterburner will fail to respond to the OSD hotkey.
    However if I close and relaunch afterburner it works absolutely fine until the next reboot.

    I today started debugging the problem, and have it now behaving on my system, since afterburner rewrites the task in task scheduler everytime its fired up these are the steps I did.

    1 - Disable run on startup in the afterburner settings, this prevents the startup task from starting afterburner, I discovered specifically this prevents it from been started with the /s switch.
    2 - Duplicated the task, and on the duplicate task I removed the /s switch, and made one simple change to the startup trigger.
    3 - Startup trigger I set delay task by 1 minute (on the run on logon of any user).

    This solved the issue, it seems its related to it starting too early.
     
  2. Andy_K

    Andy_K Master Guru

    Messages:
    596
    Likes Received:
    103
    GPU:
    MSI GTX 960 OC
    Seems like something else which is started after Afterburner is "stealing" hotkey hook and when you start Afterburner later that app has already made it's hook and MSI AB can then add it's hook to the chain.

    So you didn't fix the problem by identifying the causing app but you worked around it.
     
  3. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,351
    Likes Received:
    2,629
    You don't need to delay startup this tricky way, there is native StartupDelay fileld (value in milliseconds) in MSIAfterburner.cfg.
     
    Chrysalis and EdKiefer like this.
  4. Chrysalis

    Chrysalis Master Guru

    Messages:
    217
    Likes Received:
    23
    GPU:
    RTX 3080 FE
    I cant think of what app it would be sadly. The OS was only clean installed not long ago, and the other startup apps are the following.

    Onedrive.
    7+ taskbar tweaker
    c-media panel (soundcard)
    Telegram
    Winnut
    Nettime
    Windows Firewall Control
    Sandboxie

    None of these use the hotkey I assign, I tried different hot keys, so yes sadly this is the solution I had to adopt. I do agree though there is something going on locally on this machine, and will try to investigate more when I can.

    I will now change to using the official startup delay feature Unwinder has mentioned, it is good it has that feature, thanks.
     

  5. gedo

    gedo Master Guru

    Messages:
    300
    Likes Received:
    38
    GPU:
    RX 570 4GB
    Knowing what your hotkey actually is would help in offering suggestions on what application might be using the same...
     

Share This Page