MSI afterburner bug report & suggestion

Discussion in 'MSI AfterBurner Application Development Forum' started by msi-afterburner, Oct 1, 2009.

Thread Status:
Not open for further replies.
  1. herpaderpa

    herpaderpa Member

    Messages:
    43
    Likes Received:
    0
    GPU:
    AMD
    ADLODNPerformanceLevelX2
    int iClock;
    int iVddc;
    int iEnabled;
    int XXX?;
     
  2. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,690
    Likes Received:
    3,150
    That XXX is a bitmask validating the rest fields of each performance level.
     
  3. Ancymon

    Ancymon Active Member

    Messages:
    81
    Likes Received:
    23
    GPU:
    GTX 1070
    It's possible to add setting for length [in pixels] of RTSS frametime graph?
     
  4. WhiskeyOmega

    WhiskeyOmega Master Guru

    Messages:
    282
    Likes Received:
    25
    GPU:
    RTX 3090 MSI GXT
    Cant seem to get the OSD to work with theHunter Call of the wild's Apex Engine no screenshots no OSD and no video. they come out blank.
     

  5. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,690
    Likes Received:
    3,150
    Confirmed. Create theHunterCotW_F.exe.cfg file in .\ProfileTemplates subfolder in RTSS installation folder with the following contents:

    Code:
    [RendererDirect3D10]
    Enable = 0
    
    Built-in profile for it will be available in the next version.
     
  6. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,690
    Likes Received:
    3,150
    It can be edited in .cfg, negative value (-32 by default) specify width in symbols (so it resized with scaling the text size), positive value specify width in pixels.
     
  7. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,518
    Likes Received:
    2,912
    GPU:
    MSI 6800 "Vanilla"
    Interesting, could have sworn I used Afterburner with TheHunter a few months ago but they do periodically update the game and disabling the D3D10 compatibility option via RivaTuner's profile settings shouldn't really have any problems, bit curious what they might have changed though but that doesn't really matter. :)

    EDIT: Huh it does load, probably down to me using windowed borderless mode.

    (But it's good to see it fixed for people who are affected by the OSD not loading of course.)


    EDIT: Should be the same (But a newer version.) engine also featured in Just Cause 3 (And Mad Max before that.) so you get windowed and fullscreen options and the "/borderless" parameter can be used to modify the windowed mode behavior.

    Though windowed and borderless display mode can have shortcomings compared to exclusive fullscreen far as I know, SLI and Crossfire can be one thing as can free and G sync display modes I believe.
    (You don't really want to give up either of those or have to tinker around with compatibility settings.)

    But that's going a bit off topic, not too much to say but nice work fixing the AMD 17.7.2 (And newer I guess?) driver compatibility with b15 of Afterburner. :)

    Nice to see a Vega GPU already being shipped over too, going by recent rumors general availability might be a bit low if it really is that effective with mining heh but at least Afterburner should be able to offer support for the GPU.
     
    Last edited: Aug 4, 2017
  8. Ancymon

    Ancymon Active Member

    Messages:
    81
    Likes Received:
    23
    GPU:
    GTX 1070

    Thanks, Unwinder, it works.
     
  9. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,690
    Likes Received:
    3,150
    You're on AMD GPU, and the profile is specific to NVIDIA GameWorks effects rendered exclusively on NV hardware. In this case D3D11 (game renderer) and D3D10 (GameWorks interop) devices coexist during the game runtime and confuse OSD renderer. The profile is disabling OSD for that helper D3D10 device.
     
  10. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,518
    Likes Received:
    2,912
    GPU:
    MSI 6800 "Vanilla"
    Oh I remember that being used for a few other games now that you mention it, the game actually uses Gameworks?

    Yep it does, I completely missed the pretty obvious CUDA helper dll right there in the game folder. cudart64_55.dll

    Which seems to be for the water effects via gfsdk_waveworks.win64.dll

    Interesting, I know that was a big touted feature in Just Cause 2 (EDIT: A older version of it.) but I had no idea it was still in the game engine, that explains it. :)
    (TXAA and HBAO have wider implementation, waveworks I don't think has been used that much though missing the cuda dll was a oversight though I guess GFSDK should have been obvious too really.)


    Thanks for the explanation too, been wondering why that actually worked. :)
    (One of the earlier Batman games I think it was? Probably a number of GeForce Gameworks games with Rivatuner profiles if I were to open them up.)


    EDIT: And while some Gameworks effects do work on AMD CUDA definitively does not so it wouldn't even be initialized. (TXAA, hardware PhysX such as fluid simulation if I remember correctly and this wave effect.)
     
    Last edited: Aug 5, 2017

  11. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,690
    Likes Received:
    3,150
    Are you sure that it is specific to new driver? Overdrive5 and Overdrive6 FanSpeed_Get implementation was deadly ineffective and causing stuttering on "fan stop" feature enabled graphics cards, basically they treated 0 RPM as failure and tried to re-read it a few time in a loop causing stutter. On such systems in can be easily fixed by forcing non-zero fan speed. But it was so for ages, since Fiji launch as far as I remember.
     
  12. DaRkL3AD3R

    DaRkL3AD3R Active Member

    Messages:
    51
    Likes Received:
    8
    GPU:
    GTX 1080 Ti STRIX OC
    4.4.0 beta 15. I'm seeing weird issue with fan controller hysteresis. My fan curve is 0% until 35c, then jump to 30% and climb up from there. I use a 1000ms update period and 5c hysteresis.

    In older versions (beta even) this would result in fans turning on at 35c then staying on even if it drops down to 34-30c. At 29c they would then turn off.

    Now on 4.4.0 beta it sometimes glitches and shuts the fans off at 34c. It doesn't happen all the time. In addition to this, fan speed does not update every 1000ms like I have it set to. It will stick to certain fan speeds despite supposed to be changing every 1 second.

    Last issue. When "Force fan speed update on each period" is enabled, hysteresis doesn't work at all. I'm not sure if that's intended.

    Thanks
     
  13. SickBeast

    SickBeast New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    GTX 1070 SLI
    Hey @Unwinder have you looked into the voltage adjustment for mGPU setups? I have found that I can only adjust the voltage on my primary GTX 1070 card, it has no effect on the secondary card. If you are working on this in a new version I would be willing to beta test it, please send me a PM if you have a new version with this feature. Thanks!
     
  14. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,690
    Likes Received:
    3,150
    I'm not working in it because it is understanding issue, sorry.
     
  15. ivanosky

    ivanosky Active Member

    Messages:
    90
    Likes Received:
    15
    GPU:
    NVIDIA GTX 960M
    Hi, I would like to report a bug. I´m using Afterburner on a NVIDIA Optimus Laptop. Every single beta after Afterburner 4.4.0 beta 7, does not show any monitoring for the NVIDIA GPU Usage. The beta 7 works perfectly.
     

  16. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,690
    Likes Received:
    3,150
    That's undersranding ussue as well. Examine beta 8 changes list, especially the part in bold text and check contents of profiles you're applying.
     
  17. BahamutxD

    BahamutxD Master Guru

    Messages:
    268
    Likes Received:
    15
    GPU:
    MSI 1080 GamingX
  18. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,690
    Likes Received:
    3,150
    Seriously, I'd love to see users able to search.
     
  19. Ancymon

    Ancymon Active Member

    Messages:
    81
    Likes Received:
    23
    GPU:
    GTX 1070
    About wrong CPU [Intel i5 3570k] clocks values, I have this situation:

    [​IMG]
    Link to image: http://i.imgur.com/MZBAsNO.png

    MSI Ab 4.4.0 Beta 12 was the last ok, it started with Beta 14 and it occurs in 15 & 16.



    Edit:

    Screen from Beta 12 for proof:

    [​IMG]
    Link to image: http://i.imgur.com/FlO3ngW.png
     
    Last edited: Aug 6, 2017
  20. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,690
    Likes Received:
    3,150
    The same for you, learn to search PLEASE. How many dozens times do I have to repeat that any CPU related monitoring is provuded under no support obligations?
     
Thread Status:
Not open for further replies.

Share This Page