MSI Afterburner 2.2.5 (2012-10-31)

Discussion in 'MSI AfterBurner Overclock Application Discussion' started by msi-afterburner, Oct 31, 2012.

  1. msi-afterburner

    msi-afterburner Master Guru

    Messages:
    414
    Likes Received:
    0
    GPU:
    MSI N275GTX Lightning
    Hi guys, the Afterburner 2.2.5 official version is ready for you to download. this version supports the control of South Island and Kepler card, if you get the card, you may try to play it.

    Changes list includes:

    • Added new graphics cards support.

    Download:
    http://www.guru3d.com/files_details/afterburner_download_msi.html
     
  2. Eluder

    Eluder Member

    Messages:
    41
    Likes Received:
    0
    GPU:
    MSI GTX 680 Lightning
    Downloaded and it comes up as Beta 1 of 2.2.5, if this expected or is the wrong file posted?
     
  3. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,953
    Likes Received:
    41
    Small not on this release: it is still an old good 2.2.3 binaries with altered database to add support for new MSI cards like 660 Hawk series. So there is zero need to upgrade if you don't own it.
     
  4. fgw

    fgw Member Guru

    Messages:
    115
    Likes Received:
    0
    GPU:
    MSI N680GTX Lightning
    should'n we expect 2.3.0?

    will this update indicate a delay of 2.3.0?
     

  5. heroxoot

    heroxoot Master Guru

    Messages:
    440
    Likes Received:
    0
    GPU:
    MSI R9 290X Gaming
    I have massive flickering on my 7970 when using either unofficial OC mode on windows 8. I'm pretty sure its the dlls to extend the clocks. Is there any fix for that?
     
  6. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,953
    Likes Received:
    41
    Stop spamming the same in different threads and start reading.
     
  7. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,953
    Likes Received:
    41
    Nope, 2.3.0 is not delayed and it is in closed beta testing stage. In meanwhile MSI just decided to launch intermediate 2.2.5 version to provide support for 660 Hawk.
     
    Last edited: Oct 31, 2012
  8. CyberDemonVZ

    CyberDemonVZ Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    MSI N570GTX M2D12D5
    Is it a bug, or is it just my PC?
    I keep getting "v2.2.5 is available for download", but i've installed it.
     
  9. Xzibit

    Xzibit Banned

    Messages:
    4,383
    Likes Received:
    0
    GPU:
    7970 Windforce
    Thanks. What about VRAM counter on Windows 8?
     
  10. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,953
    Likes Received:
    41
    Read above, it is renamed old 2.2.3 binaries, it has no new code, just new database entries for 660 Hawk. Don't expect new features from it.
     

  11. Xzibit

    Xzibit Banned

    Messages:
    4,383
    Likes Received:
    0
    GPU:
    7970 Windforce
    I saw that. So no W8 support soon?
     
  12. -Tj-

    -Tj- Ancient Guru

    Messages:
    13,865
    Likes Received:
    8
    GPU:
    ZOTAC GX980Ti Amp!Extreme
    So v2.2.4 is also with old binaries from v2.2.3?
     
  13. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,953
    Likes Received:
    41
    Yes, and I declared it in the forum.
     
  14. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,953
    Likes Received:
    41
    In this version - no of course.
     
  15. Xzibit

    Xzibit Banned

    Messages:
    4,383
    Likes Received:
    0
    GPU:
    7970 Windforce
    When? :eyebrows:
     

  16. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,953
    Likes Received:
    41
    Videomemory usage monitoring for AMD cards in Win 8 will be available in 2.3.0 a bit later
     
  17. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    14,932
    Likes Received:
    4
    GPU:
    EVGA GTX 1080 Ti SC2
    I keep being prompted to download the v2.2.5 update when I already have v2.2.5 beta 1 installed from the original link Afterburner pointed me to earlier on yesterday. At first I thought it was an update to a non-beta build but if I download and install it again from the same link then it still shows as v2.2.5 beta 1! I'm using Windows 8 Pro.

    /is confused
     
  18. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,953
    Likes Received:
    41
    MSI didn't sync version info / update server properly
     
  19. msi-afterburner

    msi-afterburner Master Guru

    Messages:
    414
    Likes Received:
    0
    GPU:
    MSI N275GTX Lightning
    Sorry, The Afterburner 2.2.5 can correct push update form server now. Thanks
     
  20. izikog

    izikog Maha Guru

    Messages:
    1,126
    Likes Received:
    0
    GPU:
    Sapphire 6950@70 910/1400
    flickering 2d

    With amd 12.10 and this version of AB I get big 2d flickering... in 3d no issues... interesting if FAH is running no 2d flickering
     

Share This Page