Msi 5450 bios

Discussion in 'Videocards - AMD Radeon' started by AZkiller7, May 9, 2012.

  1. AZkiller7

    AZkiller7 Active Member

    Messages:
    50
    Likes Received:
    0
    GPU:
    MSI 280x gaming
    HI,
    My second PC is equipped with a MSI 5450 400mhz core which I recently flashed it with a bios of the 650mhz core version, the video card is unbootable at the moment. I don't seem to find the right bios for it either in MSI website or any other website containing vga bios's.
    Can somebody send me the bios file via e-mail or something?
    I've even contacted MSI customer support and I got one of the funniest replies:

    " Sorry, we don’t have the BIOS here and this will require you to send the card in under a RMA.


    Please kindly submit a RMA request here, thank you.

    http://service.msicomputer.com/msi_user/rma_form_new.aspx


    Sincerely,

    MSI Technical Support Team "

    LOL "we don’t have the BIOS here..." Like if an alien installed it on their chips.
     
  2. killer_939

    killer_939 Ancient Guru

    Messages:
    2,598
    Likes Received:
    0
    GPU:
    Radeon 7950 @ 1100/1500
    Did you check the card ran at that speed before you flashed it? Also why would you flash it if you can just use overclocking software? I believe flashing software and gpu-z can back up bioses and it is highly recommended to do so before flashing a new one on your card, if it doesn't work you can then use another card to boot the PC and flash the bad card back that way.

    As for getting it working again, did the version of the card you flashed it to have different ram (ddr2 vs gddr3)? If so you might be able to grab a bios from here with matching ram type, edit the speeds as you want in a bios editor and flash it to the card.
    http://www.techpowerup.com/vgabios/...ufacturer=&model=HD+5450&interface=&memSize=0

    Good luck.
     
    Last edited: May 9, 2012
  3. zavulon

    zavulon New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Sapphire 4730 512 MB
  4. AZkiller7

    AZkiller7 Active Member

    Messages:
    50
    Likes Received:
    0
    GPU:
    MSI 280x gaming
    My card is MSI 5450 1gb DDR3.
    The BIOS I tried was from "techpowerup" MSI, which didn't work, even the flashing procedure didn't go successful cause the MSI BIOS listed there is about 128kb, then I tried Sapphire one, about 58kb or something. The card flashed just fine but still nonfunctional. Please note that I even edited the BIOS file settings to match the previous default clock speeds, still no luck. Probably due to different memory brands ( Hynix, Samsung, Qimonda ....) IDK.
    That's why I need somebody in here with the exact same card to dump the BIOS with GPU-Z and send it to me if possible.
     

  5. AZkiller7

    AZkiller7 Active Member

    Messages:
    50
    Likes Received:
    0
    GPU:
    MSI 280x gaming

Share This Page