Motheboard upgrade -> HD no longer recognised

Discussion in 'SSD and HDD storage' started by Craigfanman, Dec 21, 2013.

  1. Craigfanman

    Craigfanman Member

    Messages:
    45
    Likes Received:
    0
    Hi. I just upgraded my PC with a new motherboard, cpu, gfx card and an SSD. All the new components booted up fine, but when I try and attach my old HD (standard sata 1tb) it is not recognised and makes a horrible clicking noise. I thought the drive was dead but I put it in another PC and it loads up fine all the files are there and readable. So worst case scenario I can use that to retrieve all the data from it, but I wonder why it does not work in my new PC setup? If anyone's got any ideas that would be appreciated thanks.
     
  2. clawhamer

    clawhamer Ancient Guru

    Messages:
    2,579
    Likes Received:
    0
    Check your bios to see it is being detected during post, if it isn't, ensure your sata port that it's connected to is enabled.

    Could also try a different sata port, sata and power cable.
     
  3. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    17,742
    Likes Received:
    4
    Same thing happened with my Brothers HDD after new X87 mobo upgrade, wasn't even recognised in the BIOS

    Had to put the HDD into an older machine where it worked and update the HDD firmware

    After that it worked fine with the new board
     

Share This Page