monitoring windows and linux clients

Discussion in 'Folding@Home - Join Team Guru3D !' started by sverek, Nov 6, 2012.

  1. sverek

    sverek Ancient Guru

    Messages:
    6,073
    Likes Received:
    2,953
    GPU:
    NOVIDIA -0.5GB
    Good day! After failing for 3 times setting linux (minimum CentOS) fah client, I finally got it working today. :banana:

    I'd like to share problems I had during setup and solutions for it.

    My goal was to setup folding on linux machine via terminal and connect/control all folding machines clients within lan to my main pc.

    current setup:
    local (daily usage pc) : Windows client - 2 GPUs : 6870 + 5770 (fed by 2500k)
    Sharon : Windows Client - SMP : Core2Duo E8400
    linux : CentOS 6.3 - SMP : Core2Duo E7200

    [​IMG]

    1st problem I hit on running fah on linux is connecting to fah servers, console error below :
    Code:
    WARNING:WU00:FS00:Failed to get assignment from 'assign4.stanford.edu:80': Could not get IP address for assign4.stanford.edu: Temporary failure in name resolution
    I got it solved by editing /etc/resolv.conf , which is apparently responsible for DNS stuff:
    added 2 lines :
    nameserver 8.8.8.8
    nameserver 8.8.4.4

    Code:
    # Generated by NetworkManager
    
    nameserver 8.8.8.8 # added
    nameserver 8.8.4.4 # added
    search local
    
    
    # No nameservers found; try putting DNS servers into your
    # ifcfg files in /etc/sysconfig/network-scripts like so:
    #
    # DNS1=xxx.xxx.xxx.xxx
    # DNS2=xxx.xxx.xxx.xxx
    # DOMAIN=lab.foo.com bar.foo.com
    After adding this 2 lines, fah client successfully fetched WU from FAH server.
    However, on system restart it went back to default, edit your eth0 (/etc/sysconfig/network-scripts/ifcfg-eth0) or whatever by adding this line:
    Code:
    NM_CONTROLLED="no"
    this will disable networkManager(wireless connector?), that keeps rewriting our script.

    2nd problem I run into is allowing access for windows machine to control linux fah client.

    It was rather easy task by adding this 2 lines into /etc/fahclient/config.xml

    <command-allow v='127.0.0.1,network.ip.to.allow'/>
    <command-allow-no-pass v='127.0.0.1,network.ip.to.allow'/>

    where 127.0.0.1 is localhost, so we can control FAHClient from linux machine and 'network.ip.to.allow' is ip to machine that will control linux's FAHClient. (in my case windows machine)

    Code:
    ....
      <smp value="true"/>       <!-- If true, attempt to autoconfigure SMP -->
      <gpu value="false"/>       <!-- If true, attempt to autoconfigure GPUs -->
    
      <!-- Remote Command Server -->
      <command-allow v='127.0.0.1,192.168.0.2'/>
      <command-allow-no-pass v='127.0.0.1,192.168.0.2'/>
    
      <!-- Folding Slots -->
    ....
    I already had client folding, so to apply changes to xml I needed to run command

    Code:
    /etc/init.d/FAHClient reload
    After adding linux machine network IP on windows fah control, it instantly hooked it up as shown in screenshot above.

    software used :
    windows PC : FAHControl 7.2.9
    Linux PC : fahclient-7.2.9-1.x86_64.rpm
     
    Last edited: Nov 24, 2012
  2. iancook221188

    iancook221188 Ancient Guru

    Messages:
    1,725
    Likes Received:
    11
    GPU:
    GTX 670 SLI / GTX 460 SLI
    god guide will useful if i go the linux rote still trying to get my head round linux
     

Share This Page