Monitor randomly blackscreens, fps and power drops on GPU in multiple games, MSI Armor RX570 8GB

Discussion in 'Videocards - AMD Radeon' started by kkjfjns2014, Dec 24, 2021.

  1. kkjfjns2014

    kkjfjns2014 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Radeon RX 570 / 8GB
    My pc specs are as follows:


    CPU: AMD FX-8350 Black

    GPU: MSI Armor Radeon RX570 8GB GDDR5

    Motherboard: ASUS M5A78L-M Plus

    RAM: G.SKILL Ripjaws X DDR3 1600 (2 x 4GB)(2 x 8GB) (24 GB Total)

    PSU: EVGA Bronze 500W

    SSD: HP M700 120GB

    HHD: 3 x 2TB Western Digital Blue 7200 RPM

    DVD Drive: ASUS 24x DVD-RW SATA Drive

    Monitor: ViewSonic XG2705 27 Inch 1080p 144Hz

    DisplayPort Cable: IVANKY DisplayPort 2.0, 2K@144Hz 4K@60Hz


    Built in February 2019.


    I am about to pull my hair out, I've been dealing with this issue for a few weeks now and have no idea what's causing it. When I bump my desk when I get up my screen goes black. I moved the cable around and figured out that it moving is what was causing the issue. Sometimes I have to change display ports on the GPU to get it to come back on. It is a little loose on the PC side, completely tight on the monitor side. I also randomly get an error from my Radeon software that tells me it can't make a good connection so it can't display the proper output quality (144Hz 1080p). When I switch ports it goes away.


    The other issue, when I'm playing graphically demanding games, my FPS will drop out frequently, like every few minutes. It only lasts for about 6 seconds each instance. Example is, when I play red dead 2 online, my FPS averages about 40 with all the settings on medium. The GPU is running at around 65 Celsius and using 80-82 watts of power. My FPS will randomly drop to 12 or so and I noticed as it does this, the power draw changes from the 80s down to the 50s, usually around 55 watts or so. When I'm playing esports games, such as CS:GO, I never have an issue. It averaged 66 FPS with everything as high as it can go. My GPU should be able to play RDR2O on high settings without a hitch, but can barely handle medium it seems like.


    RDR2O also crashed once every couple hours or so completely. It pulls up a graphics driver error on my Radeon software, says something about how a graphics driver stopped working, and Rockstar just has an error saying ERR-GFX-STATE. I think this is a game error rather than a GPU issue though.


    What I've tried:

    • Rolling back GPU Drivers
    • Overclocking GPU and CPU (no change so went back to no overclock on both)
    • Changing how many cores RDR2O uses
    • Set everything to high performance instead of balanced or power saving
    Does anyone have any ideas? I'm so frustrated with it right now. My GPU has 3 months left on the warranty so I'm also wondering if I should just RMA it just in case or not. Thank you in advance.
     
  2. kkjfjns2014

    kkjfjns2014 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Radeon RX 570 / 8GB
    Edit: I also just noticed that my GPU Utilization is at 100% even thought I'm not doing anything graphically demanding at the moment. I wonder what's up with that?
     
  3. MaCk0y

    MaCk0y Maha Guru

    Messages:
    1,114
    Likes Received:
    442
    GPU:
    5700XT
    Did you try to change the PCI-e power cable?
     
    386SX likes this.
  4. opbush

    opbush Member

    Messages:
    15
    Likes Received:
    7
    GPU:
    RX 6700xt
    sounds like gpu sag.
     

  5. Mannerheim

    Mannerheim Ancient Guru

    Messages:
    4,885
    Likes Received:
    78
    GPU:
    MSI 6800XT
    Sounds like ur motherboard cant keep up with 8 core. Common problem with low end mobo and 8 core fx
     
  6. 386SX

    386SX Maha Guru

    Messages:
    1,426
    Likes Received:
    1,622
    GPU:
    AMD Vega64 RedDevil
    Did you try changing the monitor cable? If it is loose weird stuff can happen if it gets a partially connection.
     
  7. KRISPYnepa

    KRISPYnepa Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    AMD RX570 8GB
    Greetings. It sounds like the card is failing imho. I just got back my RMAd MSI RX570 8GB about a month ago. Built a new system in April 2020, before prices went out of control. Gradually over time i was getting blue screens, random crashes, slow down in games, and finally, dead on boot for the system. Replaced the card with a known good one and it worked fine. Tried my dead RX570 in my sons identical system and it too was dead on boot. Tried a different psu and all the regular remedies and no luck. Contacted MSI and they replaced my card. Works great now. Hope this helps you out. Cheers
     

Share This Page