1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Monitor LG 29UM68-P (G-SYNC stutter)

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Brenno, Feb 16, 2019.

  1. Brenno

    Brenno New Member

    Messages:
    3
    Likes Received:
    2
    GPU:
    RTX 2070
    Hello, first of all I'm sorry if I'm posting in the wrong place, if I am asking you to redirect or delete this post. Secondly, I'm sorry for my lousy English ...

    Let me tell you about the problem:

    I have a LG 29UM68-P monitor and am trying to choke on using g-sync. The riva tuner is marking that the games are running at 60 fps and the frametime is stable at 16.6 but I do not feel the flow of 60 frames at all times, there are times that it runs fluidly but in a few seconds I'm already starting to have the feeling that the frames are not flowing as they should and are not ... I already configured g-sync in the panel of nvdia, I already activated freesync in my monitor already tried to use it in 60 and 75hz, I formatted my windows 10, I already tried to use the last two drivers of nvdia I tested in games with direct x 11 and 12, but nothing solve my problem.

    Would anyone have an idea of what might be causing this problem?

    Thanks.
     
  2. Warkratos

    Warkratos Active Member

    Messages:
    55
    Likes Received:
    14
    GPU:
    GTX 1060 6Gb
    I have the same monitor, latest drivers work fine with this monitor.

    Here's how I setup to get it working butter smooth.

    Disabled Freesync on the monitor OSD.
    Go into Windows Safe Mode and use DDU to remove drivers.
    Disconnect the PC from the internet in order to stop windows downloading drivers.
    Install newest available driver.
    Reboot PC.
    Enable Freesync on monitor OSD.

    Then I go to the NVIDIA Control Panel and set G-SYNC to Fullscreen and Windowed Mode, check the box to Enable on this monitor model.

    I use Afterburner + RTSS and lock my FPS to 72 and set V-SYNC ON globally on NVIDIA Control Panel, disabled inside the games options.

    With all this I get stable 72 FPS in all games and really good frametime with no tearing and low-to-none input lag. Works flawlessly here in 75 Hz.
     
    Last edited: Feb 17, 2019
  3. freeman94

    freeman94 Master Guru

    Messages:
    290
    Likes Received:
    4
    GPU:
    MSI GTX 1070 ARMOR
    on prevous drivers I had to do the little trick to make it to work, there was some issues, but on the newest one 418.91 so far its working.
    The thing was that montior even when gsync compatible enabled in drivers and in monitor setting it just drops frame (good way to test it is to go website testufo)
    The trick is when you are on that website, with gsync enable in drivers and monitor see if it drops frame if it does just stay on that web page and go into monitor setting, and just toggle Freesync off and then agein on.
    after the blinks the testufo should be smooth.
    On prevously nvidia drivers the issue persist, let say you start computer and on 2-3 boot the problem was on 2 of 3 so I was really pissed.
    Now with 418.91 so far so good, no problems seems that they solve it.
    GTX 1070 with the same monitor LG 29UM68-P
     
  4. Brenno

    Brenno New Member

    Messages:
    3
    Likes Received:
    2
    GPU:
    RTX 2070
    Thanks man, solved my problem!
     
    fantaskarsef and Warkratos like this.

  5. kevnb

    kevnb Master Guru

    Messages:
    354
    Likes Received:
    2
    GPU:
    Zotac 1070
    Nvidia really needs to make it obvious that its better to use their vsync option when using gsync or freesync.
     
  6. Chastity

    Chastity Ancient Guru

    Messages:
    1,507
    Likes Received:
    329
    GPU:
    Nitro 390/GTX1070M
    @Brenno

    When using GSync, when it's at max refreshrate and VSync enabled, the monitor disables VRR and just uses VSync. When the fps dips below that, VRR is enabled, and you will get a stutter as it switches modes, and will do so again when max is attained.

    This is why you use a frame capper to prevent maxfps, and keep VRR enabled. Gameplay will then be hesitation-free.
     
  7. Smough

    Smough Active Member

    Messages:
    78
    Likes Received:
    6
    GPU:
    GTX 1060 3GB
    Hey man, a question: When you use Freesync on nVidia or G-Sync for that matter, do you need to keep the v-sync on the control panel? Cannot you just disable it and limit the fps with RivaTuner and forget about any form of v-sync? Since you are already using G-Sync.
     
  8. Chastity

    Chastity Ancient Guru

    Messages:
    1,507
    Likes Received:
    329
    GPU:
    Nitro 390/GTX1070M
    VSync will still do frame timing compensation to prevent tearing in the VRR range. USe VSync enabled in NVCP, and disable it in game.
     
  9. Brenno

    Brenno New Member

    Messages:
    3
    Likes Received:
    2
    GPU:
    RTX 2070
    Unfortunately today when playing some games I have again the same problem again ... I do not understand what may be causing this sttuter.
     
  10. Chastity

    Chastity Ancient Guru

    Messages:
    1,507
    Likes Received:
    329
    GPU:
    Nitro 390/GTX1070M
    There's a driver bug where the driver will not set the timings for VRR properly, and you will get hesitation and/or tearing and dropped frames. Solution: turn off monitor, wait a few secs, then turn back on. When the monitor is re-detected by Windows, the drivers will restore the timings info. You can also disconnect monitor and reconnect, or use restart64.exe from CRU's package if more convenient.
     

  11. d0X

    d0X Member Guru

    Messages:
    173
    Likes Received:
    3
    GPU:
    MSI GTX1070 GamingX
    Even changing the refresh rate to 60 and back to 75Hz helps.
     
  12. eGGroLLiO

    eGGroLLiO Member Guru

    Messages:
    134
    Likes Received:
    35
    GPU:
    EVGA 2080ti FTW3 UG
    If you are using EVGA Precision in any form it is definitely the culprit. Just turn it off and watch the stutter disappear!
     

Share This Page