1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Monitor flickers with green pixels

Discussion in 'General Hardware' started by vg24a3, Jan 9, 2019.

  1. vg24a3

    vg24a3 Active Member

    Messages:
    91
    Likes Received:
    0
    GPU:
    MSI GTX 980TI Gaming 6G
    1. After turning on the computer, during the first 1 or 2 hours it goes to this green flickering mode (look at the video below) for every few minutes or so.
    2. When I move the DVI cable or rather slightly nudge the video card by moving the DVI plug it goes away and screen returns to normal for until the next time.

    3. BELOW IS ADDITIONAL INFO THAT MAY BE RELEVANT TO THE ISSUE

    4. I used a DP cable before and I had mostly horizontal gray lines when this happened.
    5. 2y ago this power cable that provides additional power to video card (it was one of those 2 in one cables so I guess 16 lanes) melted / fused itself on the connection with my PSU (modular PSU) os I had it replaced, there was no problems until now.
    6. Also quite recently (but much later than video problems) I have noticed that when I turn on the computer, it tells me that it doesn't detect the Keyboard during the initial bios power up, only to seconds later work fine. Basically I can't even get into bios now (naively I've tried bios reset and I couldn't even get into the system because for a while it was stuck on the "get to bios message" and fix some things before you can go further and I couldn't obviously but somehow one day it just clicked in after I removed battery for long time.
    Has anyone here seen something like this before? at this point I have no idea if this is a MOBO, GFX or monitor or all three...

     
  2. GlennB

    GlennB Member Guru

    Messages:
    144
    Likes Received:
    33
    GPU:
    Sapphire Vega 56 EK
    Bad cable or connector ?
     
  3. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    2,163
    Likes Received:
    1,118
    GPU:
    GTX 1080Ti
    Sounds like a faulty mobo - I had red lines across the screen which was caused by mobo.

    What keyboard you have? have you tried using PS2 keyboard in Bios, does it work then or same issues?

    What I would test is - Have you tried other cables?
    Have you tried reseating GPU?
    Have you tried a different PCI-E Slot?
    Have you tested with a different GPU?
     
  4. vg24a3

    vg24a3 Active Member

    Messages:
    91
    Likes Received:
    0
    GPU:
    MSI GTX 980TI Gaming 6G
    It is possible but I dismissed this hypothesis because it happened first when I had a Display port cable, though it was mainly grey horizontal lines back then so I switched to DVI and got these instead, not right away but fairly quickly like maybe after 1 or 2 days. So I had two different cables already tried.

    I had greay lines on DVI about a week ago too, but ratio is like 1 to a 100 were 1 is when I had grey lines and 99 times it was green.
     

  5. vg24a3

    vg24a3 Active Member

    Messages:
    91
    Likes Received:
    0
    GPU:
    MSI GTX 980TI Gaming 6G
    I'm thinking it could be the MOBO too, that's why I included the recent NO KEYBOARD FOUND message in the information about the problem. Strange though how nudging the card a little in the slot fixes it temporarily.

    I tried 2 different cables DP and DVI (both HP came with the monitor)
    Yes I put the GPU in another slot, no difference
    I was going to try the built in GPU as I don't have another card laying around BUT I can't get into the bios (that's a real series of unfortunate events).

    I might try swapping GPU with my wife's computer, to make the final confirmation which is it.
     
  6. Passus

    Passus Master Guru

    Messages:
    978
    Likes Received:
    168
    GPU:
    GTX 1060 3GB
    Yes test the gpu in the wifes machine to rule that out, try hers in yours if she has 1

    does your mobo have the ps2 ports on the back? either 2 which 1 is green other purple or 1 dual port?

    if so you can try getting a usb to ps2 converter to get into the bios,, probably something to with with usb legacy support settings being off in the bios
     
  7. vg24a3

    vg24a3 Active Member

    Messages:
    91
    Likes Received:
    0
    GPU:
    MSI GTX 980TI Gaming 6G
    No it doesn't have PS/2 ports at all, that's why I'm stuck and unable to get to bios, so this makes the case stronger for the MOBO being broken.
    I would reset it again but I'm worried I might not be able to get past the "press F1 to continue" message again.
    I'll check her GPU first will see how it goes.
     
  8. Passus

    Passus Master Guru

    Messages:
    978
    Likes Received:
    168
    GPU:
    GTX 1060 3GB
    check your gpu and monitor on her machine,, if all good then its defo the mobo

    good luck
     
  9. kens30

    kens30 Maha Guru

    Messages:
    1,139
    Likes Received:
    20
    GPU:
    GTX 1070 STRIX OC
  10. vg24a3

    vg24a3 Active Member

    Messages:
    91
    Likes Received:
    0
    GPU:
    MSI GTX 980TI Gaming 6G
    Good idea, I didn't know about this feature, sadly it didn't work for me, it reboots my system, to dark black screen and nothing happens. I think my MOBO is the main problem here, I still haven't check the GFX, I might do it tonight, I just haven't got the time.

    It seems like a forced upgrade for me here, even tough my computer is old now 4770k + 980ti, it still bloody performs well in 2560x1600 (my native res) I really didn't want to change it yet. If my work circumstances change the way I want them to, I'll upgrade it to 4k TV and all new guts otherwise I'll keep it until it breaks down and I can't use it anymore.
     

  11. Astyanax

    Astyanax Master Guru

    Messages:
    861
    Likes Received:
    177
    GPU:
    GTX 1080ti
    turn off anisotropic filtering in the global settings.
     

Share This Page