Moded 5900XT BIOSes - Part II

Discussion in 'Videocards - NVIDIA GeForce' started by Cybermancer, Apr 13, 2009.

  1. Cybermancer

    Cybermancer Don Quixote

    Messages:
    13,795
    Likes Received:
    0
    GPU:
    BFG GTX260OC (192 SP)
  2. alf_igel

    alf_igel New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Nvidia 5900 128MB
    Since the other thread got closed, I just post my problem here again.

    So I wanted to mod my 5900XT into a Quadro FX 3000 by flashing the FX 3000 bios (I know there's a soft-mod using rivatuner, but I still want that bios flash).
    I used the nvidia.qfx3000.256mb.rev.02.rom (+ a couple of others) and the command "nvflash -4 -5 -6 new.rom" to flash my card. Everything went fine, I rebootet my system and a new graphics adapter was found. But instead of a qfx 3000, windows found a 5900 Ultra.

    What did I wrong?

    Another strange thing is: When I load my currently flashed bios into NiBiTor, everything is displayed correctly.

    [​IMG]
    [​IMG]

    And yet another srange behaviour occured. When I power off the computer, the bios gets reverted to the original 5900 XT, without me doing any flashing. :question:
     
  3. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    I believe the Quadro fx3000 is based on a 5900Ultra. And if so, then because of direct design similarities it may be reasonable to assume that 5900NU, 5900U and 5950U cards could be "soft/hard" modded into a sort of QFX3000 ?

    On the other hand, the FX5900xt is from a different (less capable) original design and therefore i'm not sure it would adequately qualify in "any" kind of QFX3000 activity?

    However, because of your card's built-in 5900 series "hard ID", after flashing, it has apparently become a sort of 5900Ultra Which likely means that making it correctly identify as a FX3000 may not be possible without somehow also hard modding your card's ID ---> maybe you should be googling around for this info?

    And although your card currently ID's as a fx5900U, if you want to try "running" it as Quadro fx3000 then just Select/Force your chosen driver to install as a Quadro fx3000?

    ;)
     
  4. alf_igel

    alf_igel New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Nvidia 5900 128MB
    I forgot to mention that before I tried flashing the card, I already did the soft-mod with rivatuner and it worked fine.
    But since the soft-mod doesnt work in other OSes (Mac OS), I need to flash the card. Or am I wrong?
     

  5. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    At the basic level, a soft-mod essentially works by isolating your card from the driver and thus can allow the card to be identified as anything. On the other hand, a bios mod will neither isolate nor fully reidentify your card in the way you want. Meaning, as previously posted, proper reidentification of your 5900xt as a qfx3000 would likely also require a hard-mod to your card's ID. This could be as simple as a resistor(s) value change ---> and which is in fact the info I suggested you should maybe be googling around for?

    Of course, common sense would dictate that before bothering to research for hard-mod ID info, you should maybe be using the Riva soft-mod to prove that your particular 5900xt can provide whatever performance benefits you actually need from the newly created pseudo qfx3000 ?

    So by saying "did the soft-mod with rivatuner and it worked fine", are you only indicating that your card was then properly recognised as a QFX3000 after the soft-mod, or do you mean that your soft-modded 5900xt had actually demonstrated it can provide the performance benefits you expect from a QFX3000 type card?

    Also, ignoring the fact that there is a slight ID mismatch with your "qfx3000-bios-flashed" card, have you yet tried forcing a Quadro Driver to install the bios-modded card as a qfx3000 ---> and if so, what was the outcome of your subsequent "quadro based" testing ---> and were your results any different from what was achieveable by going the "soft-mod" route?

    :)
     
    Last edited: Apr 15, 2009
  6. ViperXtreme

    ViperXtreme Ancient Guru

    Messages:
    3,124
    Likes Received:
    21
    GPU:
    GTX 1070 Super Jetstream
    oh wow, this brings back memories of my ancient 5900XT :D
     
  7. DARKSF

    DARKSF Active Member

    Messages:
    55
    Likes Received:
    13
    Hi the bios-es from the first thread are no longer available for download.Can u please send me something suitable for Asus V9950GE Non ultra fx 5900!? mail dark_@abv.bg
     
  8. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    Although the modded bioses originally hosted by Dr.Infern0 are no longer available, there are still some other options available to you.

    Most 5900nu cards were found to be suitable for flashing with standard 5950u bioses. And although you could just go for a ASUS5950u bios type, I would suggest a better option to be either a MSI5950u or BFG5950u bios. All suitable 5950u bioses can be downloaded from the linked website below:-

    http://www.mvktech.net/

    Of course if you would like to also "tweak" your chosen FX59xxx Bios for a bit more performance, then I suggest you read my "Basic FX59xxx Bios Modding Guide" at the nVnews linked thread below,

    http://www.nvnews.net/vbulletin/showthread.php?t=29230

    And if you search through the nvnews linked thread, you will find some already modded FX59xxx bioses which you may also like to try ?

    ;)
     
    Last edited: Sep 5, 2009
  9. DARKSF

    DARKSF Active Member

    Messages:
    55
    Likes Received:
    13
    Hi i`ve run in some problems after 4 hours of Flashing and moding of bios-es it was inpossible to run successfully the card with bios other than the original.

    OK lets start with the MSI bios 5950U
    Flashed but the clocks where to high for my card and i`ve moded the bios with NiBiTor 5.2 to get more normal clocks 425 / 850 flashed again everything worked fine until i`ve shuted down the PC and get it back on few hours later i was unable to boot in windows in normal mode in VGA mode it got to the log on screen and loaded successfully.Reflashed with the old checked the edited nothing strange found and reflashed again with the moded 5950 it worked fine even after the restart but after shut down and power cable unplug i`ve encountered the same problem on boot unable to get to the log on screen.

    BFX FX 5950U 256MB rev 02
    Same modifications done same problem!

    I`ve downloaded Asus FX5900U 256MB Rev01,02 and 03
    Tryed with all of them everything is working fine until shut down
    then i`m getting arteffacts slow performance and the card running in AGP 4x

    I`ve tryed to modify the bios but NiBiTor 5.2 is unable to modify the clocks and the Voltages of these bioses and on the original of the card too!
    NiBiTor 2.3 is showing the clocks and let me modify them but after flashing with the modifyed bios it is still running with the basis clocks that it come with i`ve reflashed few times and reopened few times the bioses to be shure that i`ve done all corect.

    Asus 5950U 256mb rev 02
    To high clocks Artefacts and finaly system blocks.Nibitor 5.2 not showing clocks and voltage.Nibitor 2.3 shows clocks and voltage and modify them but after flash with modifyed bios it is still on the original 5950U clocks.

    Did someone have run in such problems!?Again the problems are coming on shut down.After i flash the video it is running fine with the new bios and clocks in games and desktop and after restart again it is working fine but after shut down these problems are coming!
     
  10. vhalili

    vhalili Master Guru

    Messages:
    281
    Likes Received:
    0
    GPU:
    Evga 9800 GTX 512 MB in S
    Damn that card looks nice hehe GL

    [​IMG]
     

  11. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    Because your asus 9950ge doesn't appear to like flashing with fx5950u bioses I did a little internet searching to identify what FX59xx design it is based on ---> and found it is actually a 5900XT type and NOT a 5900NU as you indicated in your original posting?

    A genuine 5900NU runs at defaults of 400/850. However, because it's on-board design allows Core volts of up to 1.5v, and because it uses 2.2ns memory chips, after having flashed with a 5950u bios, it is then possible to overclock it to around 500/1000 levels.

    On the other hand, your 5900XT type normally defaults at 400/700. It is usually limited to Core volts of 1.3 v, and typically uses no better than 2.8ns memory chips. Which means it can likely only overclock to around 450/800 ---> and sometimes only when having done the "memory latency mod"as indicated in the 5900xt modded bioses thread; and of course in my 59xxx bios modding guide.

    This of course also means that if your really want to try your card with a 5950u type bios, then you have to reduce the chosen 5950u bios's core/memory speeds to same 450/800 levels?

    You can of course try flashing with different manufacturers XT bioses. Which in fact is actually the reason for raising the original "Moded 5900xt bioses" thread. And a good version to try might be the Aopen 04.35.20.38.A6 bios which many people found to be a good choice...where, after latency modding, overclocks to around 450-480/800 were quite common?

    Mind you, maybe before going any further with other type bioses, you could try modding your card's original bios at the very least iaw the 5900XT "memory latency" section of my Bios modding Guide ---> just a thought?

    Also, ASUS bioses are manufactured different from the supplied Nvidia design standard in where "Core/Memory" speed data is located. Therefore Bios Editors like Nibitor, which are based on only dealing with "standard nvidia" bios designs, have no way of changing such parameters. Only way to mod core/memory data in a ASUS bios is to use a Hex editor.

    Hope some of this helps!

    :)

    EDIT:-

    And I am assuming that you know that a Memory speed of 800MHz is actually stored in the Bios as 400...The card speed is only normally stated as 800 because the card uses DDR memory!

    :)
     
    Last edited: Sep 8, 2009
  12. jimmor

    jimmor Ancient Guru

    Messages:
    4,528
    Likes Received:
    1
    GPU:
    EVGA8800GTS 512Mb
    DARKSF, the linked Darksf_02.zip file contains 2 modded bioses. One is the Aopen 5900XT bios (04.35.20.38.A6) which many people found excellent; and the other is a well used BFG5950U type. Both bioses include a relaxed Latency mod to improve memory overclocking/performance and are set to run at 300/425/800 (2D/3D/Mem) ---> which are speeds that most 5900XT type cards should be capable of running?

    http://www.nvnews.net/vbulletin/attachment.php?attachmentid=38133&d=1252413082

    Obviously you can change the Bios's default speeds to anything you want. However, you should only consider increasing the Bios's Core/memory speeds after you have established your card's Max STABLE overclock capabilities.

    And when overclocking your 5900XT, or any vga card for that matter, it is very important that you also give consideration to upgrading your cards heatsinking. Otherwise your selected overclocks may not run stable; especially during Gaming, etc?

    Also, although it is ok to make bios changes using NiBiTor with the BFG 5950u bios, it is recommended that you use the MHz5900 bios editing tool (or of course direct bios editing using a Hex editor) for the Aopen 5900XT bios. NiBitor currently appears to have some issues working with 5900XT bioses?

    ;)
     
    Last edited: Sep 8, 2009
  13. nolimits

    nolimits New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    2x GTX 275
    hi.im new here .aopen bios rulez btw i managed to flash it yesterday to an msi 5900xt.its not giving me trash anymore during benchmark.with moded original bios worked at 450/766(only vlt mod).um is it possible to set the fan speeds to bios for this card?im using nibitor.thanks again
     

Share This Page