Microsoft .NET Framework 4.5.1 Final

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Watcher, Oct 25, 2013.

  1. Watcher

    Watcher Ancient Guru

    Messages:
    2,592
    Likes Received:
    234
    GPU:
    Gigabyte Windforce R9 380
    This is not a driver update but related software. Without any fanfare, Microsoft has released .NET Framework 4.5.1 Final a couple of days ago.

    Now since the Catalyst driver requires the .NET Framework, I've updated a couple of computers and CCC seems to response more quickly.

    Download locations:

    http://download.microsoft.com/downl...79F8E2/NDP451-KB2858728-x86-x64-AllOS-ENU.exe < Direct download.

    http://www.microsoft.com/en-us/download/details.aspx?id=30653

    http://www.majorgeeks.com/files/details/microsoft_net_framework_4_5_final.html

    http://www.softpedia.com/get/Others/Signatures-Updates/NET-Framework.shtml
     
  2. Joe 69

    Joe 69 Master Guru

    Messages:
    213
    Likes Received:
    0
    GPU:
    Sapphire HD4850 1GB


    I installed net 4.5.1 today and even for me CCC seems pops on faster and responses snappier on my win 7 64b.....

    ...however, the first, third and forth link that you gave are for off-line install but needs even language pack to be installed (see details section of this link: http://www.microsoft.com/en-us/download/details.aspx?id=40779 )

    language pack for off-line install link:
    http://www.microsoft.com/en-us/download/details.aspx?id=40751


    for web install (language pack comes automatically) heres the link :
    http://www.microsoft.com/en-us/download/details.aspx?id=40773

    Your second link is only Net 4.5, so I think you made an error.
     
    Last edited: Oct 25, 2013
  3. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
  4. Joe 69

    Joe 69 Master Guru

    Messages:
    213
    Likes Received:
    0
    GPU:
    Sapphire HD4850 1GB
    There are two known issues with net 4.5.1

    1. http://support.microsoft.com/kb/2867719
    This issue is for Windows 8 or Windows Server 2012 users and if an application needs net 4.5.1 to work a warning might pop on saying that net v4.5.1 needs to be installed...this means that net 4.5.1 is not correctly installed so it must be uninstalled for attempting to install it again.

    2. http://support.microsoft.com/kb/KB2867723
    I suppose that this issue is resolved because, as you can see, they retired the link.
     
    Last edited: Oct 25, 2013

  5. Elite3540

    Elite3540 Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    MSI GTX 970 GAMING 4G OC
    Thank you, installing now. :)
     
  6. sent3D

    sent3D Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    MSI HD7850 1GB 1150/1300
  7. Berdugoo

    Berdugoo Member Guru

    Messages:
    151
    Likes Received:
    0
    GPU:
    INTEL 4000 w/ AMD 8750M
    thank you installing now!!! :eyebrows::eyebrows::eyebrows:
     
  8. ubysm1

    ubysm1 Active Member

    Messages:
    55
    Likes Received:
    0
    nice catch. i think it's worth pointing out for any 8.1 users out there that that this is already included in the OS update.
     
    Last edited: Oct 25, 2013
  9. Joe 69

    Joe 69 Master Guru

    Messages:
    213
    Likes Received:
    0
    GPU:
    Sapphire HD4850 1GB
    Yep, Net 4.5.1 is already included in windows 8.1
     
  10. flow

    flow Maha Guru

    Messages:
    1,003
    Likes Received:
    10
    GPU:
    Asus TUF RTX3080 oc
    I wonder what happens if you do a driver install and the older 4.5 is included. Would it overwrite things or make it complicated? Because with every beta driver the same old .net insists on being installed again. Even if it already sits on your system.
    This is really something amd should fix, it takes quite some time for the driver install, this could be cut in half if it would detect certain parts are already installed.
     

  11. sent3D

    sent3D Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    MSI HD7850 1GB 1150/1300
    That's why i always delete .NET Framework and VC++ Redistributables from AMD Drivers before install since they are always older than those that i currently have installed.
     
  12. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
    And ya, it is strange that why it can replace the newest version...
     
  13. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,404
    Likes Received:
    793
    GPU:
    6800XT Nitro+ SE
  14. Joe 69

    Joe 69 Master Guru

    Messages:
    213
    Likes Received:
    0
    GPU:
    Sapphire HD4850 1GB
    Yes, but like I said in my first post, this is the off-line version and needs even the language pack.....it's better (ms words) the on-line (or web) version with the language pack included.
     
  15. Pill Monster

    Pill Monster Banned

    Messages:
    25,216
    Likes Received:
    8
    GPU:
    7950 Vapor-X 1100/1500
    Oh you guiez...lol. :p

    The offline install pack is here.
     
    Last edited: Oct 27, 2013

  16. TyrantofJustice

    TyrantofJustice Ancient Guru

    Messages:
    5,021
    Likes Received:
    26
    GPU:
    RTX 2080 super
    how do you delete the .net framework in the driver?

    or is it an editable option on the install ticker?
     
  17. kurtextrem

    kurtextrem Master Guru

    Messages:
    244
    Likes Received:
    27
    GPU:
    NVIDIA GeForce GTX 970
    Actually it doesn't seem like it replaces the old version:
    [​IMG]

    Not sure which one CCC uses then, the newest one? Is it safe to remove the old ones?
     
    Last edited: Oct 31, 2013

Share This Page