1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Max Prerendered Frames: Always set to 1 or leave on Default?

Discussion in 'Videocards - NVIDIA GeForce' started by StephenEnzor, Nov 30, 2018.

  1. StephenEnzor

    StephenEnzor Active Member

    Messages:
    50
    Likes Received:
    1
    GPU:
    GTX 770M SLI
    Hi there guys,

    For the Max Prerendered Frames setting in the Nvidia Control Panel, I read previously that lowering this can reduce input lag, but sometimes it may not be a good idea as it can mess with frametimes or result in a lower overall framerate (which I assume would cancel out/negate the benefit?).

    Should I just globally set this to 1 (the minimum) or is it preferable to leave this on the "Default" -> "Let the 3D application decide" setting?

    I would think that lower input lag is basically always gonna be a good thing, but I'm not sure if that's exactly how reducing this to 1 really works out.

    Thanks for your time, I appreciate it.

    For some context if it matters I recently acquired a 1080 Ti 8700K system w/ 1440p G-Sync monitor and I'm wondering if I should set the max prerendered frames count to the minimum (1) as that's what it was recommended to me to do in the past with my old computer where I often had to cap at 30 fps with Rivatuner. I would think the input lag reduction would still be valuable at higher framerates though, but I could be missing something(s).
     
  2. StephenEnzor

    StephenEnzor Active Member

    Messages:
    50
    Likes Received:
    1
    GPU:
    GTX 770M SLI
    @RealNC Sorry to spam you all the time like this :p But, if you get the chance and happen to have a recommendation/preference for this sort of thing or could lay out exactly what the benefits of each approach would be, that would be very helpful for me as I've had a tough time tracking down specifics elsewhere online. Thanks for your time.
     
  3. RealNC

    RealNC Ancient Guru

    Messages:
    2,599
    Likes Received:
    850
    GPU:
    EVGA GTX 980 Ti FTW
    @StephenEnzor I have it set to 1 globally. Some people have said that 1 results in lower FPS in some games, but personally I've never seen that. I guess if you see a game where you can't reach your target FPS, you can try setting it to default and see if it helps. For me, it never helped.
     
    fluidz likes this.
  4. XenthorX

    XenthorX Ancient Guru

    Messages:
    2,125
    Likes Received:
    229
    GPU:
    EVGA XCUltra 2080Ti
    Recently changed this settings to 1 globally, As i usually play around 60 FPS it means i won't have latency beyond 16ms as far as rendering is concerned.
     

  5. Mda400

    Mda400 Master Guru

    Messages:
    666
    Likes Received:
    7
    GPU:
    GTX 980 1519/7906
    1 will only result in lower FPS if the CPU can't keep up with the demand of the GPU (CPU bottleneck). I've only experienced this on my old q9550 and GTX 480 setup when playing games such as GTA 4 or games where a single thread is used to render, perform physics calculations, etc.

    Not many CPU's should cause this I'd believe since Sandy Bridge, where the IPC increase was major for Intel.
     
  6. StephenEnzor

    StephenEnzor Active Member

    Messages:
    50
    Likes Received:
    1
    GPU:
    GTX 770M SLI
    Thanks a lot guys, this was helpful for me -- will set it to 1 globally then.
     
  7. Astyanax

    Astyanax Master Guru

    Messages:
    727
    Likes Received:
    151
    GPU:
    GTX 1080ti
    i remember when setting it to 1 would bsod opengl games under windows xp.
     
  8. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    5,592
    Likes Received:
    195
    GPU:
    MSI GTX 1070
    Last time i tried this was during Skyrim in 2011 to fight the terrible mouse lag in that game.

    I ended up 15 FPS lower.

    Then again i had a first gen i7 950 @ 3,8 GHz and a GTX680 4GB at the time.

    Might not be the case anymore nowdays.
     
  9. Chastity

    Chastity Maha Guru

    Messages:
    1,326
    Likes Received:
    259
    GPU:
    Nitro 390/GTX1070M
    My desktop is an i7 950, with 18GB RAM (gotta love x58 triple memory) and my R390. Still does quite well in this day and age. Tho my laptop kicks it's butt. :D
     
  10. StephenEnzor

    StephenEnzor Active Member

    Messages:
    50
    Likes Received:
    1
    GPU:
    GTX 770M SLI
    @RealNC

    Regarding the "Max Prerendered Frames" setting there's something I ran into you might want to know about.

    So, currently I have "Max prerendered Frames" forced to 1 (minimum) globally -- however, in DOOM (2016) with Max-prerendered frames forced to 1, G-Sync enabled, and V-sync enabled (all nvidia control panel settings) with Rivatuner capping the framerate at 141 (on a 144 hz monitor), I get horrendous "Jitter" with Max Prerendered Frames forced to 1.

    Now, it should be noted that pretty much no matter what settings I use in that title, for some reason the framerate is all over the place -- I may be CPU bound there not sure.

    Anyway, if I could hit a stable framerate target then the jitter doesn't occur, but if the framerate is variable/unlocked with g-sync on and max prerendered frames set to 1 I get horrendous Jitter in-game (oscillating between 60-120 fps variance -- average probably at 90 or a 100).

    For DOOM (2016), if I force max prerendered frames to "Use the 3D application setting" than this Jitter mostly goes away and is greatly reduced (this issue occurs with Vulkan or OpenGL for context).

    My rig is 1080 ti + 8700K if that's relevant.
     
    Last edited: Dec 2, 2018

  11. RealNC

    RealNC Ancient Guru

    Messages:
    2,599
    Likes Received:
    850
    GPU:
    EVGA GTX 980 Ti FTW
    @StephenEnzor Good to know. I don't get that issue myself, but others might.
     
  12. StephenEnzor

    StephenEnzor Active Member

    Messages:
    50
    Likes Received:
    1
    GPU:
    GTX 770M SLI
    @RealNC

    I did a bunch more research on the stuttering/framerate spikes downwards I was seening in DOOM 2016 and though increasing the max prerednered frames counter from 1 made those dips and spikes more bearable, I looked online and the performance I was seeing was just unusual for my rig/resolution/etc.

    In this thread seems the problem ended up being the razer chroma synapse settings in game: https://www.resetera.com/threads/doom-2016-doesnt-feel-smooth-on-high-end-system.33194/page-7

    Once I'm home from work i'll try disabling that to see if it improves the situation! If so I'll go back to 1 max prerendered frame there
     
  13. SKIBA

    SKIBA Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    GTX 1060 / 6 GB
    I mostly set the 4 (half).
     
  14. BlueRay

    BlueRay Master Guru

    Messages:
    245
    Likes Received:
    33
    GPU:
    GTX970
    I would leave it on default or change it to 1 only for some specific games that works well with it set on 1.
    There is a reason that Nvidia did not set it to 1 by default.
    Not all games like it and some of them behave weirdly with it on 1.
    Some of them lose FPS and some other don't feel smooth anymore.
     

Share This Page