1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Massive DPC latency with latest drivers

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Mangix, Jul 14, 2019.

  1. Mangix

    Mangix Active Member

    Messages:
    65
    Likes Received:
    0
    GPU:
    PowerColor Vega 56
    https://imgur.com/OFP5QvE

    Running Ryzen R5 3600 with latest chipset drivers as well as GPU drivers. Motherboard is Asrock X370 with latest BIOS that supports 3rd gen.

    Anyone else experience this? I did not see this with my Ryzen 1200.

    This lag happens in both Windows and Linux. I get audio dropouts.
     
  2. Mangix

    Mangix Active Member

    Messages:
    65
    Likes Received:
    0
    GPU:
    PowerColor Vega 56
    Switched to the 1200. Same issue.

    edit: Actually it's a little bit better with the 1200. That is, no red bars show up. But still yellow.

    edit2: I tried downgrading the BIOS. The tool says invalid file. #fuckasrock

    edit3: After 30 minutes of listening to music, I conclude that the stutters are completely gone. Looks like I'm returning this 3600. Shame...
     
    Last edited: Jul 14, 2019
  3. SpajdrEX

    SpajdrEX Ancient Guru

    Messages:
    2,019
    Likes Received:
    376
    GPU:
    GB RX 5700 Gaming
    Try LatencyMon, Latency Checker does not work well on Windows 10 (if that is the version you use).
     
    OnnA likes this.
  4. Poor Tom

    Poor Tom Active Member

    Messages:
    54
    Likes Received:
    1
    GPU:
    2080TI XC Ultra
    Hopefully there is no need to return your nice new CPU. Try downgrading to an older Nvidia driver and see if that helps.

    I had crazy high latency after putting the new system together and that fixed it for me. I'm using X570 mb and your on X370 so maybe it's not the exact same issue, but it's worth a try.
     

  5. Astyanax

    Astyanax Ancient Guru

    Messages:
    3,274
    Likes Received:
    847
    GPU:
    GTX 1080ti
    set interrupts to MSI's with msi util
    use latest 1.7 chipset driver (not the on disk driver)
     
    eGGroLLiO likes this.
  6. OnnA

    OnnA Ancient Guru

    Messages:
    9,413
    Likes Received:
    1,912
    GPU:
    Vega 64 XTX LiQuiD
    use this tool:
    timer_test_x64

    [​IMG]
     
  7. Mangix

    Mangix Active Member

    Messages:
    65
    Likes Received:
    0
    GPU:
    PowerColor Vega 56
    Using AMD Vega.
     
  8. OnnA

    OnnA Ancient Guru

    Messages:
    9,413
    Likes Received:
    1,912
    GPU:
    Vega 64 XTX LiQuiD
    So update Your Profile :p
     
  9. GlennB

    GlennB Master Guru

    Messages:
    206
    Likes Received:
    51
    GPU:
    Sapphire Vega 56 EK
    Use latencymon to find which process is causing the increased latency. I had problems with latency twice and both times the soundcard was the problem (1 onboard realtek, 1 asus strix soar).
     
  10. Poor Tom

    Poor Tom Active Member

    Messages:
    54
    Likes Received:
    1
    GPU:
    2080TI XC Ultra
    Alright, AMD then. So I also had serious latency issues on two different occasions. Once when I updated the Nvidia driver, which isn't relevant for you, and the other when I updated the Intel NIC driver. As others have suggested, using DPC Latency Monitor did verify the high latency and pointed to the Nvidia driver in that case, but not to the network driver so it's not always easy to track down.

    Just try and isolate the last few driver changes made to see which is causing your problems. If nothing fixes it then maybe your right and the bios isn't working that great with the new Ryzen 3000 CPU's. Best of luck.
     

  11. Mangix

    Mangix Active Member

    Messages:
    65
    Likes Received:
    0
    GPU:
    PowerColor Vega 56
    Oh wow that is so old.

    I tried using LatencyMon but I couldn't see anything wrong. While DPC Latency Checker is not accurate, I do see the red spikes when stutter happens.

    I tried going to device manager and disabling every not needed device. I was still getting stutters.
     
  12. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,890
    Likes Received:
    4,525
    GPU:
    GeForce GTX 1070
    OnnA likes this.
  13. Montville

    Montville Member Guru

    Messages:
    194
    Likes Received:
    17
    GPU:
    Aorus RX 570 4GB
    Similar for me Latency up to 4-10 seconds mainly caused by storport.sys but without latest driver.
    Ryzen 2700x here


    https://pasteboard.co/IojzeTr.jpg
     
    Last edited: Jul 17, 2019
  14. Mangix

    Mangix Active Member

    Messages:
    65
    Likes Received:
    0
    GPU:
    PowerColor Vega 56
    Seems the issue was some BIOS setting. I put my 3600 back in and reset the BIOS. No issues so far.
     

Share This Page