Mass Effect 2 tweaking...

Discussion in 'Games, Gaming & Game-demos' started by syklonis, Jan 27, 2010.

  1. syklonis

    syklonis Active Member

    Messages:
    82
    Likes Received:
    12
    GPU:
    RTX 3080 TUF OC
    For some reason Mass effect 2 is extremely dark and over saturated on the PC, in game-play and in cut-scenes. You lose all the details in the uniforms etc, since you cant even see them!! After time spent tweaking a ton of lines, I have found a way to turn this off and make it look better in my opinion. Some will prefer it on, but I just can't stand it. You lose some light blurring and darker shadowing, but look at the colors now..not as washed out on the characters.

    Go into your users folder, example...

    C:\Users\yourname\Documents\BioWare\Mass Effect 2\BIOGame\Config

    open up the GamerSettings.ini and add this line under [systemsettings]

    DepthOfField=False

    [​IMG]

    Of course make a backup of your ini file before adding changes!!

    There are other lines to add as well like texture filtering etc..so I am still tweaking to make this look better. So if anyone else wants to add to this thread, please do :) Oh and grab nhancer if you have nvidia and force aa there..I have it maxed and its very nice looking..smooth as hell!

    Enjoy :)
     
  2. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,009
    Likes Received:
    527
    GPU:
    EVGA GTX 1080 Ti SC2
    I presume the bottom screenshot is the tweaked version?

    If so, then it certainly looks less washed out but on the LCD screen I'm using at here at work (hey, I'm on a break!) it looks overly dark and much of the fine detail is lost. Miranda's black hair blends into the shoulders of her jacket for example and Jacob's jacket also shows less detail as it's lost in shadows.

    That said, the bottom image looks better for colours but the brightness needs upping a notch or two IMO.

    *Edit*
    Sorry... sorry.

    Damn, my small 1024x768 monitor. I didn't see the text on the right-hand side. I see the bottom image is the original version. That being the case I prefer it to the washed out one above, it just needs the gamma raising a little, that's all. As you say though, it's a personal thing.
     
    Last edited: Jan 27, 2010
  3. syklonis

    syklonis Active Member

    Messages:
    82
    Likes Received:
    12
    GPU:
    RTX 3080 TUF OC
    No the top image is the tweaked one where I typed in Depth of field Off. This will of course be user preference, but to me it looks much better. On my lcd I had the same issues..the colors of Miranda jacket bleeding together with hair, etc...This fixes that!

    I see you edited it lol yeah to each their own :)
     
  4. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,009
    Likes Received:
    527
    GPU:
    EVGA GTX 1080 Ti SC2
    Yeah sorry about the mix up, syklonis.

    I'll take a look at the images when I get home as I have a calibrated HP LP2475w monitor which is way superior to the one I'm using here.

    Thanks for the tweak anyway. I'll probably try it anyway as the top image definitely shows more detail as you say.
     

  5. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,009
    Likes Received:
    527
    GPU:
    EVGA GTX 1080 Ti SC2
    By the way, you have a very similar system to me... what framerates are you getting with the game and what resolution are you playing it? I presume you have AA forced as those screenshots look very 'clean' and free of aliasing... what AA setting are using... 4x, 8x?
     
  6. Anarion

    Anarion Ancient Guru

    Messages:
    13,604
    Likes Received:
    378
    GPU:
    GeForce RTX 3060 Ti
    50/50 would be quite good looking:
    [​IMG]

    In my opinion the DoF off looks a bit too washed out and with DoF on it definitely is too dark.
     
  7. syklonis

    syklonis Active Member

    Messages:
    82
    Likes Received:
    12
    GPU:
    RTX 3080 TUF OC
    I am using 8X AA 16X AF in nhancer with 000100C5: Unreal Engine 3 compatibility, at 1680X1050 resolution. And its running extremely smooth! No slowdown yet for me :)
     
  8. Copey

    Copey Ancient Guru

    Messages:
    10,710
    Likes Received:
    0
    GPU:
    960 2GB
    I like the top one better, lighting and shadows look alot better, there should be some other things you can mess about with.
     
  9. syklonis

    syklonis Active Member

    Messages:
    82
    Likes Received:
    12
    GPU:
    RTX 3080 TUF OC
    Yes there is a bunch of lines you can add..I have been pulling them from the cooked Coalesced.ini

    I'm working on getting higher textures and better shadowing now :)

    Sometimes I wish devs would just chime in and show what's the absolute best quality you can get by tweaking the ini..it would be easier than hours of trial and error lol
     
  10. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,009
    Likes Received:
    527
    GPU:
    EVGA GTX 1080 Ti SC2
    You might want to consult Tweakguide's guide to the original Mass Effect here for things to mess around with in Mass Effect 2 as they both use the same engine. The link is here: http://www.tweakguides.com/ME_1.html
     

  11. syklonis

    syklonis Active Member

    Messages:
    82
    Likes Received:
    12
    GPU:
    RTX 3080 TUF OC
    Thanks Darren, I have been referencing that guide :)
     
  12. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    add a line: Trilinear=TRUE
    you can add it above anisotropic filtering line.. and you're good to go! :)

    otherwise you will get bilinear Anisotropic filtering, it was the same with ME1 or Batman AA, Mirrors Edge.. And believe me it looks ugly once you spotted it, its like a bow wash effect 2m in front of you..
     
  13. IPlayNaked

    IPlayNaked Banned

    Messages:
    6,559
    Likes Received:
    0
    GPU:
    XFire 7950 1200/1850
    I think your brightness or gamma is the problem, not the depth of field. Your's does look way too dark, but the top image compromises way too much in IQ for my taste. At any rate, mine doesn't look like your's did and I don't have DoF turned off.
     
  14. EarlZ

    EarlZ Master Guru

    Messages:
    218
    Likes Received:
    0
    GPU:
    2x Zotac GTX 780
    I tried the same settings and during a conversation the FPS drops down to 20-30fps but is still acceptable but does not feel as smooth as a solid 60fps, On firefights I get 60 most of the time.
     
    Last edited: Jan 27, 2010
  15. syklonis

    syklonis Active Member

    Messages:
    82
    Likes Received:
    12
    GPU:
    RTX 3080 TUF OC
    I have zero gamma and brightness issues with any art programs or other games I run.

    If brightness or gamma was an issue then why does this tweak make the game seem less dark. Going by what you say, if I turn off depth of field then the brightness and gamma should be untouched, but as you can see that is not the case. Depth of field in this game uses some kind of dark shadowing and just isn't for my tastes.

    But it's cool you don't have it as dark. Maybe some setting in nvidia on this game is making it dark for me with the setting on :)
     

  16. Templ

    Templ Guest

    Some more tweaks to try:

    Code:
    [SystemSettings]
    MinShadowResolution=32
    MaxShadowResolution=512
    I changed it to 512, 2048 respectively. Seems to make a bit of a difference.

    EDIT: Don't increase the min res to more than 64 or you'll get glitches (some shadows won't appear, others might flicker).

    Code:
    [SFXGame.BioArtPlaceable]
    m_nMaxCorpseVisibilityCleanupAttempts=4        ;If after this many tries, the body has not gone off screen, use the distance threshold
    m_fCorpseCleanupFirstAttemptTime=5.0            ;How many seconds to wait until the first corpse cleanup attempt
    m_fCorpseCleanupAttemptRetryTime=2.0            ;How many seconds to wait between cleanup tries
    m_fMaxCorpseCleanupDistanceThreshold=4000.0        ;FOR NON SKELETAL MESH CORPSES: Distance the corpse must be from the camera before it is cleaned up even if it is in view (in centimeters)
    m_fMaxCorpseCleanupScreenSizeThreshold=0.20        ;FOR SKELETAL MESH CORPSES: The corpse must take up this much screen space or less before it is cleaned up even if it is in view (see FSkeletalMeshObject::MaxDistanceFactor)
    Not sure if this works, but if it does, it should prevent bodies from fading away (those that you don't incinerate or shatter anyway) if set properly.

    Anyway, as with other lines, just add them to GamerSettings.ini
     
    Last edited by a moderator: Jan 28, 2010
  17. syklonis

    syklonis Active Member

    Messages:
    82
    Likes Received:
    12
    GPU:
    RTX 3080 TUF OC
    Thank Templ, I have added this line as well :)

    I'm trying to get the shadows underneath the other players to stop disappearing now. It's quite annoying..I walk like 5 feet from squad members and the shadow beneath them goes away and turns off. There's got to be some kind of lod line for that..still looking :)
     
  18. NODO-GT

    NODO-GT Master Guru

    Messages:
    370
    Likes Received:
    5
    GPU:
    RTX2070
    nice thread
    i like DOF effect, so i'm keeping it

    i also tried this lines
    ShadowFilterRadius=5
    AllowD3D10=True
    can anyone confirm if they are working?
    i don't know why, but RivaTuner didn't show me whether the game was running DX9 or DX10...
     
  19. CartCSS

    CartCSS Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    HD4870
    The game is DX9 it doesnt have a DX10 path
     
  20. syklonis

    syklonis Active Member

    Messages:
    82
    Likes Received:
    12
    GPU:
    RTX 3080 TUF OC
    Adding AllowD3D10=True crashes the game for me. Tried that earlier :)

    So far these are the lines I have added

    DepthOfField=False
    TEXTUREGROUP_Character_2048=(MinLODSize=512,MaxLODSize=2048,LODBias=-1)
    TEXTUREGROUP_Environment_2048=(MinLODSize=512,MaxLODSize=2048,LODBias=-1)
    MinShadowResolution=512
    MaxShadowResolution=2048
    DisableHWShadowMaps=False
    DynamicLights=True
    ShadowFilterQualityBias=2
    Trilinear=TRUE
     

Share This Page