Mass Effect 1 - Insane Glitching / Artifacting on AMD hardware

Discussion in 'Videocards - AMD Radeon Drivers Section' started by cryohellinc, Jul 12, 2020.

  1. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,334
    Likes Received:
    2,656
    GPU:
    RX 5700 XT/GTX 1060
    Hi all,
    Getting the following issues (loaded an old save for testing purposes, however, problems appear everywhere regardless)

    Example:


    Significant Artifacting and glitching all over the place.

    My hardware is perfectly fine, and doesn't have those issues in any other game.
    Perhaps someone saw / faced something similar?

    What I have tried so far:
    -various compatibility modes
    -amd Black box glitch fix mod
    -turning off RivaTuner/ Radeon Software overlay
    -reinstalling
    -Various graphical settings
    FIXED IT:
    The issue was the 20.7.1 driver. Rolled back to 20.5.1 HWS - everything is working great now.

    Thank you to everyone for their support and suggestions.

    Update:
    And it's back.

    Update2 + Solution:
    I thought it was the cache, however, finally narrowed down what was causing this behavior.

    For what ever reason it doesn't seem to like those two:

    Tesselation Mode and Anti-Aliasing

    Tesselation mode has to be set to AMD Optimized (Prior to this I was testing with "Use Application Settings" hence that was the default, it was resulting in glitches)
    With any other setting, it glitches all over the place.

    Anti-Aliasing works only if set to "Enhance Application Settings"

    Hope this helps someone in the future.
     
    Last edited: Jul 13, 2020
    Deleted member 213629 likes this.
  2. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,050
    Likes Received:
    7,057
    GPU:
    GF RTX 2070 Super
    Your computer is indoctrinated!!!
     
  3. itpro

    itpro Master Guru

    Messages:
    682
    Likes Received:
    375
    GPU:
    Radeon Technologies
    Set your CCC/Radeon graphics settings at default or keep your settings highest quality except put everywhere possible to "Use application settings/let application decide". Perhaps you changed something that is incompatible with game's engine/coding.
     
  4. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,334
    Likes Received:
    2,656
    GPU:
    RX 5700 XT/GTX 1060
    Tried that as well. Everything is on default., and the issue still persists.

    Perhaps there is someone with 5700xt that can give Mass Effect 1 a go? It's either hardware incompatibility (however I did play many Unreal Engine 3 games, and they worked just fine) or something with a driver. I am running card stock both on clocks and ram.
     

  5. Only Intruder

    Only Intruder Maha Guru

    Messages:
    1,322
    Likes Received:
    267
    GPU:
    Sapphire Fury Nitro
    It's Mass Effect 1... (Mass Defects) it has bugs everywhere, I've experienced all manner of graphical glitches through the years on various hardware (Nvidia and ATi/AMD) but there are fan patches and mods that will help.

    Give this a go https://www.moddb.com/mods/mass-effect-1-new-texture-updatesimprovements-mod/downloads
     
  6. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,050
    Likes Received:
    7,057
    GPU:
    GF RTX 2070 Super
  7. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,334
    Likes Received:
    2,656
    GPU:
    RX 5700 XT/GTX 1060
    I have installed all those mods beforehand, started the game and saw all the glitches. Initially, I assumed it's mod related. Wiped the game, all the mods, all config files e.t.c

    It's not the mods, this video above is from an unmodded game. So it's something with the engine conflicting with hardware/software on my end.

    Hence if someone with 5700xt could give it a go please, would be really helpful in narrowing it down for me.
     
  8. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,334
    Likes Received:
    2,656
    GPU:
    RX 5700 XT/GTX 1060
    A guy on the steam forum posted a video with his 5700xt - works just fine. So it seems to be something on my end.

    I literally have no clue what is causing this. Will try to experiment with driver versions.
     
  9. Astyanax

    Astyanax Ancient Guru

    Messages:
    8,466
    Likes Received:
    2,840
    GPU:
    GTX 1080ti
    turn off anything that defaults to an amd optimized setting, ie, tesselation

    use application defaults equivalent for antialiasing and set it ingame.
     
  10. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,334
    Likes Received:
    2,656
    GPU:
    RX 5700 XT/GTX 1060
    Tried that already, same result. What can't be really seen on the footage I posted, is that on some angles on characters - shadows look like horizontal lines.

    I'm running an Origin version of the game, I think there is a way to transfer it to Steam. Will give that a go.
     

  11. Pyrage

    Pyrage Master Guru

    Messages:
    392
    Likes Received:
    39
    GPU:
    580 CF@ 1470
    Try to downclock or overclock your card. Remove overclocks from CPU, ram etc.
     
  12. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,334
    Likes Received:
    2,656
    GPU:
    RX 5700 XT/GTX 1060
    Yup, will have to give that a go as well. GPU is stock, no OC/Undervolt.
     
  13. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,334
    Likes Received:
    2,656
    GPU:
    RX 5700 XT/GTX 1060
    Tried with stock CPU values, same stuff. So it has to be something in Windows / Driver / Graphical Settings / Local files

    Redownloading a different version of ME1 from Steam now. Will report back when possible.
     
  14. Crisidelm

    Crisidelm Active Member

    Messages:
    52
    Likes Received:
    16
    GPU:
    XFX 5700 DD Ultra
    Just loaded a ME1 savepoint; no noticeable problem here.
     
  15. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,334
    Likes Received:
    2,656
    GPU:
    RX 5700 XT/GTX 1060
    Which driver are you on?
     

  16. Crisidelm

    Crisidelm Active Member

    Messages:
    52
    Likes Received:
    16
    GPU:
    XFX 5700 DD Ultra
    20.5.1 HWS
     
    cryohellinc likes this.
  17. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,334
    Likes Received:
    2,656
    GPU:
    RX 5700 XT/GTX 1060
    Will give it a go. Cheers will report back in a bit.
     
  18. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    3,334
    Likes Received:
    2,656
    GPU:
    RX 5700 XT/GTX 1060
    FIXED IT:
    The issue was the 20.7.1 driver. Rolled back to 20.5.1 HWS - everything is working great now.

    Thank you to everyone for their support and suggestions.

    Update:
    And it's back.

    Update2 + Solution:
    I thought it was the cache, however, finally narrowed down what was causing this behavior.

    For what ever reason it doesn't seem to like those two:

    Tesselation Mode and Anti-Aliasing

    Tesselation mode has to be set to AMD Optimized (Prior to this I was testing with "Use Application Settings" hence that was the default, it was resulting in glitches)
    With any other setting, it glitches all over the place.

    Anti-Aliasing works only if set to "Enhance Application Settings"

    Hope this helps someone in the future.
     
    Last edited: Jul 13, 2020
    Krteq and OnnA like this.
  19. Astyanax

    Astyanax Ancient Guru

    Messages:
    8,466
    Likes Received:
    2,840
    GPU:
    GTX 1080ti
    does ME1 even have tesselation?
     
  20. mbk1969

    mbk1969 Ancient Guru

    Messages:
    10,050
    Likes Received:
    7,057
    GPU:
    GF RTX 2070 Super
    Of course no, but it seems that drivers just create problems for itself with its own settings combination(s).
     

Share This Page