Mafia 2 Thread

Discussion in 'Games, Gaming & Game-demos' started by GT40Nutcase, Aug 21, 2007.

  1. Drazio

    Drazio Banned

    Messages:
    363
    Likes Received:
    0
    GPU:
    FVCKING
    [​IMG]

    Highest detail @ 1680x1050

    So, everyones game look's amazing with detailed graphics and clear picture?

    As shown in my screen shot everything is blurred/distorted..it looks worst while playing..wtf?..
     
    Last edited: Aug 11, 2010
  2. lmimmfn

    lmimmfn Ancient Guru

    Messages:
    10,458
    Likes Received:
    127
    GPU:
    AorusXtreme 1080Ti
    just ran it with physx on medium, everything high, vsynch off, and resolution of 3840x1024 got min 12.2FPS, average 41, max 166.7 on the benchmark. My 8800GT and 5850 were maxed on gpu usage at the end though.

    Theres some weird vsynch thing going on though because the FPS hover at 30FPS or 60FPS and only fluctuate for less than a second to around 40FPS or 80FPS
    [​IMG]
     
    Last edited: Aug 11, 2010
  3. Indeo

    Indeo Ancient Guru

    Messages:
    1,552
    Likes Received:
    0
    GPU:
    XFX 5970@950\1200 + GT240
    Same here. Vsync is broken.
     
  4. lmimmfn

    lmimmfn Ancient Guru

    Messages:
    10,458
    Likes Received:
    127
    GPU:
    AorusXtreme 1080Ti
    ahh cheers, glad its not just me
     

  5. crushilista

    crushilista Ancient Guru

    Messages:
    3,471
    Likes Received:
    0
    GPU:
    MSI GTX 670
  6. Cyrosis

    Cyrosis Ancient Guru

    Messages:
    1,560
    Likes Received:
    1
    GPU:
    HD4000
    Same super blur I mentioned in the other thread. It would look good if they removed that post processing.

    Forcing AA in nhancer and turning off the in game "AA" got the real thing working, but the blur remained so it really didn't help anything.
     
  7. Insomniac34

    Insomniac34 Ancient Guru

    Messages:
    1,903
    Likes Received:
    0
    GPU:
    GTX 460 768mb (800/1900)
    When playing, I couldn't help but notice how bad the power cables looked. It's pretty hideous to be honest. Anything in the distance is just way too blurry and borders on distracting. My game looks nothing like the image Crushilista posted on the previous page (comparing Mafia I to Mafia II), and that's with everything maxed at 1600x900 (PhysX off). Just have to hope that the full version has more graphics settings.
     
  8. Cyrosis

    Cyrosis Ancient Guru

    Messages:
    1,560
    Likes Received:
    1
    GPU:
    HD4000
    That screenshot is from 2 or more years ago, apparently before they stuck their head's up their arse's.
     
  9. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,509
    Likes Received:
    2,906
    GPU:
    MSI 6800 "Vanilla"
  10. Drazio

    Drazio Banned

    Messages:
    363
    Likes Received:
    0
    GPU:
    FVCKING

  11. serbicu

    serbicu Ancient Guru

    Messages:
    2,320
    Likes Received:
    418
    GPU:
    RTX 2080Ti
    yeah i saw that..PhysX enabled
     
  12. isidore

    isidore Ancient Guru

    Messages:
    6,276
    Likes Received:
    58
    GPU:
    RTX 2080TI GamingOC
    Huge performance improvement with the fix
    here, guys: every thing on and max out, including physx 1680x1050
    with npc's cloth
    [​IMG]

    without npc's cloth
    [​IMG]

    and now in game no more fps drops and increases randomly + much better fps..
     
    Last edited: Aug 11, 2010
  13. °L°

    °L° Master Guru

    Messages:
    288
    Likes Received:
    4
    GPU:
    GTX 970
  14. pedropaulo

    pedropaulo Ancient Guru

    Messages:
    2,305
    Likes Received:
    91
    GPU:
    HD5850
  15. serbicu

    serbicu Ancient Guru

    Messages:
    2,320
    Likes Received:
    418
    GPU:
    RTX 2080Ti
    quote:

    Nvidia has revealed new PhysX System Software package – 9.10.0513

    According to release notes, main difference from previous PhysX drivers is

    •Bug fixes for Mafia 2
    You can download 9.10.0513 PSS from here

    Update: We can’t notice any performance increase in Mafia II.

    i updated my PhysX driver also but no difference at all...i'm curently running the demo with the cloth mode.
     

  16. eclap

    eclap Banned

    Messages:
    31,495
    Likes Received:
    4
    GPU:
    Palit GR 1080 2000/11000
    Ooh, what fix!? Sorry I'm at work on my blackberry and don't have time to search for it :)
     
  17. Copey

    Copey Ancient Guru

    Messages:
    10,710
    Likes Received:
    0
    GPU:
    960 2GB
  18. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,509
    Likes Received:
    2,906
    GPU:
    MSI 6800 "Vanilla"
    There was apparently a issue with .552 where it didn't properly initialize or something (As explained in another article on the above PhysXInfo website as well.) but could be worked around by reinstalling the drivers, these .553 probably solves that issue and might help with some other smaller bugs in the PhysX drivers if there are any.
     
  19. TheHunter

    TheHunter Banned

    Messages:
    13,405
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    same here, although i saw a little boost @ high apex and only Vito's suite.

    [​IMG]

    vs old physx driver and all cloth
    [​IMG]


    Nvidia coders and physx sucks big time, and dont tell me my gpu sucks i know it does, but still now on last sequence (window explosion) there is avg of 26fps, before 33fps.. great optimization yes!!!
     
  20. isidore

    isidore Ancient Guru

    Messages:
    6,276
    Likes Received:
    58
    GPU:
    RTX 2080TI GamingOC
    you don't need new drivers, we need a patch the game physx engine has issues..disabling cloth for npc's helped a lot, if the full game will have the same bugs then that's gonna be the only way to play it smooth with everything at max, including physx.
     

Share This Page