1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

M.2 not showing in bios

Discussion in 'SSD and HDD storage' started by macdaddy, Aug 14, 2019.

  1. macdaddy

    macdaddy Ancient Guru

    Messages:
    2,400
    Likes Received:
    4
    GPU:
    TITAN X
    I'm having trouble getting the Asrock x570m pro the see my m.2 Nmve xpg pro. Things l tried.
    1. Updated the bios
    2. Disable CSM as suggested by Google search
    3. Loaded windows on normal ssd and going to disk management. M.2 not there.
    Trying to get the m.2 to show up so l can do fresh install of Windows 10. Loading up windows installation from uefi usb windows does not see drive and ask for drivers.
    Is this the Motherboard or m.2 is dead ? I don't have any other means to test the m.2 and l don't have spare m.2 to test.
     
  2. Syranetic

    Syranetic Master Guru

    Messages:
    450
    Likes Received:
    66
    GPU:
    GB RTX 2080 Ti
    Going to go out on a hunch and suggest that perhaps it wasn't installed correctly.

    You would think it's pretty idiot proof but my new mobo had this heatsink arm with an adhesive strip that you attach the M2 and then insert one end into the mobo before screwing it in. In my case I had to reseat it because during installation it shifted just enough that it had improper contact.

    Once I did that it showed up in my BIOS.
     
  3. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    36,104
    Likes Received:
    5,132
    GPU:
    AMD | NVIDIA

    I have to concur with the previous post - 9 out of 10 times a reseat or move to another m2 slot helps. Push it in tightly.
     
  4. macdaddy

    macdaddy Ancient Guru

    Messages:
    2,400
    Likes Received:
    4
    GPU:
    TITAN X
    I tried it on both of my m.2 slots on the mobo. And have already reseat it a few times.
     

  5. macdaddy

    macdaddy Ancient Guru

    Messages:
    2,400
    Likes Received:
    4
    GPU:
    TITAN X
    Thanks guys. You were right. I did reseat it a few times but as l screwed it down it just loosen that tiny bit. So l just screwed lightly and pushed it hard into the slot. Heard a click and I'm up and running again. Thanks
     
  6. Caesar

    Caesar Master Guru

    Messages:
    728
    Likes Received:
    260
    GPU:
    GTX 1070Ti Titanium
  7. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    36,104
    Likes Received:
    5,132
    GPU:
    AMD | NVIDIA
    Awesome, enjoy the new rig mate :)
     
  8. macdaddy

    macdaddy Ancient Guru

    Messages:
    2,400
    Likes Received:
    4
    GPU:
    TITAN X
    Hi again. I seem to hit a roadblock with my xtg pro. So after getting it see in bios and windows setup. I tried to install window but keep on getting " window cant install on this locaton".
    So after going through trouble shooting the drive. I found out the the drive is stuck to 'read only' l tried using diskpart to clear the read only attribute and to clean it but still stuck on read only. Anything else l can try before returning it to store ? Seems like a faulty drive if it's locked itself to read only.
     
  9. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    36,104
    Likes Received:
    5,132
    GPU:
    AMD | NVIDIA
    Yeah you should return it, it all should not be that difficult.

    Before you do please check if CSM is Enabled. If for whatever reason there is a GPT/EUFI tied partition on the unit it could be conflicting.
     
  10. SweenJM

    SweenJM Master Guru

    Messages:
    536
    Likes Received:
    273
    GPU:
    Sapphire 590 nitro
    I just built a system with same board and an nvme system drive (wd sn750) and had zero issues. Sounds like the drive to me too. I might also add to try a different build of windows 10 to install with just for kicks.......strange i know, but i have had some weirdness with installs from one build to the next (i used 1809 for the system i built with x570m pro-4)
     

  11. macdaddy

    macdaddy Ancient Guru

    Messages:
    2,400
    Likes Received:
    4
    GPU:
    TITAN X
    I will try with csm enabled after work. The thing also is that l booted into windows on another drive to take a look at the m.2 in drive management. I was able to partition the m.2 to GPT. I tried to initualize the unallocated drive (m.2) but couldn't it as the option was greyed out. That's where l found that Windows was reporting the drive as 'read only'
     

Share This Page