LOD bias not working

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by PAINTEDWINGS, Apr 5, 2013.

  1. PAINTEDWINGS

    PAINTEDWINGS New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    550 gtx
    I play dota 2 and TF2 on steam. I was running a high LOD bias using sli profile tool on tf2 successfully until I got my new graphics card, a geforce gtx 550 ti. Since then, I have not been able to change the LOD bias on either dota 2 or tf2. I have tried both sli profile tool and nvidia inspector, neither of which seems to have any effect at all. I also tried rivatuner but obviously it doesn't really work with any drivers made in the last decade or so. I've been told by a friend that there might be some setting in my nvidia control panel that's overriding the NVI settings, but I've searched for one to no avail. As far as I can tell, profile tool and NVI simply have no affect whatsoever with this graphics card, although I find that unlikely for several reasons. I've literally spent that last 10 hours googling through forums for an answer to my problem and there is seemingly none. Naturally at this point I'm frustrated ad absurdum and I would really just like anybody to give me an answer to give me a way to play these games on with a LOD bias of 15. I would most certainly assume that the reason it isn't working is pretty simple, although on the other hand, I'm not a complete retard and I did press make sure to apply the settings from NVI.
     
  2. PhazeDelta1

    PhazeDelta1 Moderator Staff Member

    Messages:
    15,613
    Likes Received:
    1
    GPU:
    EVGA 1080 FTW
    Did you change LOD bias in Inspector from clamp to allow?
     
  3. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,689
    Likes Received:
    0
    GPU:
    ASUS GTX 980 STRIX
    LOD bias does not work manually unless you set "Driver controlled LOD Bias" to "Off" in Nvidia Inspector

    Clamp basically does nothing now. If you have DCLB on Clamp will not stop the driver from adjusting automatically.
     
  4. PAINTEDWINGS

    PAINTEDWINGS New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    550 gtx
    I'm having a bit of difficulty believing that DCLB was my problem. In my several hours of messing around with the program, I'm pretty sure I tried it multiple times with it off. Regardless, I did so again just now and still it doesn't work. It's something that's very good to know, and I appreciate it, but doesn't solve my immediate problem. It also doesn't really explain why the geforce SLI profile tool won't work. Any other takers? This is still a very pressing issue for me, and I appreciate any and all input.
     

  5. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,689
    Likes Received:
    0
    GPU:
    ASUS GTX 980 STRIX
    Hm. Well, i'm not sure now. I don't know about SLI Profile Tool(Since never used SLI before)

    And as far as LoD Bias goes, maybe the source Engine has an internal console command for that ?


    Also, this is a long shot but is your NVCP set to https://i.minus.com/iM2uO9PU3k8rS.png
     
  6. PAINTEDWINGS

    PAINTEDWINGS New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    550 gtx
    Yeah, it is set to that. I assume that's what it's supposed to be? I'm very familiar with the source engine, and it has a few console commands for example mat_picmip which reduces texture quality, but is limited to a certain degree, not sure how it translates to a lod bias but it's probably limited to 2-4 positive or so. I used the profile tool to bypass the limit, of course, but there shouldn't be a conflict; the video card settings from profile tool and NVI should simply override any console commands or steam settings. I actually thought your long shot was going to work, because that was a setting I didn't quite understand and looked promising, but I went to the page on my control panel and it turns out that I was using that setting already anyway. Any other long shots?

    EDIT: One last clue, which probably won't help at all. In the process of messing around with the sli tool or nvidia inspector (not sure which), the only thing about either of my games that seems changed is that now TF2 has a lighting error wherein the screen flashes fullbright rapidly (the terrain flashes fully lit for a second, losing all shading aspects), at least once per second.
     
    Last edited: Apr 5, 2013
  7. rewt

    rewt Maha Guru

    Messages:
    1,245
    Likes Received:
    0
    GPU:
    LOD Bias and Clamp settings are broken in Direct3D for a while now. Last I remember it working properly was pre-300 series drivers. Try it if you want.

    For most games it wouldn't really matter what it was set on, since the setting only works to clamp in OpenGL. I think both games he mentioned are Direct3D but I'm not sure.

    There is somewhat of a sloppy workaround in 300 series drivers, if you set supersampling transparency mode to AA_MODE_REPLAY_MODE_ALL in Inspector then custom lod bias usually gets applied in-game.
     
    Last edited: Apr 5, 2013
  8. PAINTEDWINGS

    PAINTEDWINGS New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    550 gtx
    The AA_MODE_REPLAY_MODE_ALL worked perfectly. Thanks rewt.
     
  9. brendanvista

    brendanvista Master Guru

    Messages:
    237
    Likes Received:
    0
    GPU:
    GTX 980 Ti
    I can successfully set a high LOD bias manually, in dx9, in 306.97. It's my understanding that after that set, the driver automatically does it, and that works with dx10 and 11. I'm not sure what this setting "Driver controlled LOD Bias" is though.
     
  10. brendanvista

    brendanvista Master Guru

    Messages:
    237
    Likes Received:
    0
    GPU:
    GTX 980 Ti
    I can successfully set a high LOD bias manually, in dx9, in 306.97. It's my understanding that after that set, the driver automatically does it, and that works with dx10 and 11. I tried setting the AA to AA_MODE_REPLAY_MODE_ALL, and that worked in later drivers. So I guess that's the work-around for now. I'm not sure what this setting "Driver controlled LOD Bias" is though.
     

  11. PAINTEDWINGS

    PAINTEDWINGS New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    550 gtx
    I'm able to freely change my LOD now, which is great. Thanks again for the help. However, in dota 2 (I don't know if you guys are familiar), increasing the lod gives me a problem, as it not only blurs terrain but the minimap as well, which of course leads to me not being able to read my minimap properly. Hence, I can really only use a lod bias of 1-1.5 while still being able to play properly. The source console command mat_picmip 4 (only accessible with sv_cheats 1) does something very similar to the high lod bias...but it doesn't affect the minimap. I know this is a longshot and probably impossible, but is there any way with settings to make the lod bias affect only the terrain and not the minimap? It probably depends on how the valve developers implemented the minimap texture into the game, but I don't know what most of the driver settings do, and it's possible from my eyes that if the texture for the minimap was implemented in a different way from the world textures, that one of the settings on NVI might be able to make the lod bias affect one without the other. If possible, this would be great; thanks again guys.
     
  12. MrBonk

    MrBonk Ancient Guru

    Messages:
    2,689
    Likes Received:
    0
    GPU:
    ASUS GTX 980 STRIX
    You may want a negative value for LOD if you want it sharper. Positive values make it more blurry.



    Also: Driver Controlled LoD Bias in new drivers is basically the new clamp in a way.

    With it on, in SGSSAA the driver automatically does adjustment ALA Hybrid OGSSAA modes (like 8xS for example). If you turn it off you are free to do manual adjustments in SGSSAA.(Other AA modes possibly as well)
     

Share This Page