Limiting framerate and stutter

Discussion in 'Videocards - NVIDIA GeForce' started by draker696, Sep 29, 2012.

  1. draker696

    draker696 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Gigabyte GTX 570 1.25GB
    Everytime I limit framerate in a game so I don't get beyond my monitor's refresh rate(60hz) be it at 30fps, or 60 fps, it will always cause horrendous ammounts of stutter.

    limiting framerate at 30fps not only causes stutter but also obviously reduces overall quality of gameplay and adds a big delay.
    limiting framerate at 60fps has an even worse stutter effect, tearing is so noticeable it feels like i'm playing at 30fps.

    Not sure if it's my crappy monitor (IIyama prolite 2008HDS), this happens in every, single, game.

    When I record my games, they look normal, but when I'm actually playing them, they look horrendous.

    Using the latest beta drivers atm, and yes, this happens with every driver I've tried.
     
  2. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,621
    Likes Received:
    943
    GPU:
    6800XT Nitro+ SE
    Try enabling Vsync and triple buffering either in nvidia control panel or using a third party software such as D3DOverrider to force it on. Or just use in game option if available. This should iron out some of your stutter but may give you a little mouse lag.

    I find a consistent 30fps locked in BF3 is enough for me to play the game, yeah its nowhere near as smooth as 60fps which I can easily get with high-ultra settings but for true ultra I cap my fps at 45fps which for is more than enough.

    Also try using DXtory to cap frame rates as for me Afterburner is a little laggy for me and is still pretty buggy as I use the latest beta version.
     
  3. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    6,954
    Likes Received:
    959
    GPU:
    GTX1080Ti
    Are you exceeding your frame buffer?
     
  4. draker696

    draker696 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Gigabyte GTX 570 1.25GB
    No, never actually managed to do that.
     

  5. draker696

    draker696 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Gigabyte GTX 570 1.25GB
    When I enable v sync at 60fps, stutter is almost non existent, tearing of course disappears and everything is smooth although with a little bit of input lag.

    My problem is that not every game is stable enough to use v sync.
    Games like for exemple guild wars 2 are unplayable with v sync, framerate jumps all over the place.


    There's also this little problem I have, not sure if it's just me, but every time for exemple a cutscene plays out in a game and the camera usually moves by itself, I notice skipping(or stutter, not sure what to call it), this happens even when using v sync btw and happens around every second, it's small, but it's constant so it's noticeable.

    This is specially apparent in games like prototype.
     
  6. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,621
    Likes Received:
    943
    GPU:
    6800XT Nitro+ SE
    Prototype was and still is a VERY VERY bad console port. Your not going to have much luck there I am afraid. A lot of people still have bad performance in that game.

    Try and ALT+TAB out of a game, load up task manager and try changing the priority of the game to something like High or Realtime.

    Disable any anit viruses you have running (i use microsoft security essentials and it has never interfered with any of my games).

    I know this might sound silly, but do a complete system defrag not a quick one a complete defrag. Might help out when games are trying to load new data on the fly. disable any background defrag options as well this can seriously hurt loading and cause stutter.

    Lastly try looking into disabling core parking if your on Windows 7. Which will "park" idle cores of your CPU essintially turning them off if not needed, this helped me out and made my PC a little more responsive. Not sure if it will effect your CPU though but its worth a try.

    Oh yea and defrag your Page File too, easiest way to do this is completely turn off page file, set everything to zero, reboot, now go to run, type cmd, then type chkdsk, then set your page file back and restart. Also dont set page file too high. For 4GB system RAM you should set page file to around 2GB (2048MB). Never more than system RAM as games will try and use this instead and this can seriously hurt game performance. W7 default is probably the best option with this one.

    Sorry for rambling on and on LOL Ive just finished work from a 12 hour night shift and I'm trying to stay up with cans of red bull and energy pills lol. hope this helps.
     
  7. draker696

    draker696 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Gigabyte GTX 570 1.25GB
    No problem man, I will try all those things you suggested.

    Btw, how do I disable core parking?

    And should I disable Vdrop, and other features in the bios?
     
  8. KopyKat007

    KopyKat007 Master Guru

    Messages:
    256
    Likes Received:
    0
    GPU:
    EVGA GTX 960 SC
    If your talking about Prototype 2 especially then i must agree, its a terrible port lol.
     
  9. draker696

    draker696 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Gigabyte GTX 570 1.25GB
    Alright, disabled core parking and now my cpu is a bit cooler, and all it's threads are being evenly used now.
    Also disabled Vdrop and intel speedstep just to be sure, don't notice much of a difference tbh.

    Ran guild wars 2 for a bit, it's definitly faster now in both pvp and pve.
    Already defrag'd, I removed the pagefile completly, I don't notice much of a difference with this.

    I guess it kinda is fixed, will test a bit more.
     
  10. Brendruis

    Brendruis Maha Guru

    Messages:
    1,242
    Likes Received:
    1
    GPU:
    Reference GTX 680 SLI
    the frame limiter does cause stuttering/jerkiness problems in many games but in others it helps even when VSYNC is already on

    its very strange but I suspect that nVidia has some work to do on this feature... probably why it isn't officially included in the NVCP.
     

  11. draker696

    draker696 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Gigabyte GTX 570 1.25GB
    Disabling core parking helped a bunch on performance, but the stutter itself still appears.
    Cpu usage is much more stable now, and temperatures are a bit lower, but the stutter itself still appears.

    For exemple, in league of legends you can limit the game's framerate, when I limit it to 60 in the game, it runs choppy, real choppy, but when I change it to " benchmark " for max fps, it runs at 150+ and looks smooth as can be, 0 stutter, in fact it doesn't even tear much.
     
  12. draker696

    draker696 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Gigabyte GTX 570 1.25GB
    Another thing, some applications are crashing because I disabled pagefile.

    This isn't really related, but what's the recommended pagefile if I have 4gb ram?
     
  13. Noisiv

    Noisiv Ancient Guru

    Messages:
    7,890
    Likes Received:
    1,208
    GPU:
    2070 Super
    STOP "tweaking" is recommended :)
    Ofc all above sounds like it's a bit too late now...

    1.5 times the amount of RAM, on the disk, partition not hosting OS.
     

Share This Page