1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Limiting FPS hugely impacts performance, need help [am pleb]

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by Horst1470, Dec 11, 2018.

  1. Horst1470

    Horst1470 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    EVGA FTW GTX 1070
    Hello,

    I recently bought a 144Hz Monitor, mainly use the 144Hz for Rainbow Six Siege. With unlimited FPS, the game ran at 160-200 FPS, which did not feel fluid or good to me, so I wanted to limit the FPS to match my screen's 144Hz. Since my nVidia Inspector only allowed me to cap the FPS at max. 120Hz, I searched the internet and found the RTSS 7.1.0 + Afterburner 4.5.0 package. I selected the Rainbow6.Exe and capped it to 144Hz and all was well, for a while.

    Recently, I've been having TONS of problems of getting Siege to run at 144Hz, no matter how low I turned the settings, I was never getting the consistent 144Hz I wanted. It would hit 144 for a second, dip to 120, go to 130 but never constant at 144Hz, which is a very stuttery and unpleasant experience. I was thinking that maybe my CPU is too bad for the game or whatever and was going crazy. Yesterday RTSS crashed, and the game had unlocked FPS. It was running at 180+ FPS, never dipping below 160. When I started RTSS and activated the cap, it suddenly dropped to 130, again the problematic experience. If I deactivated the cap, the game ran again at 180-220 FPS, never dropping below 170.

    I googled a lot, but never found a solution that worked for me. Is this a common error? My PC obviously has the power to run Rainbow Six at 144Hz, if it can run it at 160+ consistently, why cant I run it at 144Hz consistently then? Also if I lowered the cap to 120, it would run at an even lower framerate etc.. Does anyone know how to fix it and get the game running at 144Hz consistently?

    My specs are the following:
    GTX 1070
    I5-6600
    16GB RAM

    Appreciate any help!
     
  2. Andy_K

    Andy_K Master Guru

    Messages:
    399
    Likes Received:
    29
    GPU:
    MSI GTX 960 OC
    Do you have OSD enabled?
    If so: did you try the various OSD rendering modes?
     
  3. Horst1470

    Horst1470 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    EVGA FTW GTX 1070
    OSD was disabled for me. FPS display was from nVidia Shadowplays overlay
     
  4. -Tj-

    -Tj- Ancient Guru

    Messages:
    16,255
    Likes Received:
    1,400
    GPU:
    Zotac GTX980Ti OC
    No1 rule

    Don't use more then 1 monitoring app at the same time.



    That said either enable msi ab ost or try nvidia fps limiter, but you need nvinspector for that.. it's a nvcpl profile editor, it has two types of limiting. Try fps limiter v2
     
    Andy_K likes this.

Share This Page