Legacy Modder

Discussion in 'Videocards - AMD Radeon Drivers Section' started by AmiloMan, May 9, 2013.

Tags:
?

Do Legacy users need a driver Mod tool?

Poll closed Jun 8, 2013.
  1. Yes

    75.0%
  2. No

    25.0%
  1. AmiloMan

    AmiloMan Master Guru

    Messages:
    338
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    Hi all, I was wondering why no-one has made a modder for the legacy drivers and I have a few questions in mind:

    1. Has AMD changed its stance on their drivers being modded by MOD tools?
    2. What red tape is there, does someone need express permission from AMD to make a modder?
    3.How about Logo usage? I'm referring to the old ATI Logo, if someone was to use it is permission required or is there like a "fair use clause" about this as well?

    I wonder if Legacy users are in for a new modder?
     
  2. AmiloMan

    AmiloMan Master Guru

    Messages:
    338
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    Thanks for voting guys, keep them coming.

    How come no one has replied to the post?
     
  3. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    red tape? the code is GONE from the dlls, there's nothing to mod

    all you can do is make a frankenstein driver out of mixing dlls from various sets that contain legacy code (or that dont die on legacy cards)

    http://forums.guru3d.com/showthread.php?t=374236 kev is doing all the work anyway, i'm too lazy

    yes i am 100% ignoring dellon's thread, not sure why it still exists, i inspected the dlls in one of his so called modded drivers, the game profiles were extremely out of date, clearly using a dll from years ago that looks like similar filesize to the newer drivers (since the legacy code removal reduced the filesize)

    EDIT: my mistake, your legacy is the previous legacy from 2010, but the same situation applies, the code is removed in spots where you need legacy code, the main thing is newer d3d & ogl dlls would not work at all usually

    EDIT2: lulz just saw that you're apparently making a tool already, & i even replied in that other thread back in 2012 :infinity:
     
    Last edited: May 28, 2013
  4. AmiloMan

    AmiloMan Master Guru

    Messages:
    338
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    DirectX 10 card users are still lucky that they can Mod the drivers without a lot hassle, for DirectX 9 cards its much worse since the newer legacy dll's wont even run on the cards.
    Kev is doing an awesome job for the DirectX 10 crowd wish we could have the same for Directx9 cards but I know its next to impossible .

    The only solution for DirectX 9 card users is using Frankenstein drivers which from my testing are pretty stable, DXVA was broken anyway... I can't remember the last time I used DXVA only up until I modded my drivers and am getting pseudo DXVA to work.
    [​IMG]

    Unfortunately we can't really be picky about what we want and how we want it because we have 1 set of drivers that are from 2010 to use or even worse we can only resort to using drivers from early 2009 and below.The simplest thing like hardware acceleration in firefox was impossible :wanker: because of driver issues, but the mod actually allows us to use good old hardware acceleration.
    [​IMG]
    Firefox and other browsers are smooth as butter now, Even aero is more responsive not to mention gaming got better as compared to using 10.2, the difference is clear.
    These small improvements are a reason for me to install the modded drivers.Its fairly stable with no crashes in applications or kbsync errors.

    Yes you are right kn00tcn there is nothing to mod in the dll's since I read that everything has been stripped from the newer drivers but using compatible legacy: kernel,3d,and dxva files gets it working just fine.Frankenstein Lives!!!!!
    [​IMG]

    This is enough reason for me to use them and to build a modder that makes the process easier everytime a new driver comes out, given the option of choosing between the 10.2 legacy driver lolz and the new modded ones I think we all know the answer to that;)
     
    Last edited: May 28, 2013

  5. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Hmm... If you don't mind me asking are you by chance referring to the Dx9 dll? if so then it would probably be best for you take a look at it again since those files have changed over the last two to three month's.

    So, you are currently working on a tool that allows you to download any modded driver while also linking users to the forum of the modded driver to report a problem if necessary?
     
    Last edited: May 28, 2013
  6. AmiloMan

    AmiloMan Master Guru

    Messages:
    338
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    Well... the modder should be able to mod the new drivers that come out,its not a down-loader.The user will download and extract the driver of choice as usual and use the mod tool to get the driver to work on the system.No files will be added or altered, just replacing newer incompatible ones with older compatible ones.

    As to what Dll's he was referring I have no clue, i'm not familiar with your drivers. Did you manage to get your drivers to work on Legacy DirecX 9 cards using the new driver dll's that came out:eek:?
     
    Last edited: May 29, 2013
  7. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    My drivers only support HD 2000 to HD 6000 Graphic cards....The x2100 and any x1000 series graphic card are unsupported as the code does not exist. I'm a bit curious as to whether or not you managed to get your current Gpu working with any of the Official Amd Drivers (Or is your HD 2300 a rebranded Graphic Card?). Also I would like to ask if your current Gpu is an AGP card or a PCIE.
     
    Last edited: May 29, 2013
  8. AmiloMan

    AmiloMan Master Guru

    Messages:
    338
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    Yes my card is a rebranded x1300 with UVD and its a PCIE.
    When the official legacy drivers came out they refered to HD 2000 as being in the supported card list but I came to find out that the dime stops at 2400 or is it 2350 just short of 2300:bang: . None of the new drivers work,even the legacy one's, the last working driver set was 10.2 and i'm not satisfied with their performance at all after all this time.Modding them keeps me in the times, well partially anyway......Its better than what we had. Every modder mods for DX10 cards and its impossible to install any of the drivers, since the 1 thing in common with all the cards in the support list of the new legacy drivers is that they are all DX10.

    So we have to improvise by using older dll's since the new legacy dll's are a No-go.You say your drivers support HD2000 - 4000 but aren't all of them Dx10 cards? Mine is HD2300 but I don't think it falls in that list because its a DirectX 9. Any thoughts?
     
  9. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    The Atiumdag.dll and the Atiumd64.dll are responsible for Dx9 Functionallity. I recommend you try using those dlls from Ati Catalyst 10.3 if it works try dx9 files from the driver after 10.3.
     
  10. AmiloMan

    AmiloMan Master Guru

    Messages:
    338
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    Yeah... tried them before and it didn't work, if it did then would have tried all the way higher up to the last working version but no none worked.
    Sometimes I use my OEM Atiumdag.dll from the manufacturers site which surprisingly gives really good 3D performance compared to the regular one's released by AMD/ATI.
    It is dated all the way back 2007:infinity:
     

Share This Page