Left 4 dead 2 Performance drop

Discussion in 'Videocards - AMD Radeon Drivers Section' started by sideeffect, Jul 31, 2010.

  1. sideeffect

    sideeffect Master Guru

    Messages:
    323
    Likes Received:
    34
    GPU:
    Vega 56
    Anybody else having bad performance with Left 4 dead 2 on recent drivers?

    Problems started around the 10.6 drivers but it could also be a game update or the new mods. The FPS always used to be constant 60 with Vsync and now it drops to as low as 10FPS at some points.

    None of my other games seem affected.
     
  2. xXx_Fess_xXx

    xXx_Fess_xXx Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    Hd5850
    I have the same problem if I turn Super Sample AA mode in CCC with x8AA in game. But if I set x4AA it works fine
     
  3. crushilista

    crushilista Ancient Guru

    Messages:
    3,471
    Likes Received:
    0
    GPU:
    MSI GTX 670
    Supersampling+ L4D2 is murder. That may well be the reason; was for me.
     
  4. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,627
    Likes Received:
    480
    GPU:
    MSI 5600XT G. MX
    Supersampling is murder for all the games.
    Adaptive should be used always.
     

  5. xXx_Fess_xXx

    xXx_Fess_xXx Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    Hd5850
    ye but games like TF2 and L4D2 looks so ****ty without Supersampling
     
  6. fellix

    fellix Member Guru

    Messages:
    195
    Likes Received:
    35
    GPU:
    KFA² GTX 1080 Ti
    I play L4D2 with 4xSSAA at 1680*1050 -- 60 FPS most of the time v'sync-ed and triple buffering. Haven't had any performance issues with any Catalyst release.
     
  7. AbjectBlitz

    AbjectBlitz Ancient Guru

    Messages:
    3,462
    Likes Received:
    2
    GPU:
    R390 1200/1720
    Not sure about L4D2 but got a big performance drop in TF2 with the latest drivers. 10.5a fastest all round the only problem being they have no profiles for newer games like SC2.
     
  8. ShadowMyth

    ShadowMyth Ancient Guru

    Messages:
    3,490
    Likes Received:
    0
    GPU:
    GByte GTX 980 G1 Windforc
    Just as a comparison, I play L4D 2 max in-games AA & settings @ 1920x1080 with AA-Transparency set to 8xSS & average around 55 fps, dropping on the rare occasion to 42 fps. This is on a GTX 470 & Phenom II x4 940BE @ 3.57GHz.
     
  9. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,627
    Likes Received:
    480
    GPU:
    MSI 5600XT G. MX
    Yes, they have.
    At Driver level.
     
  10. AbjectBlitz

    AbjectBlitz Ancient Guru

    Messages:
    3,462
    Likes Received:
    2
    GPU:
    R390 1200/1720
    Ok so you show me how you get Crossfire and AA working in SC2 with 10.5a then. You cant because there is no profile in 10.5a for it at driver level.
     

  11. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,627
    Likes Received:
    480
    GPU:
    MSI 5600XT G. MX
    Lol, I am sorry. I read "TF2" instead of SC2
     
  12. sideeffect

    sideeffect Master Guru

    Messages:
    323
    Likes Received:
    34
    GPU:
    Vega 56
    I still have this problem. I thought I had fixed it by disabling the steam overlay and afterburner overlay but it still happens after a few maps.

    It could be a windows 7 x64 problem as there was an identified issue with the game and slowdowns after map changes with that OS but it never happend to me before the last few weeks.

    Changing the settings has no effect.
     
  13. lenne

    lenne Master Guru

    Messages:
    352
    Likes Received:
    0
    GPU:
    1080 GTX Gainward
    Is ur gfx loud ? seems like it caught a lot of dust, clean it and check ur overall cooling in the case.
     
  14. sideeffect

    sideeffect Master Guru

    Messages:
    323
    Likes Received:
    34
    GPU:
    Vega 56
    The GPU never gets above 70 degrees. I have a Xigmatek Utgard case with 7 x 120mm - 170mm high cfm Xigmatek fans and a constant case temp of 25 degrees.
     
  15. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    BTW, steam games / engine love edge-detect AA ........
     

  16. lenne

    lenne Master Guru

    Messages:
    352
    Likes Received:
    0
    GPU:
    1080 GTX Gainward
    hmm strange, sounded exactly like an overheating problem, hows ur cpu ?
     
  17. sideeffect

    sideeffect Master Guru

    Messages:
    323
    Likes Received:
    34
    GPU:
    Vega 56
    CPU is cooled by a Xigmatek Dark Knight cooler and is only 40 degrees under heavy load.

    All my other games are working fine its only a problem with L4d2. I think i will rollback drivers to 10.5 to see if the problem goes away.
     

Share This Page