KoTor vs. Win7 vs. atioglxx.dll

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by atomic_dumpling, Feb 19, 2010.

  1. atomic_dumpling

    atomic_dumpling New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Radeon HD5770
    Hello,

    I searched through the steam, Bioware and Lucas Arts forums for hours, but I just can't get my steam version of "Knights Of the Old Republic" to work. Most people experience crashes mid-game, but in my case I can't even start it, because the atioglxx.dll throws an exception at me which points to an OpenGL problem (see below). I am currently running the official Catalyst 10.2 on Win7 x64. I've read that many people can play it fine on Win7, but sadly not me.

    Code:
    swkotor.exe 
       1.0.3.0 
       00000000 
       atioglxx.dll 
       6.14.10.9551 
       4b68f509 
       c0000005 
       00031a60 
       c98 
       01cab0ef81e018a0 
       G:\Steam\steamapps\common\swkotor\swkotor.exe 
       C:\Windows\system32\atioglxx.dll 
       bfd4dfb0-1ce2-11df-a53c-f0b094c49ccd
    The KoToR hardware check spits this out:

    [​IMG]

    I have tried a lot of things, to no avail. I even put different DLLs in the game folder, from Cat 4.2, 9.7, 9.3, 8.5 - it still crashes. Sometimes I can watch the intro videos before the CTD. According to Win7 my system runs at actual 60Hz, so the infamous "59Hz bug" isn't the problem either.

    I also tried different stuff with the INI file and even tried a crack (which is needed for the widescreen fix anyway), but still no joy.

    I am open to suggestions. As I said, it looks like an OpenGL-problem to me. I know this game is a technical desaster (especially the steam version), but I am not giving up yet. I guess it's just a matter of finding the right DLL.

    Thanks, Chris

    EDIT: In case you are wondering, I played through Dragon Age and ME2 multiple times without incident and my rig is Furmark and prime95 stable. Furmark is also proof that OpenGL itself works.

    EDIT2: Just ran the rendering tests in the OpenGL Extension Viewer - everything works from 1.1 to 3.2
     
    Last edited: Feb 19, 2010
  2. MerolaC

    MerolaC Ancient Guru

    Messages:
    2,818
    Likes Received:
    0
    GPU:
    Sapphire NITRO R9 390 8GB
    By any chance, do you have installed Matlab?

    If so, uninstall it.
     
  3. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    26,666
    Likes Received:
    34
    GPU:
    Inno3d GTX 1070 iChill x4
    hey i got it working with a few workarounds, when ill get home ill respond :)
     
  4. beezley

    beezley Member

    Messages:
    19
    Likes Received:
    0
    GPU:
    5870 Powercolor
    hello mate :) yeah had the same problems as you :( just been reading on the ati forums and saw this thread

    http://forums.amd.com/game/messageview.cfm?catid=279&threadid=128067&enterthread=y

    to be honest i have given up all hope and just dual boot with xp.....just wish the ati driver team would stop concetrating on all the fancy crap like (half of it seems marketing bull**** any how) and just concentrate on the drivers....back to basics comes to mind.....these 10.2 are making my card pretty hot, nothing i've done wrong just installed them as per instructions....monkey see monkey do.... lol
     

  5. Xzibit

    Xzibit Banned

    Messages:
    4,383
    Likes Received:
    0
    GPU:
    7970 Windforce
  6. atomic_dumpling

    atomic_dumpling New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Radeon HD5770
    Thanks, but still no joy. This fix has been mentioned a couple of times in the different forums I checked, but that Miles Sound System library is related to a sound driver problem. I am sure that trick worked for a lot of people having that issue, sadly it's the ATI OpenGL driver (atioglxx.dll) that fails in my case. I tried several versions of this DLL file by putting it in the game folder. The game read them properly, but still crashed.

    And I don't even know what MatLab is ;)

    I am going to try the DLL from Cat 9.12 next, but I don't have high hopes.

    It seems the atioglxx.dll from Catalyst 9.12 worked (in window mode, at least). I am going to spread the word about this in the Lucas Arts forum, where I created a topic, too.

    Thanks everyone,
    Christian

    ps: ATI :3eyes:
    pss: turned out I can ALT-Tab in the main menu to get working fullscreen :)
     
    Last edited: Feb 19, 2010
  7. Xzibit

    Xzibit Banned

    Messages:
    4,383
    Likes Received:
    0
    GPU:
    7970 Windforce
    Finaly with Cat 10.3a works but with one condition
    remove intro movies(biologo.bik,leclogo.bik)
     
    Last edited: Mar 19, 2010
  8. vurt

    vurt Master Guru

    Messages:
    253
    Likes Received:
    0
    GPU:
    GTX TITAN
    Nice one serp (mine is already fixed since a long time back and works great here in windows7 x86 with 10.3.).

    KOTOR also plays best with just 1 core activated. I'm using a program called ForceCore to force it each time..

    I also recommend the widescreen patch.. game looks nice in 1920x1080.
     

Share This Page