Kepler Drivers: Nvidia, stop that 70C "throttling" Nonsense please

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by flexy, Apr 26, 2013.

  1. flexy

    flexy Member Guru

    Messages:
    177
    Likes Received:
    0
    GPU:
    Riva 128
    Please Nvidia, increase that 70C threshold - it's silly to start "throttling" at 70C.
    (I know it's done in the drivers, not in the BIOS!!).

    You can increase this to 75C or 80C, what is the reasoning for "throttling" once the GPU hits 70C?

    By the way I say "throttling", aware that the term as such is not correct since the "throttling" actually means that boost will not go that high - but it comes out as the same thing.
     
  2. Zarich

    Zarich Member Guru

    Messages:
    159
    Likes Received:
    0
    GPU:
    Galaxy GC 670
    I don't think this is an Nvidia thing. I say that because My galaxy GC 670 does not throttle at all. I can hit well over 80c without throttling.. so I believe this may be a manufacturer bios issue.
     
  3. andressergio

    andressergio Master Guru

    Messages:
    895
    Likes Received:
    0
    GPU:
    GALAX GTX 1080Ti HOF SLI
    +1 for this my 3 SLI of Galaxies GTX680 dont even at 86C
     
  4. 3dPlayer

    3dPlayer Banned

    Messages:
    1,820
    Likes Received:
    0
    GPU:
    Have
    It's to reduce the RMA and for those who abuse there cards and keep asking for a new one.That is maybe one of the reasons if not the only one.

    My ex-650ti 2gb from Gainward had the same at 55ºC.
     

  5. vitale

    vitale Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    EVGA GTX TITAN SC
    Agreed with OP cut the power saving / throttling **** or give us a straight forward option to disable it
     
  6. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    729
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    I don't mind a throttle, but 70c is too low to have any kind of throttling. The throttle and voltage lowering should come into play at 85-90 if at all.
     
  7. CSF90

    CSF90 Master Guru

    Messages:
    208
    Likes Received:
    0
    GPU:
    Gigabye GTX 980Ti OC
    Your card throttled at 55c? :3eyes:

    No wonder it's an ex-650 Ti.
     
  8. Zarich

    Zarich Member Guru

    Messages:
    159
    Likes Received:
    0
    GPU:
    Galaxy GC 670
    If it was done in the drivers then EVERY card would throttle. Again.. Galaxy cards do not throttle. So it HAS to be the bios.
     
  9. aayman_farzand

    aayman_farzand Master Guru

    Messages:
    816
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FTW
    I don't want it completely removed since it really might save a couple of cards, but I agree that 70C is too low, that's an everyday temperature in the Summer and any card should be able to easily handle it.
     
  10. flexy

    flexy Member Guru

    Messages:
    177
    Likes Received:
    0
    GPU:
    Riva 128
    I didn't know that Galaxy cards don't (temp-)throttle, interesting to say the least. I had reason to believe it's done in the drivers since there were several driver releases where they addressed issues with throttling - I still think that the hardware/bios only makes the numbers available (temps, TDP etc.) and the drivers do the rest.

    I agree also that there is SOME sense in regards to keeping RMA low and simply to protect cards (preowner of my 660 TI had it at 300W with modded BIOS and 2.1V - quite sure such idiocy would otherwise have smoked the card) - NEVERTHELESS 70C is unrealistically low. NV knows that, GK-104 can tolerate a max. of 97C, there is no reason for "throttling" at 70C. 70C is astonishingly cool under load for a GPU.
     

  11. 3dPlayer

    3dPlayer Banned

    Messages:
    1,820
    Likes Received:
    0
    GPU:
    Have
    Because i got i great deal with 2 6870 1GB, for different machines, for almost the same price that i sold the 650ti 2gb.

    Yes it thottled at 55ºC, but i managed to mod my mK-13 and fit it there.No noise, overclocked at 1183mhz.Couldn't get any far because was limited by voltage.
     
    Last edited: Apr 27, 2013
  12. Radical_53

    Radical_53 Ancient Guru

    Messages:
    3,621
    Likes Received:
    0
    GPU:
    Gainward GTX 1080 GLH
    Thanks to a slightly modified Windforce block my card doesn't even see 70°C.
    The heat Kepler puts out is so low that 70°C shouldn't be a "real" issue. Some older generations would have required a good water block to keep them below 65° at all times.
     
  13. IamGODobeyORdie

    IamGODobeyORdie Banned

    Messages:
    245
    Likes Received:
    0
    GPU:
    2x GTX 780@SLI & GTX 780M
    Maybe because the 650 ti cards are very cool even at 100% usage. I put one in my mothers computer, it never goes over 50c, not even when I oc it a little. I dont know if this is the reason, but It could be.
     
  14. Rapyer

    Rapyer Member Guru

    Messages:
    198
    Likes Received:
    0
    GPU:
    1080ti
    my old 8800 ultra ran at like 70 idle
     
    Last edited: Apr 27, 2013
  15. Scouty

    Scouty Active Member

    Messages:
    81
    Likes Received:
    0
    GPU:
    GTX 970 OC WiNDFORCE 3X
    * See my latest post !!!
     
    Last edited: Apr 28, 2013

  16. flexy

    flexy Member Guru

    Messages:
    177
    Likes Received:
    0
    GPU:
    Riva 128
    wow....if that works.... thanks a ton, will try later!

    Edit: Doesn't seem to work on my 660 TI, it's still "throttling" once it gets to 70C. Interesting find tho.
     
    Last edited: Apr 27, 2013
  17. ---TK---

    ---TK--- Ancient Guru

    Messages:
    22,135
    Likes Received:
    0
    GPU:
    2x 980Ti Gaming 1430/7296
    def doesnt work
     
  18. Scouty

    Scouty Active Member

    Messages:
    81
    Likes Received:
    0
    GPU:
    GTX 970 OC WiNDFORCE 3X
    maybe u are doing something wrong...
     
  19. ---TK---

    ---TK--- Ancient Guru

    Messages:
    22,135
    Likes Received:
    0
    GPU:
    2x 980Ti Gaming 1430/7296
    theres only 1 setting and then click apply?
     
  20. Scouty

    Scouty Active Member

    Messages:
    81
    Likes Received:
    0
    GPU:
    GTX 970 OC WiNDFORCE 3X
    first Click "create powermizer settings..."
    then check ""Overheat Slowdown Overhide"" and select "disable overheat slowdown"

    click INSTANT APPLY..
     

Share This Page