Just got a Asus 2G 6950 Doesnt power 430W

Discussion in 'Videocards - AMD Radeon' started by mrzedx, Jun 15, 2011.

  1. mrzedx

    mrzedx New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Asus2GB HD6950 directCUII
    Hey guys i just purchased an asus 2gb 6950 link here

    http://www.asus.com/Graphics_Cards/AMD_Series/EAH6950_DCII2DI4S2GD5/

    It doesnt seem to be working at doesnt even boot up :S i have a thermaltake 430W power supply but i mean why doesnt the thing power up at all even on boot the red light comes on on the card but nothing on the display i have a GA-P35-DS4 mobo and it has large silentpipe heatsinks i think they might be getting in the way its a fat ass card, it takes up at least 3 pci slots. heres a link to my mobo i dont know where its going wrong i just went back and installed my nvidia 8600GS card till i work it out.

    heres a link to my mobo. Thanks in advance guys.

    http://www.gigabyte.com/products/product-page.aspx?pid=2745

    EDIT: i would like to know if its the mobo or if my psu just isnt supplying enough power or what the story is, i will upgrade the psu soon anyways but i just wanted to know if the card itself is faulty or what :S
     
  2. Jeepster50

    Jeepster50 Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    ASUS 6950DCII 2GB CF
    Which port are you using to connect display? If DVI single link, is the switch in the #1 position?
    Also I think you need at least a 500 PSU.
     
    Last edited: Jun 15, 2011
  3. mrzedx

    mrzedx New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Asus2GB HD6950 directCUII
    i tried both DVI ports which connect to hdmi converter and go to my screen, the rest are 4 DisplayPort Outputs. i dont know how to convert them to a monitor :S
    i am willing to change the PSU but i really want to know what the exact problem at hand is :S its got me going nuts, i dont wanna have to do a psu then change other parts so i want to know firsthand but that doesnt mean it shouldnt work at all right?
     
  4. sykozis

    sykozis Ancient Guru

    Messages:
    21,995
    Likes Received:
    1,183
    GPU:
    MSI RX5700
    If you could fill in the full specs for your computer, it would be VERY helpful...
     

  5. millerman61

    millerman61 New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    2 Diamond 3850's
    Do you have both an 8pin and 6pin connector for power going to it?
     
  6. mrzedx

    mrzedx New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Asus2GB HD6950 directCUII
    ive connected 2X 6 pin connectors because i dont have an 8 pin connector? :S but it should still boot up right? :S one of the connectors are 6 pin one of them are 8 pin, my current psu only has 1 6pin connector and the gpu came with 1 other 6 pin so i tried my luck.

    my pc specs are

    E6750 core 2 duo 775 socket
    mb is an asus p35 ds4
    4 GB ram ddr2
    430W Thermaltake PSU
    Aerocool PGS VX-9 pro case
    At the moment im running a GFORCE 8600GS 512MB asus
     
  7. Metz

    Metz Master Guru

    Messages:
    229
    Likes Received:
    0
    GPU:
    2x 5850 TOP CF
    "8pin + 6pin Power connector is required for best performance" This is from ASUS Website. If it has a 6 pin and 8 pin, use a 6 pin and 8 pin ;).
     
  8. harkinsteven

    harkinsteven Ancient Guru

    Messages:
    2,942
    Likes Received:
    119
    GPU:
    RTX 3080
    I seriously doubt a 430w is gonna power that card and your pc.
     

Share This Page