Jitter in games driving me nuts!

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by iFRAC7UR3, Mar 23, 2012.

  1. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,717
    Likes Received:
    6
    GPU:
    GTX 1080 Amp!
    Maybe someone already asked... but... have you checked your VGA for dust? have you dusted off since you got it? maybe the core temps is ok but mems are full of dust?

    Cleaning it won't hurt ^^
    If this and a clean reinstall didn't work, something ion the hardware side is hurting :S
     
  2. kindred

    kindred Active Member

    Messages:
    87
    Likes Received:
    1
    GPU:
    Gigabyte GTX 770 OC 4GB
    Are you running any other utilities in the background like ASUS Suite, Fraps, Evga precision etc? Also try shutting everything down including any browsers you might have running in the background and see if the jittering has gone.

    I sometimes get jittering when I have Avant browser or Firefox running in the background and Kaspersky can also cause jittering. So if you have those try shutting them down before gaming.
     
  3. samtroy

    samtroy Member

    Messages:
    27
    Likes Received:
    0
    GPU:
    Inno3D GTX 780 Ti 3GB
    I had the same problems on Assassin's Creed: Revelations! Same card, same driver.

    I fixed it with the 300.83 driver :)! Yes!! Thanks to some guys over at the NVidia forums. Seems like NVidia broke something in the 301 driver...

    Source: http://forums.nvidia.com/index.php?showtopic=226227
     
  4. tyRant.594

    tyRant.594 Master Guru

    Messages:
    472
    Likes Received:
    0
    GPU:
    MSI R9 280x
    so the 300 driver is better to use than the 301? I get the weird stuttering without vsync on bf3.
     

  5. samtroy

    samtroy Member

    Messages:
    27
    Likes Received:
    0
    GPU:
    Inno3D GTX 780 Ti 3GB
    Yes, the 300.83 is much better. No more weird stuttering.

    Just check out the thread I posted.
     
  6. Shadowdane

    Shadowdane Maha Guru

    Messages:
    1,421
    Likes Received:
    70
    GPU:
    MSI RTX 3080 Suprim
    Cool I'll have to give the 300.83 driver a try, the stuttering and jitter in a few games on 301.10 was driving me nuts!!
     
  7. tyRant.594

    tyRant.594 Master Guru

    Messages:
    472
    Likes Received:
    0
    GPU:
    MSI R9 280x
    wow, the 300 driver is better in every game I tried. Bf3, Crysis 2, darkness 2. I have no more stuttering or jitters, thank god!
     
  8. Netherwind

    Netherwind Ancient Guru

    Messages:
    7,788
    Likes Received:
    1,622
    GPU:
    MSI 3080 Gaming X
    Am I the only one who does not experience stuttering using 301.10 while Vsync enabled?
     
  9. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,056
    Likes Received:
    572
    GPU:
    EVGA GTX 1080 Ti SC2
    No, I've never noticed any stutter in any of the games I've been playing (Alan Wake, Jurassic Park, Batman: Arkham City, Skyrim, Mass Effect 3, Ridge Racer Unbounded, etc.) with any of the 30x.xx drivers I've tried so far and I can't stand tearing so I always have v-sync enabled (and triple buffering too using D3DOverrider).
     
  10. Frohman0905

    Frohman0905 Master Guru

    Messages:
    976
    Likes Received:
    0
    GPU:
    GTX680 2GB OC @ 1202/7000
    Same here!
     

  11. uffa

    uffa Active Member

    Messages:
    80
    Likes Received:
    0
    GPU:
    EVGA GTX 680
    Thank god i'm not the only one who has it. Looks like the drivers need to mature?
     
  12. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,717
    Likes Received:
    6
    GPU:
    GTX 1080 Amp!
    Well, if you wait for them to be ripe, you'll probably die before that happens.
     
  13. Sajittarius

    Sajittarius Master Guru

    Messages:
    427
    Likes Received:
    47
    GPU:
    3090 Turbo 24G
    @iFRAC7UR3: check your cpu overclock

    @Faks: Snipping tool is your friend (meaning you dont need to take giant friggin screenshots)
     
  14. Year

    Year Ancient Guru

    Messages:
    11,594
    Likes Received:
    1
    GPU:
    EVGA GTX 690
    if i said that with every card i ever got, i wouldn't've gotten any card. :D
     
  15. pokerapar88

    pokerapar88 Ancient Guru

    Messages:
    1,717
    Likes Received:
    6
    GPU:
    GTX 1080 Amp!
    True !
     

  16. NiColaoS

    NiColaoS Master Guru

    Messages:
    656
    Likes Received:
    47
    GPU:
    GTX 1660 SUPER
    Which BIOS fixed that problem? I'm using the 2303... I don't see any newer... This month's at least.
     
  17. dnottis

    dnottis Master Guru

    Messages:
    695
    Likes Received:
    0
    GPU:
    EVGA SSC 970 GTX 4GB
    Thats the new bios.
     
  18. NiColaoS

    NiColaoS Master Guru

    Messages:
    656
    Likes Received:
    47
    GPU:
    GTX 1660 SUPER
    Ah, ok! Because that came the previous month.
     
  19. Saabjock

    Saabjock Master Guru

    Messages:
    359
    Likes Received:
    70
    GPU:
    PNY GTX1070XLR8
    Try going into the Nvidia control panel and enabling V-sync at the bottom of the list if you use a flat panel monitor. I also noticed a massive gain in smoothness after switching power management to maximum performance. Try those to see if that helps.
    Here are my settings (obviously forget the SLI settings and let the application decide on those). I also included a link to one of my videos to verify smoothness. I have V-sync off as I use a CRT and do not have a problem with tearing.

    http://dl.dropbox.com/u/588472/301.24_1.jpg
    http://dl.dropbox.com/u/588472/301.24_2.jpg
    http://www.youtube.com/watch?v=eq3AhKSzKKA&list=UU1xakOBplC7jG4CHGCZEtXg&index=1&feature=plcp
     
    Last edited: Apr 18, 2012

Share This Page