It seems the Win 10 Anniversary update fixed 2D clock issue with multiple displays

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by mstcobra, Aug 7, 2016.

  1. mstcobra

    mstcobra Member Guru

    Messages:
    128
    Likes Received:
    3
    GPU:
    GTX 1080 Ti (H2O)
    So in my case at least the Windows 10 Anniversary update fixed the issue where my 1080 would not fully downclock to its 2D clocks when in the desktop environment.

    Before my clocks would only partially lower to 1200 something MHz, even when not in a 3D application just because I had multiple displays. Anytime I would do Win+P -> PC Screen only though it would fully downclock.

    Glad that's fixed! Especially since I also use this thing as a workstation. :banana:
     
  2. Mr_ALLroy

    Mr_ALLroy Ancient Guru

    Messages:
    1,992
    Likes Received:
    17
    GPU:
    EVGA RTX 3080 FTW3
    I'm not so sure it's got anything to do with the update. I have the same issue when I have Corsair Link and/or Razer Synapse installed and running. With or without the Anniversary update. Close them down and my clocks go to proper idle speeds. I'd keep an eye on it and if it happens again, trying closing stuff down one at a time and see if what app or program is causing it.
     
  3. DF-1

    DF-1 Maha Guru

    Messages:
    1,417
    Likes Received:
    0
    GPU:
    EVGA gtx 580
    mine (1080) seems to not downclock unless i close battlenet, even if its not "open" but just in the tray.

    i also have corsair link installed.

    it should be something like is GPU load < 10%? dont clock **** high.
     
  4. CrazyBaldhead

    CrazyBaldhead Master Guru

    Messages:
    300
    Likes Received:
    14
    GPU:
    GTX 1070
    Just force a low power state for bnet. I've done the same.
     

  5. BuildeR2

    BuildeR2 Ancient Guru

    Messages:
    2,898
    Likes Received:
    150
    GPU:
    MSI 2080 Ti GX Trio
    Maybe it has to do with the new driver that is available for 1080's through WU? Either way, glad it works better now.

    I had an issue with clocks not being at their lowest setting at a black desktop, so I opened up NVCP, went to the bar along the top and under "Desktop" you can enable a tiny app in the notification bar that tells you what things are using your GPU. In my case it was battle.net so I went through its settings and turned off hardware acceleration. All has been fine since.
     
  6. mstcobra

    mstcobra Member Guru

    Messages:
    128
    Likes Received:
    3
    GPU:
    GTX 1080 Ti (H2O)
    Even with Link running I am still idling at 240 MHz core clock with all 3 displays enabled. See the screen below.

    I am running the normal Game Ready Driver version 368.81.


    The only change for me was the Windows 10 Anniversary update. Prior to this the only way I'd full power down to the true 2D idle clocks was to disable my extended monitors.



    Screenshot here - I am using a link for the image rather than posting it directly in the reply because it widens the whole thread to 5760 and apologies for all the blackouts, I had my work stuff up.
     
    Last edited: Aug 7, 2016
  7. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,503
    Likes Received:
    1,551
    GPU:
    ROG Strix 1080 OC
    If you go to NVCP > Desktop menu > Display GPU activity icon

    You get this, which might narrow it down

    [​IMG]
     
  8. Mr_ALLroy

    Mr_ALLroy Ancient Guru

    Messages:
    1,992
    Likes Received:
    17
    GPU:
    EVGA RTX 3080 FTW3
    My issues were still there after I did the "upgrade". I've since reformatted and installed a fresh copy but haven't installed CL or Synapse. I'm going to do just that and see what I find.
     
  9. mstcobra

    mstcobra Member Guru

    Messages:
    128
    Likes Received:
    3
    GPU:
    GTX 1080 Ti (H2O)
    Do you have high refresh rate displays? I heard folks also have this 3D clock in 2D environment issue with monitors that have a higher refresh rate. (mine are only 60Hz)
     
  10. k4sh

    k4sh Member Guru

    Messages:
    117
    Likes Received:
    0
    GPU:
    Geforce 1070 @ 2139-2152
    I noticed exactly the same behaviour after updating W10 to anniversary update.
    Prior to this my memory clock used to stay at max and core used to drop to 1500 Mhz approx.
     

  11. Mr_ALLroy

    Mr_ALLroy Ancient Guru

    Messages:
    1,992
    Likes Received:
    17
    GPU:
    EVGA RTX 3080 FTW3
    My main is 120Hz, and I've got two others at 60Hz. However. I did reinstall both CL and Synapse again, have played a couple games, rebooted a couple times and other ordinary tasks I would normally do. And my clocks go down like they should. It appears you may be right mtscobra. I've had no issues so far. :)
     
  12. mstcobra

    mstcobra Member Guru

    Messages:
    128
    Likes Received:
    3
    GPU:
    GTX 1080 Ti (H2O)
    Glad to hear it Mr-ALLroy!
     
  13. Bloodred217

    Bloodred217 Master Guru

    Messages:
    356
    Likes Received:
    1
    GPU:
    2x GTX 1080 G1 Gaming 8GB
    My main card never goes below ~1.2GHz with 3 monitors, one of them is 4K though. Anniversary update didn't do anything to change that.
     
  14. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    6,924
    Likes Received:
    1,166
    GPU:
    NVIDIA GTX 1070
    Interesting, my 1070 also stayed at 1533 MHz because i have the global profile set to Maximum Performance.

    I also had 3 programs in that list.

    Battle.net
    Chrome
    Epic Games Launcher

    I made a profile for all those and set them to Adaptive which fixed the problem. The Core Clock now drops to 165 MHz.
     
  15. My card no longer downclocks to idle speeds (144hz/60hz setup) after this driver update. It finally worked perfectly with the previous hotfix driver, I am so annoyed :(. As usual, the fix is to run at 120 Hz instead of 144 Hz. This sucks because it makes alt tabbing worse, because the games will run at 144 Hz, causing a delay. Considering switching back to previous drivers just for this issue now.

    FYI, this is a separate problem than the 2d/3d clocks not working properly. This one is easy to fix with Afterburner/RTSS. You just have to click on the 'i' in afterburner (right above Core Voltage) and you'll find which apps are counting as being 3D, and you can use RTSS to disable them activating 3d clocks by choosing "Application Detection: None". It turns out that there are a lot of apps that count as being 3D whereas you wouldn't want 3D clocks with them.
     

  16. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,391
    Likes Received:
    918
    GPU:
    1080Ti H20
    Do you have a Gsync screen?

    One time mine wouldn't idle and i disabled and re-enabled it, causing card to idle.
     
  17. Mr_ALLroy

    Mr_ALLroy Ancient Guru

    Messages:
    1,992
    Likes Received:
    17
    GPU:
    EVGA RTX 3080 FTW3
    Yeah, I'm happy. I came home today from work, booted up and clocks are idling as they should.

    Thanks Man!!!
     
  18. CrazyCoder

    CrazyCoder New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    Gigabyte GTX690
    No luck for me with 3 displays (all @60Hz).

    Still have to use Nvidia Inspector Multi GPU power saver app.
     

Share This Page