issues with dx9 crossfire 6950

Discussion in 'Videocards - AMD Radeon Drivers Section' started by jarrod357, Apr 24, 2014.

  1. jarrod357

    jarrod357 Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    crossfire 6950 dirt 3 tf2
    Can anyone help me with dx9 issues? I am using crossfire 6950s. Whenever play games in dx9 mode the whole screen flashes constantly. Some times it has a band that runs up and down on the screen. When i turn i off crossfire it doesnt flash. I had re installed windows 8.1 and I'm using 14.4 rc1 drivers. I was using 13.12 whql and had the same issues. Dx11 mode works fine. Thanks to anyone that can help.
     
  2. MojoW

    MojoW Member Guru

    Messages:
    173
    Likes Received:
    0
    GPU:
    Gigabyte 1080 G1 Gaming
    Do you use any driver cleaner ? Because if u don't it can cause problems, even on a clean windows install.
    Windows 8/8.1 auto installs the driver with windows update that's why i recommend a cleaner like DDU.
    It's worth a try and if that doesn't work i'm sure members of the community will have other suggestions for you to try.

    Good luck!
     
  3. jarrod357

    jarrod357 Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    crossfire 6950 dirt 3 tf2
    Thank you for the suggestions! I used the amd uninstall utility they have on their website then I did ccleaner. I usually use driver sweeper in safe mode. I have windows auto driver install turned off as well. This issue happened using both uninstall methods. I view this forum regularly and use the recommended processes when doing things but I have never had this problem before.
     
  4. stigbeater

    stigbeater Active Member

    Messages:
    54
    Likes Received:
    0
    GPU:
    GTX 1070 msi gaming X
    have you tried re installing direct x?
     

  5. jarrod357

    jarrod357 Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    crossfire 6950 dirt 3 tf2
    I have an update on this situation. I tried turning on triple buffering and forced v sync I CCC as well as turned off frame pacing and it fixed the issue. I had to leave for work so I don't know if it was the from pacing or the v sync that fixed it. I will update later today for anyone who is interested. I didn't try reinstalling direct x.
     

Share This Page