Issues updating BIOS

Discussion in 'Processors and motherboards Intel' started by cryohellinc, May 6, 2017.

  1. cryohellinc

    cryohellinc Master Guru

    Messages:
    851
    Likes Received:
    43
    GPU:
    1080Ti SeaHawkX@2k+PG348Q
    Good day guys,

    Haven't touched my mobo's bios for a while, and wanted to give it some maintenance today by updating to latest version. However when I try to update bis using mflash, nothing happens. It just freezes, nothing happens. I gave it a good minute wait time, before getting nervous and rebooting. Rebooted fine, and loaded windows as usually. My procedure was -

    Downloaded latest AMI bios from MSI website dated - 2015-05-13 for MSI Z87 Mpower;

    Made a bootable usb under fat32, copied all the files to it, booted into bios --> mflash --> selected drive --> selected bios file to update --> approved.

    And that's it, it just hangs there, doesnt crash, doesnt do anything.

    Should I just wait? Afaik from my previous updates it would start updating right away.

    Any ideas from more experienced "flasher's ;)"?

    Thank you.
     
  2. anticupidon

    anticupidon Ancient Guru

    Messages:
    2,894
    Likes Received:
    3
    GPU:
    XFX RX480 GTR 8GB
    try to use a standard USB thumbdrive.Just format it FAT32 and put the unzipped file onto it.From UEFI acces the MFlashj menu, choose the flash memory and the new UEFI BIOS file.It should work fine.No need to make it bootable.
     
  3. cryohellinc

    cryohellinc Master Guru

    Messages:
    851
    Likes Received:
    43
    GPU:
    1080Ti SeaHawkX@2k+PG348Q
    Just did exactly what you suggested, fat32, nothing else.

    Still doesn't work, just hangs there after I choose files and click start.
     
  4. Steppzor

    Steppzor Master Guru

    Messages:
    723
    Likes Received:
    0
    GPU:
    MSI 1080 Ti Gaming X
    Seems Mflash is borked for a lot of MSI boards in Z77 and Z87. Quick google search showed me that. There should be another BIOS update tool available on the MSI forums.
     

  5. cryohellinc

    cryohellinc Master Guru

    Messages:
    851
    Likes Received:
    43
    GPU:
    1080Ti SeaHawkX@2k+PG348Q
    That's really odd, i do remember updating it some years ago ( as my current bios is from 2013 ) and it worked just fine, now it refuses.

    Oh well i guess i'll just keep it like it is, last thing i need is bricked mobo.

    Thank you for help guys!
     
  6. lexer98

    lexer98 Master Guru

    Messages:
    668
    Likes Received:
    0
    GPU:
    GTX 1070 - WC
  7. Margalus

    Margalus Member Guru

    Messages:
    129
    Likes Received:
    0
    GPU:
    EVGA GTX 980 Ti FTW
    Possibly a problem similar to ASUS bios upgrades?

    You have to completely rename the downloaded file for it to work. Why they make you do this is anyones guess. And the problem is, it doesn't tell you that. And ASUS support doesn't tell you that when you call. I finally found this out after spending days googling and finally found somebody saying this. Lo and behold it works...
     
  8. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    10,048
    Likes Received:
    152
    GPU:
    1080Ti H20
    That is only for USB flashback..

    And it's good reason to have specific name so it doesn't accidentally choose wrong rom file to update with.
     
  9. mbk1969

    mbk1969 Ancient Guru

    Messages:
    3,608
    Likes Received:
    37
    GPU:
    GeForce GTX 970
    Are you sure you can`t flash from BIOS setup itself? In my MB`s BIOS there is such option and I always use it.
     
  10. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    18,069
    Likes Received:
    172
    GPU:
    GTX980 SLI
    I think that's what mflash is
     

  11. cryohellinc

    cryohellinc Master Guru

    Messages:
    851
    Likes Received:
    43
    GPU:
    1080Ti SeaHawkX@2k+PG348Q
    That's exactly what it is, simply different name under MSI.

    And does not work, ive read about above mentioned mode with DOS command, but i wont go that far.
     
  12. The1

    The1 Member

    Messages:
    48
    Likes Received:
    0
    GPU:
    2x EVGA 780ti SC, H20

    Hi cryohellinc, if you haven't tried it already make sure that your original bios is set to "default". i.e. vanilla settings- noticed your cpu was clocked,,reset and try your flash again.
    Some tools are extremely picky when it comes to the bios flash.
    Good luck and let us know how it goes...:)
     
  13. cryohellinc

    cryohellinc Master Guru

    Messages:
    851
    Likes Received:
    43
    GPU:
    1080Ti SeaHawkX@2k+PG348Q
    The1
    A sound suggestion, will do that when home. Thank you!
     
  14. Labyrinth

    Labyrinth Ancient Guru

    Messages:
    4,293
    Likes Received:
    0
    GPU:
    Tri-X R9 290 4G
    Probs a stupid question, have you tried another USB stick and/or redownloading the file in case it's corrupt.
     
  15. The1

    The1 Member

    Messages:
    48
    Likes Received:
    0
    GPU:
    2x EVGA 780ti SC, H20

    +1 :)
     

Share This Page