Issue installing drivers > 13.6 Beta2

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by Prasad007, Sep 19, 2013.

  1. Prasad007

    Prasad007 Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970M 2GB
    The Catalyst 13.6 Beta 2 is the last real working driver on my machine. Anything newer that I tried including 13.8 Beta2, 13.10 Beta and even the 13.9 WHQL fails to install. During installation, I get a black screen when it reached Display Driver install and the black screen just flickers indefinitely (no display until system restore). I have an Alienware M17x R4 w/ AMD 7970M on Windows 8 Pro x64. Please help!
     
    Last edited: Sep 19, 2013
  2. CoMa666

    CoMa666 Master Guru

    Messages:
    392
    Likes Received:
    0
    GPU:
    HD7970 Dual-x Boost
    try diver fusion, it's great.
     
  3. Prasad007

    Prasad007 Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970M 2GB
    I have no issues uninstalling drivers. It's just that any driver after 13.6 Beta2 just WON'T work! I've tried it on a fresh Windows install too..
     
  4. Prasad007

    Prasad007 Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970M 2GB
    Update: OK So apparently 13.9 WHQL works with Enduro OFF. Why can't I get it to install with Enduro ON, since if I install it when it's off, I have driver issues again when I turn it back on!
     

  5. Insomnia

    Insomnia Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    ATI 7970M
    Stuck in the same mess!!!!!!!

    I am having exactly the same problem and am extremely frustrated and exasperated. After trying multiple methods and restoring windows numerous times daily after each attempt to get rid of the permanently flickering black screen I eventually ended up corrupting my restore points and now am left with what seems like a completely broken operating system, or at the least video drivers. I have even reported the problem twice to AMD, but with no luck/response. Please help somebody!!!!!!!! Can't install any update since the 13.6 beta 2, and this is driving me absolutely crazy. I don't know how much damage I have already done, or will end up doing in case I don't find a solution soon, to my m17xR4 by restarting and restoring it every minute in attempts to solve the issue.
     
  6. Prasad007

    Prasad007 Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970M 2GB
    I'm able to install the driver with Enduro OFF FWIW, but never when it's on.. Maybe try contacting Dell to see if you turn up with better luck?
     
  7. Insomnia

    Insomnia Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    ATI 7970M
    How to contact Dell?

    What do you suggest, should I email them? And at what region? I got it from the US but live in Pakistan. Now my windows are completely broken, there is an "RTSS not working" and "bootstrapper" error at start up, even the dell online diagnostic tool fails to complete its check up giving a message that "dell diagnostic tried to start a program but failed"...I'm surprised how it's only the two of us confronting this problem, or at least so it appears given that I wasn't able to find anything on the net pertaining to this issue except the thread posted by you.
     
  8. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
    RTSS not working...
    Try uninstall MSI Afterburner first, and RTSS(RivaTuner Statistics Server).
     
  9. Prasad007

    Prasad007 Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970M 2GB
    Agreed. I couldn't find any related information either. I'm thinking the issue might be specific to this laptop model, which means Dell is responsible for an answer. I'll email them myself. PM me if you're willing to investigate further..
     
  10. Insomnia

    Insomnia Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    ATI 7970M
    Yes lets contact Dell!

    But Alienware M17xR4 is a popular gaming machine with users posting on issues everywhere on the net, except this particular one, which nobody else seems to be facing except us. And yes, I'm most definitely interested in getting this issue resolved a the earliest so lets contact them. We didn't pay upwards of $2500 for nothing! What do you mean by PM?
     

  11. Insomnia

    Insomnia Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    ATI 7970M
    AMD Catalyst Mobility 13.8b2 PX and Enduro Fix (Integrated graphics optimization)

    Hey, have you tried the solution provided on the following thread:

    AMD Catalyst Mobility 13.8b2 PX and Enduro Fix (Integrated graphics optimization)
    The link is as follows:
    http://forums.guru3d.com/showthread.php?t=380915

    It seems to be an answer to a similar problem as ours and also appears to be working. What say you? Should we give it a try?
     
  12. Prasad007

    Prasad007 Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970M 2GB
    I've emailed Dell and am awaiting a response. I guess I can give this driver a try today..
     
  13. Insomnia

    Insomnia Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    ATI 7970M
    Hope it works!

    Do let me know if it works. and please also post a step by step guide of the solution if it does. Can't understand fully what the guy has proposed. Thanks!
     
  14. Insomnia

    Insomnia Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    ATI 7970M
    Any luck?

    Did you receive any response from Dell? And did you try the solution I posted?
     
  15. pato

    pato Member Guru

    Messages:
    132
    Likes Received:
    0
    GPU:
    EVGA Geforce GTX-970
    Last edited: Sep 30, 2013

  16. Insomnia

    Insomnia Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    ATI 7970M
    Thank you for the suggestion!

    Thank you for the advice, I'll try this today. One more thing, an even later driver version (12.***8203;8.***8203;0.***8203;1016) of the intel RST RAID technology than the one you recommended is currently available on the intel website. The link is as follows:

    https://downloadcenter.intel.com/Se...telĀ®+RST)&ProdId=2101&LineId=1090&FamilyId=42

    Is an upgrade to it recommended? Would it have any compatibility issues with my system? I am concerned because of the following disclaimer on the intel site:

    IMPORTANT:
    Before installing this application or requesting technical support from Intel, first contact your system manufacturer. They typically provide software which is specifically configured for your system.
     
  17. Insomnia

    Insomnia Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    ATI 7970M
    Correction: Driver Version

    The latest RST driver version is 12.8.0.1016
     
  18. pato

    pato Member Guru

    Messages:
    132
    Likes Received:
    0
    GPU:
    EVGA Geforce GTX-970
    It should also work fine. You can also take Dells current version for your system, I'm pretty sure they also offer an updated version which is at least 11.6.0.1030.
     
  19. Insomnia

    Insomnia Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    ATI 7970M
    It Worked!

    The BIOS update worked!!!! Thank you! Thank you! Thank you! You are a life saver. I got IAStorIcon.exe error at restart but it has disappeared since then and all seems to be working fine. Can't thank you enough, definitely owe you one! God Bless You!
     
  20. BenYeeHua

    BenYeeHua Ancient Guru

    Messages:
    1,515
    Likes Received:
    0
    GPU:
    Asus 650M D3
    IAStorIcon.exe error.
    You just need to update your AHCI driver I think. :)
     

Share This Page