1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Is this normal ?

Discussion in 'Operating Systems' started by macdaddy, Sep 17, 2018.

  1. macdaddy

    macdaddy Ancient Guru

    Messages:
    2,395
    Likes Received:
    4
    GPU:
    TITAN X
    Last edited: Sep 18, 2018
  2. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    18,984
    Likes Received:
    1,050
    GPU:
    GTX980 SLI
    404. That’s an error.

    The requested URL was not found on this server. That’s all we know.

    Use imgur.com or imgbb.com
     
  3. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    18,984
    Likes Received:
    1,050
    GPU:
    GTX980 SLI
    Doesn't work even if you are logged in
     
    austin865a likes this.
  4. RealNC

    RealNC Ancient Guru

    Messages:
    2,603
    Likes Received:
    858
    GPU:
    EVGA GTX 980 Ti FTW

  5. macdaddy

    macdaddy Ancient Guru

    Messages:
    2,395
    Likes Received:
    4
    GPU:
    TITAN X
  6. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    18,984
    Likes Received:
    1,050
    GPU:
    GTX980 SLI
    Yea they're fine, there's even an installer kicking about here on G3D that installs them all for you
     
    macdaddy likes this.
  7. RealNC

    RealNC Ancient Guru

    Messages:
    2,603
    Likes Received:
    858
    GPU:
    EVGA GTX 980 Ti FTW
    The MS C++ runtime DLLs are not backwards compatible, which is why you need all these different versions. Meaning that if a program uses the 2012 version, having the 2017 version installed doesn't help. Only the 2012 version can work with that program.

    So yes. Perfectly normal to see all versions installed.
     
    macdaddy likes this.
  8. macdaddy

    macdaddy Ancient Guru

    Messages:
    2,395
    Likes Received:
    4
    GPU:
    TITAN X
    Thanks folks
     
  9. Alessio1989

    Alessio1989 Master Guru

    Messages:
    996
    Likes Received:
    78
    GPU:
    .
    Different versions, different ABIs so they are not backward compatible. Only 2015 and 2017 runtimes have the same ABIs (and probably this is not gonna happen in the upcoming 2019 version), so for those you only need the latest.
     
  10. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    5,595
    Likes Received:
    196
    GPU:
    MSI GTX 1070
    Just seems you have some duplicates of the 2005 and 2008 versions.

    Here is my list:

    https://i.imgur.com/zLCQ5YY.jpg

    I think you can safely remove the oldest versions of the duplicates.
     

  11. Alessio1989

    Alessio1989 Master Guru

    Messages:
    996
    Likes Received:
    78
    GPU:
    .
    Older VC runtime installers did not overwrite previous builds of the same versions. Anyway it's fine, the OS will use the last version.
     

Share This Page