Is my 280x broken?

Discussion in 'Videocards - AMD Radeon' started by Broken Haiku, Apr 4, 2016.

  1. Broken Haiku

    Broken Haiku Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    AMD 280x 3GB
    Is my 280x broken? [solved]

    System:

    Windows 10 64.
    32 GB DDR4
    i5 6600k
    AMD Radeon 280x (second monitor)
    Intel (onboard) HD Graphics 530 (primary monitor)

    Now on to the problem:

    This one really stumped me. I woke up this morning and went to check the news and noticed only one of my screens were running, wrong orientation too (I normally run my secondary screen in vertical mode).

    I poked around a bit, checked cables, rebooted. Same thing. The second screen isn't really off, because the monitor is getting a signal, just...no image.

    I started thinking it was the monitor but no, it works fine. I reinstalled the driver and rebooted. No change. Here's where things got weird:

    I decided to remove the device from the device manager and see if it'd correct itself, my first thought though, was to disable and re-enable the device.

    aaand as I disabled the device...I got a picture!

    Without the device disabled, DXDiag only shows the Intel graphics card/screen. _with_ it disabled, it shows both screens, the second one using a Microsoft Basic Display Driver.

    I've run an sfc /scannow, I've run driver uninstaller and installed the proper AMD driver again ( 16.3.2-win10-64bit), nothing.

    I played Shadow of Mordor last night on highest everything and with the HD texture pack, everything worked fine then.

    If this is a hardware problem it's one of the weirdest ones I've seen. Should I return the card?

    The reason I'm asking is because I have severe anxiety issues and dealing with a probably unhelpful online store, sending off the card, waiting for weeks, that's really stressing and hard for me, so if it could be anything else, I'd rather not have to jump through those hoops.
     
    Last edited: Apr 5, 2016
  2. Broken Haiku

    Broken Haiku Member

    Messages:
    42
    Likes Received:
    0
    GPU:
    AMD 280x 3GB
    ....after so much crawling around under the desk, cursing and muttering, trying different cables, connecting monitor A to adapter B and vice versa, re-flushing the BIOS etc...it turns out that Windows somehow had a hiccup and was set to "PC screen only" in the project page. After changing it to extend, it set itself to "second screen only". Changing it a third time and it stuck.

    I'm guessing this problem arose while I was trying out some overclocking so I have no one to blame but myself.
     
  3. styka

    styka Master Guru

    Messages:
    314
    Likes Received:
    1
    GPU:
    RX 480 8GB RD
    hey thanks for updating how you solved it :)
     
  4. oGow89

    oGow89 Maha Guru

    Messages:
    1,213
    Likes Received:
    0
    GPU:
    Gigabyte RX 5700xt
    Return the card? Did you just buy it not long ago?
     

  5. vase

    vase Ancient Guru

    Messages:
    1,653
    Likes Received:
    2
    GPU:
    -
    it looks like he fixed it by fiddling with a stuck windows display output setting.
     

Share This Page