Introducing FLEM - The Legacy Modder for legacy DirectX 9 and 10 cards.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by AmiloMan, Jul 14, 2013.

  1. AmiloMan

    AmiloMan Master Guru

    Messages:
    345
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    What game are you playing? When you say that the driver doesn't work right and doesn't work right I don't understand...... You must be doing something wrong. It should work at the first try. As we have just seen its just the wrong application that messes up the entire MOD. Probably you could walk me through the MOD process you used so I can help you out.
     
  2. KodY

    KodY Master Guru

    Messages:
    627
    Likes Received:
    0
    GPU:
    Sapphire 280X Vapor-X
    This is the error I got after the installation and reboot:

    [​IMG]

    Here is what I did:
    Downloaded 13-1-legacy_vista_win7_win8_64_dd_ccc.exe and Catalyst_10.12_CCC2_Preview_Win7_Dec7.exe and extracted them to seperate folders.

    - Opened FLEM and browsed to the root folder of the 13.1 driver
    - Clicked Full Mod
    - In the cocktail maker, I chose the seven 64 bit files (atikmdag.sy_, atiumdag.dl_, atiumdva.dl_, atiumdva.ca_, atiumd6a.dl_, atiumd6a.ca_ and atiumd64.dl_) from the driver directory of the 10.12 driver.
    - Completed the mod

    Then I did the usual uninstall of my current AMD drivers, and installed the modified one. (Driver Signature Enforcement is disabled btw.)
     
  3. AmiloMan

    AmiloMan Master Guru

    Messages:
    345
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    Try a legacy driver of your choice !
     
  4. AmiloMan

    AmiloMan Master Guru

    Messages:
    345
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    I found the reason why its not modding in your case, its not your modding method I think you are modding it well but the problem lies in your choice of drivers.
    FLEM supports Catalyst 12.3 onwards, noticed that you wanted to use the 13.1 legacy drivers as base? Remember you can't mod a legacy driver and you can't mod the 10.12's using 13.1 as the base.
    Use a normal WHQL or Beta (not-mobility)driver version after the12.3.
    Mod the normal driver with the legacy drivers as base in the coktailmaker.

    What you were trying to do with the 10.12 and 13.1 legacy will not work.
     
    Last edited: Sep 14, 2013

  5. KodY

    KodY Master Guru

    Messages:
    627
    Likes Received:
    0
    GPU:
    Sapphire 280X Vapor-X
    I tried 13.6 Beta 2 as a base now, but the same thing happened. Maybe the 10.12 files are just too old to work?
     
  6. AmiloMan

    AmiloMan Master Guru

    Messages:
    345
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    Drop the 10.12's lol there are better driver sets out there. For that game you are playing you might have application profiles available, you don't have to stick in the stone age. That's why we have driver mods.
    The term base is used for the driver files from the legacy package, im hoping you did not use the beta as base :)
    Read the guide from the top to end and you will be better off, I know its a pain but its worth it bro.
     
  7. KodY

    KodY Master Guru

    Messages:
    627
    Likes Received:
    0
    GPU:
    Sapphire 280X Vapor-X
    I know there are better ones out there, sadly ever since those 11.xx drivers, BF2 has this odd shadow bug which AMD never cared to fix.

    [​IMG]

    I just thought I'd give this a try to get the best of both worlds, so to say. Working BF2, but with newer OpenGL, DXVA etc.
    Well, thanks for the help anyway.
     
  8. xbp13x

    xbp13x Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    ATI 4250M 256MB
    This might sound strange but I too got graphical errors in certain games with the 13 series but I was able to fix them by opening the AMD control center going to preferences and doing restore factory defaults, you should try that.
     
  9. butterbisquit

    butterbisquit New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    gpu
    Support for xp32 would be great. :supercool
     
  10. Second_Fry

    Second_Fry New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Ati 7870 1GB
    Windows 8 Release Preview x64, HP Compaq 6820s, Ati Radeon x1350, latest 13.10 beta patched by 9.11 legacy.
    Bastion started working, Minecraft stopped with DrvSwapBuffers error. Will post details in hour.
     

  11. Second_Fry

    Second_Fry New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Ati 7870 1GB
    Pretty known error; the only way to fix one AFAIK is to install different drivers.
    Code:
    Client> # A fatal error has been detected by the Java Runtime Environment:
    Client> #
    Client> #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000066622fa7, pid=1292, tid=3160
    Client> #
    Client> # JRE version: Java(TM) SE Runtime Environment (7.0_40-b43) (build 1.7.0_40-b43)
    Client> # Java VM: Java HotSpot(TM) 64-Bit Server VM (24.0-b56 mixed mode windows-amd64 compressed oops)
    Client> # Problematic frame:
    Client> # C  [atio6axx.dll+0x52fa7]
    [UPD:] As of 13.6b2:
    Code:
    Client> # A fatal error has been detected by the Java Runtime Environment:
    Client> #
    Client> #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000066760f17, pid=2932, tid=1320
    Client> #
    Client> # JRE version: Java(TM) SE Runtime Environment (7.0_40-b43) (build 1.7.0_40-b43)
    Client> # Java VM: Java HotSpot(TM) 64-Bit Server VM (24.0-b56 mixed mode windows-amd64 compressed oops)
    Client> # Problematic frame:
    Client> # C  [atio6axx.dll+0x50f17]
    [UPD2:] Same problem with different address for 13.4.
    [UPD3:] Same problem with different address for 13.10b2 patched by 10.2 9.11 legacy.
    [UPD4:] Derp, patching 13.10b2 with 10.2 again - last one was 9.11 again T_T
    [UPD5:] Same with 13.10b2/10.2, 12.11b8/10.2.
    [UPD6:] Running explicit 32 bit java with 13.10b2/10.2 with OGL libraries patched also, same:
    Code:
    Client> # A fatal error has been detected by the Java Runtime Environment:
    Client> #
    Client> #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x644fab30, pid=1604, tid=3828
    Client> #
    Client> # JRE version: Java(TM) SE Runtime Environment (7.0_40-b43) (build 1.7.0_40-b43)
    Client> # Java VM: Java HotSpot(TM) Client VM (24.0-b56 mixed mode, sharing windows-x86 )
    Client> # Problematic frame:
    Client> # C  [atioglxx.dll+0x4ab30]
     
    Last edited: Sep 17, 2013
  12. tape_artist

    tape_artist Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    HD4850
    I've managed to merge 13.10b2 with 9.8 drivers, semi successfully. Counter strike source works great (and I've noticed a small performance increase), but quake live crashes upon joining a server. Back to the good old drawing board...

    I'm a proud owner of a Gigabyte hd4850, with amd board and processor.
     
  13. AmiloMan

    AmiloMan Master Guru

    Messages:
    345
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    Nice to hear it worked out, you can try different driver versions combined, some apps are more picky when it comes to opengl. Try changing the atioglxx_dl and the atiogl.xml files also when trying a perfect mod. Since you are using a Dx10 card you can opt for higher-up versions of drivers as base after the 10.2 legacy drivers.
     
  14. AmiloMan

    AmiloMan Master Guru

    Messages:
    345
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    Thanks for the feedback, do you mod the openGL files?
     
  15. tape_artist

    tape_artist Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    HD4850
    Well, with higher version it didn't work. When I use higher driver version for mod, immediately after install i get video corruption....
     

  16. xbp13x

    xbp13x Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    ATI 4250M 256MB
    How is the development for the tool to work with newer drivers? It would be nice to try on 13.9 official.
     
  17. AmiloMan

    AmiloMan Master Guru

    Messages:
    345
    Likes Received:
    10
    GPU:
    Gigabyte 270x 4GB
    I will be releasing the new version soon :) Doing some testing on the 13.10betas and their performance is great.

    The new Version's ETA should be around next weekend.
     
  18. Mrsevic

    Mrsevic Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon Hd 36
    Warm greetings from Serbia!!! Thank you so much for creating this wonderful tool.

    Unfortunately i am having some problems with it. I have Power color 9600 pro 256 AGP video card.

    I do not have any hotfixes for it and my video card does not support anything other than 10.02 legacy drivers which i am moding it with. I am using 13.9 drivers, 12.11 delon's and none of them work.

    I unninstalled everything, disabled digital driver enforcment and still no luck.

    When i click custom install it shows display driver and it installes every other component but it cannot install main one display drivers. All is green at the end but i am stuck with 1024 768 and there was not flickering that normally occurs when it installs display driver.

    Device manager install does not work too. I use original MSDNAA Windows 7 Pro x86.

    Is there any chance that you could modify driver for me and then upload it? I am doing everything by instructions it is moron friendly(just 4 ticks for my card right) but i still can get it right.

    Thanks in advance and sorry for bad french :)
     
  19. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Sorry for the intrusion Amiloman. Are you stating the latest 12.11 Modded Legacy driver V9 does not work with your Graphic Card?

    If so please list the problems you encounter.
     
  20. Mrsevic

    Mrsevic Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon Hd 36
    Well yes i first tried your drivers because they worked so well on my mobility hd 3650. On one page i found you support from cards from hd 2000 onwards and on another it stated that legacy support was added.

    I tried your drivers and they appeared in custom install and again same errors as amilomans drivers it installs everything just not display driver.

    I do not know my card is stated as 9550/9600/1050 series.

    I have Win 7 x 86.

    Cheers! :)
     

Share This Page