Introducing FLEM - The Legacy Modder for legacy DirectX 9 and 10 cards.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by AmiloMan, Jul 14, 2013.

  1. aimonz

    aimonz New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ati radeon xpress 1150
    Hi! Great software, but I can't use it with my pc: I have an hp nx6325 with radeon xpress 1150. I mod the driver but setup reports error after install

    hardware id
    PCI\VEN_1002&DEV_5975&SUBSYS_30B0103C&REV_00
    PCI\VEN_1002&DEV_5975&SUBSYS_30B0103C
    PCI\VEN_1002&DEV_5975&CC_030000
    PCI\VEN_1002&DEV_5975&CC_0300

    I try to mod catalyst 13.6 beta with 10.2 legacy driver
    Maybe mobility catalyst are better?
     
  2. AmiloMan

    AmiloMan Master Guru

    Messages:
    337
    Likes Received:
    8
    GPU:
    Gigabyte 270x 4GB
    What did you do exactly? It should MOD it without any issues, What version of windows are you running?
    There are numerous reasons why a driver would not install, maybe you used the wrong files.
    The mobility version of drivers don't work with the utility, only regular beta's or WHQL drivers will work properly.

    I remember modding a driver for a ATI Radeon Xpress 200M/1150 which is similar to that card, it should work.
     
    Last edited: Jul 28, 2013
  3. Dch48

    Dch48 Ancient Guru

    Messages:
    1,822
    Likes Received:
    1
    GPU:
    Sapphire Nitro+ RX 470 4g
    I have discovered that 2 more files need to be added from the legacy package when modding 32 bit drivers . I installed Steam and the new release of the game Half-Life. The game runs in OpenGL but it would not open that way. I added the files atioglxx_dl and atiogl_xml to the other four that are required and now it works.

    My machine has the Mobility Radeon Xpress 200M card with 128mb of dedicated video memory and I modded the 13.4 WHQL driver with the 10-2 legacy. The OS is Windows 8. For some reason the legacy driver will not install but 13.4 modded with Flem does. Even the Vision Control Center works perfectly.
     
    Last edited: Aug 1, 2013
  4. AmiloMan

    AmiloMan Master Guru

    Messages:
    337
    Likes Received:
    8
    GPU:
    Gigabyte 270x 4GB
    Yes those two files are specifically for OpenGL atioglxx_dl and atiogl_xml, seems like a downgrade to a compatible version with your card did the trick on Half Life.
    Thanks for posting your successful MOD result.

    OS Windows 8 32bits
    Card type Radeon Xpress 200M
    Driver Modded 13.4 WHQL

    Successfully Modded !
     

  5. grolla

    grolla Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    8800gt sli
    it's possible mod this 13.8 beta1 for 2 4850 on crossfire?
     
    Last edited: Aug 1, 2013
  6. AmiloMan

    AmiloMan Master Guru

    Messages:
    337
    Likes Received:
    8
    GPU:
    Gigabyte 270x 4GB
    Yeah :) Sure you can, if you plan to use crossfire I recommend that you select the last file also ("atikmpag.sys_" option) plus the files relevant for your platform(32bit or64 bit). Checkout the guide for more details about how to MOD properly, get it right the first time and enjoy your new drivers.

    You could try with the latest legacy drivers for your card, the 13.4 legacy driver.
    PS: I successfully modded the driver on my system, so there shouldn't be any problems on your end. Geez... it takes long to install this new driver set.
     
    Last edited: Aug 1, 2013
  7. grolla

    grolla Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    8800gt sli
    sorry for my English.

    I can't install correctly this 13.8 beta modded driver.
    I tried with legacy 13.1 whql and legacy 13.4 beta but doesn't work.
    when restart the downbar of windows have a artifact glich and firefox crash a few second later when started.
    3d game frozen and restart driver, inplayble.
    [​IMG]
    http://imageshack.us/f/18/nttf.png/

    I try with only 1 4850

    my procedure was a full disinstallation with amd utility and clear with driver sweeper 3.2 then i restarted.

    then i extracted 13.1 legacy and 13.8 beta.
    immediately i used flem browsing a 13.8 driver, i selected FULL MOD and i selected files from 13.1

    http://imageshack.us/f/708/pfi5.jpg/[​IMG]

    there are something wrong?
     
    Last edited: Aug 2, 2013
  8. AmiloMan

    AmiloMan Master Guru

    Messages:
    337
    Likes Received:
    8
    GPU:
    Gigabyte 270x 4GB
    What Windows version+platform 32or64bit are you using and did you use the extra file I posted about? -----> atikmpag.sys.
    You could try the 12.6 legacy driver package for modding too.

    Use all 8 files instead of the 7,
    http://imageshack.us/f/708/pfi5.jpg/
    use the one below the ones you selected also, so there should be a total of 8 files.
     
  9. karnasw

    karnasw Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    AMD HD7850 2GB
    I've tried to mod 13.8 beta with source 13.4beta legacy and 13.1 legacy. But i can't install drivers. My card is mobility hd4570 and windows 8 64bit. Disabled driver signature.

    I browsed first 32bit files from w8_inf and 64bit files from w86a_inf then I checked also 8 file from list.

    After i checked that drivers not working i checked all files from w86a_inf folder but this didn't help.

    What am i doing wrong?
     
  10. AmiloMan

    AmiloMan Master Guru

    Messages:
    337
    Likes Received:
    8
    GPU:
    Gigabyte 270x 4GB
    The thing that you are doing wrong is that you are modding using the two platforms files for 32 and 64bit.

    Delete that package and extract a fresh one, since you are on the 64bit platform use only the files from the 64bit package folder w86a in the cocktailmaker, don't touch the 32bit folder.Hope it works out for you.
     

  11. karnasw

    karnasw Member

    Messages:
    28
    Likes Received:
    0
    GPU:
    AMD HD7850 2GB
    I did that. Nothing help as I said. :(
     
  12. elite69

    elite69 Master Guru

    Messages:
    514
    Likes Received:
    13
    GPU:
    EVGA GTX 1060 6GB
    i did some moding or trying to but i guet a error in the end atikmsis its on use by the sistem.But if moded with 12.11 no error and mode its done but the 3d and open gl driver remain old only the driver its instaled in a 5165 and a 4650 Windows 8 pro with media center,but in performance in some games no performance gains.
     
  13. AmiloMan

    AmiloMan Master Guru

    Messages:
    337
    Likes Received:
    8
    GPU:
    Gigabyte 270x 4GB
    Let me get this straight... You tried modding with the 12.11? Seriously? is that a legacy driver? Search for a legacy driver and do it right.
    The instructions are simple, for most..... :)

    Your old driver remains? Meaning that you don't uninstall your previous drivers, mod properly then uninstall the drivers you are currently running.
     
  14. AmiloMan

    AmiloMan Master Guru

    Messages:
    337
    Likes Received:
    8
    GPU:
    Gigabyte 270x 4GB
    Something is wrong, it should not be doing that. It should work like this.
    Extract both the drivers.
    In the driver to MOD section you select the newer driver package.
    In the cocktailmaker, select the LEGACY files from the legacy folder applicable to your platform.
    MOD the driver and you are done.
    Uninstall the current driver.
    Restart your machine..... then install the new modded driver. It should install without issues.
    Restart the machine again. and behold your new drivers.

    It can't be made any simpler, PS: your card type has been modded succesfully previously with FLEM before, there have been user feedbacks about that.
     
  15. grolla

    grolla Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    8800gt sli
    I'm using win7 64bit.
    I tried with atikmpag.sys toke by legacy 13.1 and don't using legacy with the same result.
     

  16. AmiloMan

    AmiloMan Master Guru

    Messages:
    337
    Likes Received:
    8
    GPU:
    Gigabyte 270x 4GB
    When the driver installation completes what errors do you get during installation?
    The 13.8 drivers are difficult to mod on your machine?
    Use the 13.6Beta2 drivers, they have good performance.If even this driver does not install on your machine then you are definitely modding it wrong.
     
  17. Cave Waverider

    Cave Waverider Master Guru

    Messages:
    944
    Likes Received:
    61
    GPU:
    GeForce RTX 2080 Ti
    Is this tool also able to mod desktop drivers to use with mobility video cards?
     
  18. AmiloMan

    AmiloMan Master Guru

    Messages:
    337
    Likes Received:
    8
    GPU:
    Gigabyte 270x 4GB
    Yah man! Actually it only mods desktop drivers, you can't mod a mobility driver.
    Simply mod a latest desktop whql or beta with a legacy driver that suites you card type, if your card is supported then you are good to go.
    Unfortunately there are very few successful mod results posted by the users who have managed modding their cards successfully.
     
  19. elite69

    elite69 Master Guru

    Messages:
    514
    Likes Received:
    13
    GPU:
    EVGA GTX 1060 6GB
    it is a legacy driver but its that one from here,the 12.11,but i can guet the moding without errors must be myself must study this tool and try moding one
     
  20. Abatap

    Abatap New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Radeon HD 4650 1GB AGP
    Hello, guys.

    First of all, thanks for your modding tool, AmiloMan.

    And now is the time for my problem. I've tried to manually mod the 13.4 winXP driver with files from 13.4beta legacy driver using your guide from this thread and here's the outcome: All Direct3D applications work just fine, ccc seems to be able to control all driver settings normally too (you said it wouldn't work) but DXVA doesn't work at all so my favorite videos are all choppy because my cpu isn't fast enough! And I also have a minor (I guess) problem with OpenGL applications, they just crash right from the start (I can run the same game in d3d and ogl and guess what? It crashes only with the latter api). I guess I can fix the Opengl bug by using the atioglxx.dll (as far as I get this is the only OpenGL-related part of the driver) from 13.4beta legacy so that's not the main point of this message. So I'm asking anybody here to point out which file from that ati driver set is responsible for DXVA (aka video decoding hardware acceleration) so I could reuse it from legacy driver? Btw here's what CCC video settings page looks like, it includes some additional options that weren't visible with normal 13.1\13.4beta legacy drivers installed plus it can't control any of this options because all of the checkbox and value fields default to 0. Is there any any topic on this forum or maybe an article that describes all of those driver files and their purpose becuase I can't find that by looking at file descriptions in my system32 folder.

    [​IMG]

    Oh and btw I modified that driver in a slightly different way, I had to add ati2mtag_R7X section in that .ini file for my HD 4650 because strictily following your guide would have required me to try to use it with ati2mtag_Evergreen sections and that looks like it wouldn't work out.

    Anyway, tldr: Which file is responsible for DXVA support so I could reuse it from that legacy driver because I was just happy with how it worked there?

    Can't wait for your modding tool to support WinXP driver format too, AmiloMan, because those tweaks I can see in your tool look pretty nice (of course you can just tell us which registry keys they are responsible for so I could mod that .ini manually).
     

Share This Page