Intel Turbo Boost = Hard lock

Discussion in 'Processors and motherboards Intel' started by Smiley_ie, Nov 11, 2020.

  1. Smiley_ie

    Smiley_ie Master Guru

    Messages:
    231
    Likes Received:
    13
    GPU:
    Zotac RTX 2080 AMP
    Hi All finished a new build yesterday, so I installed two games for testing (Division 2 & Death Stranding) CPU temp goes from 80s to high 90's and get a hard lock I have tracked this down to Intel Turbo Boost Technology.
    If I disable it in the bios system seems stable temps 60-70's and CPU is hitting 5.2 MHz when running these games when idle it's @ 27 - 30c. There's also Turbo Boost Max Technology 3.0 I can leave that enabled, So am I missing out or am i good to go ?

    Gigabyte Z490-UDAC
    i9 10850k
    16gig T-Force 4000
    RTX 3090
    Cosair H115i

    Clean install of windows 10 x64, No overclocks all default, Power profile balanced (default) Reset CPU and cooler and redone thermal paste, Flashed latest bios F6c, Latest drivers installed
     
    Last edited: Nov 11, 2020
  2. Astyanax

    Astyanax Ancient Guru

    Messages:
    8,354
    Likes Received:
    2,790
    GPU:
    GTX 1080ti
    5.2 is the intended max single core boost, disable anything named along the lines of all core turbo in the bios.
     
  3. Smiley_ie

    Smiley_ie Master Guru

    Messages:
    231
    Likes Received:
    13
    GPU:
    Zotac RTX 2080 AMP
    CPU.jpg This is the performance im getting on the cores with Turbo Boost disabled
     
  4. Astyanax

    Astyanax Ancient Guru

    Messages:
    8,354
    Likes Received:
    2,790
    GPU:
    GTX 1080ti
    looks like bios misbehavior to me.
     

  5. gmavignier

    gmavignier Ancient Guru

    Messages:
    1,515
    Likes Received:
    11
    GPU:
    GTX 1660Ti Max-Q
    I used to get hard locks on my old i5 but it was related to Hyper Threading. Disabling that solved the issue. This, however, is new to me.
     
  6. Smiley_ie

    Smiley_ie Master Guru

    Messages:
    231
    Likes Received:
    13
    GPU:
    Zotac RTX 2080 AMP
    Ok fixed it if i set ram to 3600 system works fine with Intel Turbo Boost.
     

Share This Page