Intel NIC can't negotiate gigabit connection

Discussion in 'Network questions and troubleshooting' started by deltatux, May 7, 2012.

  1. sykozis

    sykozis Ancient Guru

    Messages:
    21,870
    Likes Received:
    1,081
    GPU:
    MSI RX5700
    There was a thread a couple months ago concerning network performance and an integrated Intel NIC.

    My current Broadcom is the first integrated NIC I haven't had some stupid issue with. It actually works as well as my Intel NICs do.
     
  2. deltatux

    deltatux Ancient Guru

    Messages:
    19,051
    Likes Received:
    13
    GPU:
    GIGABYTE Radeon R9 280
    My Atheros ones (my old board had an Atheros NIC as well) and they worked as well as or better than the Intel NICs. The only real thing I like Intel NICs over the Atheros NICs is that Intel has a better suite for its drivers.

    deltatux
     
  3. sykozis

    sykozis Ancient Guru

    Messages:
    21,870
    Likes Received:
    1,081
    GPU:
    MSI RX5700
    This Broadcom is the only NIC I've seen that's even close to my PCIe Intel Desktop CT NIC (EXPI9301CT). Tempted to reinstall my PCIe NIC to see if maybe there was some compatibility issue with the last motherboard. The few Atheros NIC's I've used have all suffered from high latency.
     
  4. deltatux

    deltatux Ancient Guru

    Messages:
    19,051
    Likes Received:
    13
    GPU:
    GIGABYTE Radeon R9 280
    Hmmm interesting, I haven't been seeing that issue with the Atheros NICs I've had the chance to play with. My old board had the Atheros L1 (formerly Attansic L1) and my current one is the Atheros AR8151 (also known as Atheros L1C according to Wireshark). Latency for the L1C is exactly the same as the Intel 82579V.

    deltatux
     

  5. Allygash

    Allygash New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Giagbyte 670 Sli
    Fixed

    Fixed this very issue by changing the lan cable, i can now force a Giga lan connection. Before the cable change i could only use the auto setting....
     
  6. dk_lightning

    dk_lightning Ancient Guru

    Messages:
    1,536
    Likes Received:
    59
    GPU:
    GTX 1070 8GB
    I had a similar issue.

    1 cable i was refusing to connect at 1gbps. A cable tester shows the cable as fine, all pairs working.

    Got a new cable. This one longer but still cat5e and its been working fine since.

    So just for the hell of it, get a new cable.
     
  7. deltatux

    deltatux Ancient Guru

    Messages:
    19,051
    Likes Received:
    13
    GPU:
    GIGABYTE Radeon R9 280
    lol, way to necro my old thread. As stated in previous post:

    ... I have resolved it by switching cables.

    It's just very unfortunate that the Intel NIC is very sensitive to length to the point that just slightly longer causes it to negotiate at a lower speed...

    deltatux
     

Share This Page