Intel HD Graphics 9.17.10.4101 driver Download for Sandy Bridge

Discussion in 'Frontpage news' started by Hilbert Hagedoorn, Feb 9, 2015.

  1. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    40,752
    Likes Received:
    9,171
    GPU:
    AMD | NVIDIA
  2. heffeque

    heffeque Ancient Guru

    Messages:
    4,108
    Likes Received:
    79
    GPU:
    nVidia MX150
    A few issues resolved. Good that Intel hasn't forgotten about older hardware.
     
  3. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,800
    Likes Received:
    3,354
    GPU:
    6900XT+AW@240Hz
    If anyone had hopes for QuickSync working with this driver under w8.1, then maybe in next 3 years.
    So yeah, we are still running 2500/2600k, and intel hates us for it very long time.
     
  4. heffeque

    heffeque Ancient Guru

    Messages:
    4,108
    Likes Received:
    79
    GPU:
    nVidia MX150
    QuickSync working fine here. Haven't tried this new driver yet, but I'm guessing that they haven't broken it.
     

  5. sykozis

    sykozis Ancient Guru

    Messages:
    21,798
    Likes Received:
    1,056
    GPU:
    MSI RX5700
    First new driver for HD2000/3000 since Win8.1 launched.
     
  6. Octopuss

    Octopuss Master Guru

    Messages:
    860
    Likes Received:
    71
    GPU:
    -
    Could anyone explain the super weird driver numbers Intel uses? It cannot get more confusing than this: 15.28.23.64.4101 (9.17.10.4101). What the heck?
    What's even worse is various sources use either of these, and only one of them is written in the readme.
     
  7. nick0323

    nick0323 Master Guru

    Messages:
    995
    Likes Received:
    48
    GPU:
    Asus DUAL RTX2060S
    I've had two chipset updates for my Motherboard which runs a Sandy Bridge chipset within the last 3 months using the Intel Drive Update Utility installed on my PC but before that none for 2 years.
     
  8. villa_youth

    villa_youth Master Guru

    Messages:
    808
    Likes Received:
    0
    GPU:
    780 Ti
    "This computer does not meet the minimum requirements for installing the software" WTF ?
    Running win 8.1 x64, 2600k i7. Anyone else get this ?
     
  9. heffeque

    heffeque Ancient Guru

    Messages:
    4,108
    Likes Received:
    79
    GPU:
    nVidia MX150
    Untrue. Driver 9.17.10.3517 is from 2014-03-20, several months after the introduction of 8.1.
     
  10. bulldog75

    bulldog75 Member

    Messages:
    34
    Likes Received:
    9
    GPU:
    Gigabyte G1 Gaming 1070
    Well what is the point in this.I have a massive G/Card so go figure.
     

  11. LesserHellspawn

    LesserHellspawn Master Guru

    Messages:
    660
    Likes Received:
    14
    GPU:
    2x GTX980ti
    Not using the integrated GPU in my 2600k, but my notebook has a 2620M, so there :)
     
  12. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,800
    Likes Received:
    3,354
    GPU:
    6900XT+AW@240Hz
    It has been confirmed by many users around that QuickSync and 2500/2600k does not run under W8.1.
    It runs under W7/8 only. Required files are present, you can connect monitor to iGP or use virtual screen, but that works only under W7/8.
    It is IGP driver, you have to have it enabled.
     
    Last edited: Feb 11, 2015
  13. heffeque

    heffeque Ancient Guru

    Messages:
    4,108
    Likes Received:
    79
    GPU:
    nVidia MX150
    Working fine on an i3-2328M.
     

Share This Page