Input lag

Discussion in 'Videocards - AMD Radeon Drivers Section' started by TheStrelok, Jul 26, 2011.

  1. TheStrelok

    TheStrelok New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    MSI 4870 1GB
    I have a monitor with a 5ms response time, 60hz refresh rate, a deathadder (3500DPI version) with the latest drivers & firmware installed, I have the "flip qeue size" setting set to 0, and most of my games run at 40+FPS--yet I still get an insane amount of input lag in a lot of these games. Oh, and I never use Vsync--and the Windows 7 mouse acceleration is disabled using this fix.

    An example is that I run the Witcher 2 @ 40FPS average. If I disable SSAO, my FPS doesn't increase all that much, but I get a significant reduction in input lag. I've also noticed that there are various settings in various games where even though they don't affect my FPS much, the differences in the mouse lag is huge.

    I've also noticed that Desktop Window Manager Session Manager (DWM) in Vista/7 induces a great deal of input lag when enabled--but a friend who owns an NVIDIA card doesn't get this issue with DWM (nor does he get it with TW2 or any other instance where it occurs for me).

    Perhaps this is an ATI driver problem? I'm currently running the June 27th build of the Catalyst 11.7 drivers.
     
    Last edited: Jul 26, 2011
  2. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    3,072
    Likes Received:
    600
    GPU:
    Nitro 5700 XT
    Out of curiosity how many usb devices do you have plugged up?
     
  3. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,496
    Likes Received:
    991
    GPU:
    3080Ti Strix H20
    Witcher 2 is normal. I play for a long time and then the mouse gets slow/choppy. Quit and reenter the game it is normal again.
     
  4. TheStrelok

    TheStrelok New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    MSI 4870 1GB
    My mouse, my keyboard, the USB port on my keyboard that I have to connect to motherboard's USB for it to work, and three USB drives which I use for essential backups and music storage.

    I just tired unplugging all USB devices except for my mouse and keyboard. It didn't seem to help at all, unfortunately.

    I've experienced that, but for the most part it really just seems to depend on the area I'm in (regardless of how that area affects my FPS).

    Also, running any game in DX10 or DX11 is completely out of the question. I can only play in DX9 (whether it's BC2, STALKER, Crysis or whatever) else I suffer massive input lag.
     

  5. Gavatron

    Gavatron Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    AMD 6850 @1ghz
    possible that the games in question are calling to the mouse accel function u've modified and is spinning out ?
     
  6. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,496
    Likes Received:
    991
    GPU:
    3080Ti Strix H20
    Try turning off mouse smoothing in witchers User.cfg in my documents.Smoothness=0 is under [MouseInput]
     
  7. kn00tcn

    kn00tcn Ancient Guru

    Messages:
    1,604
    Likes Received:
    2
    GPU:
    570m / MSI 660 Gaming OC
    you mean when aero is enabled? i dont have such an issue...

    vsync off & still getting input lag must be something else tied to your setup that may or may not be fixable in drivers
     

Share This Page