Improve GeForce GTX series performance with a handy tweak

Discussion in 'Frontpage news' started by Hilbert Hagedoorn, Apr 29, 2015.

  1. rta

    rta Active Member

    Messages:
    85
    Likes Received:
    0
    GPU:
    MSI GTX970
    I have an Nvidia Shield tab showing up on my porch on Friday...soooo...yeah.
     
  2. BubbaBobBob

    BubbaBobBob New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    EVGA GTX 1070 FTW
    GeForce Experience is the real problem

    Actually the problem was (is) with Nvidia GeForce Experience. That is what controls the streaming with Nvidia cards.
    The last new version that came out (2.4.1.21) started the problem.
    When I noticed it I went back to the last version and the CPU usage dropped to none.
    I did finally go into services, as I had ever since GeForce came out, and disable streaming, just to use the newer version.
    I have GTX680 in SLI and the drain was at the CPU...
     
  3. Mineria

    Mineria Ancient Guru

    Messages:
    4,996
    Likes Received:
    421
    GPU:
    Asus RTX 3080 Ti
    I have noticed that is spams the log at boot, probably because the service needs to be delayed to give the network connection a chance to get established.

    Never seen slowdowns cause of GFE though, neither any stuttering, except when I try to record Rocksmith 2014 via Shadowplay, so I skipped installing GFE all together, only used Shadowplay anyway.
     
  4. Singleton99

    Singleton99 Maha Guru

    Messages:
    1,048
    Likes Received:
    85
    GPU:
    Aorus-Extreme-1080TI
    I read this the other day over @ overclockers-uk forums , so i disabled the service then i then ran 3dmark firestrike and compared the results to my last run , but i couldn't say that there was any gain worth jumping up and down about.
    Maybe like others have said that the gain maybe on the CPU side or the tweak will benefit modest to low end systems the most.

    Anyway i will keep it disabled as i never use shadow play , damm i play bad most of the time , why the hell would i want to record it to watch the pain again or even upload it somewhere for people to laugh at . lol But i still enjoy it immensely .

    Over and out and back to having my arse kicked ingame. :):banana:
     

  5. Noisiv

    Noisiv Ancient Guru

    Messages:
    8,109
    Likes Received:
    1,393
    GPU:
    2070 Super
    been doing that since forever!!

    never gained a single fps, but it felt like a right thing to do :banana:
     
  6. vbetts

    vbetts Don Vincenzo Staff Member

    Messages:
    15,128
    Likes Received:
    1,703
    GPU:
    GTX 1080 Ti
    The way I see it, it's like any other service. If it takes up enough cpu and memory usage, turning it off will warrant positive results. How positive now that all depends on how much the service was using the cpu, memory, and your hard drive. I cut services that I usually will never use or care about but I would expect if I didn't, I probably wouldn't notice a difference in performance still.
     
  7. Kevin cobley

    Kevin cobley Member

    Messages:
    41
    Likes Received:
    6
    GPU:
    Nvidia 3070
    The story is bollocks, zero difference in frame rate GF Experience there or not and streaming on or off.
    I've got an X99 5820CPU and a GTX980 Card and 16G memory 2 x MX100 in raid 0.
    So many resources so little to throw at it.
    Skylakes benchmarks of the new 4 core 8 threads are very close to the performance of my 5820 at a 45w lower TDP.
     
  8. Corrupt^

    Corrupt^ Ancient Guru

    Messages:
    7,080
    Likes Received:
    373
    GPU:
    Geforce RTX 3090 FE
    Update on my end:

    Older drivers aren't showing this behavior and I think it's a bug. U used to have the ability to disable streaming to "Shield Devices" in Experience. This is now gone.

    In the background however, wermgr.exe (Windows Error Reporting basically) keeps spamming that the NvNetworkService is causing an issue, which is tied to the NvStreamSvc service.

    Now both are needed to start Shadowplay up (the ON/OFF switch) but they're not needed for shadowplay to function.

    IMO the issue is that NVExperience keeps trying to find a Shield Device across the network but gets no response and then it goes all wonky.

    In the meanwhile I've made a quick batch file to use the newer drivers:

    Start up ShadowPlay as normal and then run this. Tested with BF4, recording seems to work, the icon however is spazzing out and streaming (twitch for instance) won't be possible.

    Also going to test if I can install an older Experience on top of this newer driver tbh.

    EDIT: There seems to be a patch out for GFExperience, though it didn't download on its own :x
     
    Last edited: May 6, 2015

Share This Page