iiYama monitor recognized as HDMI-HDTV and not PC

Discussion in 'Videocards - NVIDIA GeForce' started by Fred Bosch, Dec 7, 2022.

  1. Fred Bosch

    Fred Bosch New Member

    Messages:
    6
    Likes Received:
    1
    GPU:
    rtx 3060
    My second monitor is connected via HDMI. RTX 3060 recognizes monitor as a HDMI-HDTV. Customised the output dynamic range to 'Full' but the screen is still not as crisp as when it was connected to intel HD graphics.

    My current feel, after trying all sorts of excellent suggestions, is that nvidia does not see the monitor as 'PC' and the screen remains unsharp. Whilst my first monitor also displays resolutions for Ultra HD, SD etc, it also displays resolutions for PC, which i selected of course.
    How can i update the Nvidia driver to address the monitor as a 'PC' ?
    Thank you!
     
  2. endbase

    endbase Maha Guru

    Messages:
    1,164
    Likes Received:
    261
    GPU:
    Intel ARC A770
    maybe start by downloading the proper driver file for your Iiyama monitor look up the type on their website

    it should look like this in device manager

    [​IMG]
     
  3. Astyanax

    Astyanax Ancient Guru

    Messages:
    14,998
    Likes Received:
    6,147
    GPU:
    GTX 1080ti
    monitors don't have "drivers."
    the inf can override the edid specified resolutions (nearly none of them do) and install typically poorly made icc profiles.
     
  4. endbase

    endbase Maha Guru

    Messages:
    1,164
    Likes Received:
    261
    GPU:
    Intel ARC A770
    Yeah icc profiles are good enough but outdated
     

  5. Fred Bosch

    Fred Bosch New Member

    Messages:
    6
    Likes Received:
    1
    GPU:
    rtx 3060
    I already tried this (see picture), but it does not make any difference. The NCP does not recognize this monitor as a PC.
     

    Attached Files:

    endbase likes this.
  6. Fred Bosch

    Fred Bosch New Member

    Messages:
    6
    Likes Received:
    1
    GPU:
    rtx 3060
    Is there anybody who could help me out, how to let nvidia NCP think the second monitor is not a HDTV?
    A registry setting perhaps?
     
  7. pegasus1

    pegasus1 Ancient Guru

    Messages:
    2,768
    Likes Received:
    1,480
    GPU:
    TUF 4090
    Have you tried a different HDMI cable? Isn't there a setting in Windows somewhere
     
  8. Ital

    Ital Master Guru

    Messages:
    201
    Likes Received:
    83
    GPU:
    ZOTAC GTX 1080 AMP
    TimmyP likes this.
  9. TimmyP

    TimmyP Maha Guru

    Messages:
    1,086
    Likes Received:
    174
    GPU:
    RTX 3070
    ^CRU will have a section for TV and TV resolutions. Delete every one which will remove the section. Persists through driver updates.

    I bet your DLDSR\DSR values are screwed up too.
     
  10. Fred Bosch

    Fred Bosch New Member

    Messages:
    6
    Likes Received:
    1
    GPU:
    rtx 3060
    Thank you! The output of the CRU 2790 is the monitor that only has TV resolutions. The 2893 is the 4K monitor that is ok.
    What do i need to delete? pl2790.png
     

    Attached Files:


  11. Cave Waverider

    Cave Waverider Ancient Guru

    Messages:
    1,623
    Likes Received:
    433
    GPU:
    ASUS RTX 4090 TUF
    Double-Click on the "CTA-861..." entry, it should open a Window with various things. One of them should be "TV Resolutions", double-click on that. You can also check under "HDMI Support" and see what's listed there.
     
  12. Fred Bosch

    Fred Bosch New Member

    Messages:
    6
    Likes Received:
    1
    GPU:
    rtx 3060
    This is the output of the two questions. Thank you again. What do you advice to change or delete?
     

    Attached Files:

    Last edited: Dec 13, 2022
  13. Cave Waverider

    Cave Waverider Ancient Guru

    Messages:
    1,623
    Likes Received:
    433
    GPU:
    ASUS RTX 4090 TUF
    I don't know about your particular monitor. It's odd that your HDMI Support section doesn't show any HDMI resolutions in the bottom. Perhaps you could try to add the monitor's native one there and see if it helps?
    If you have standard and detailed resolutions listed on the first CRU page, then you could probably try to delete all the TV resolutions and see what happens. Keep in mind that you may have to to reset it in Windows safe mode (either use CRU's reset-all.exe or you can also use DDU with the removal of monitors ticked in Settings there - which may be a good idea to try anyway in case there are any conflicts from previous monitors) if you lose sync due to it, though.
     
  14. Fred Bosch

    Fred Bosch New Member

    Messages:
    6
    Likes Received:
    1
    GPU:
    rtx 3060
    What i have done is i removed the HDMI support in full and i have deleted all tv resolutions.
    In NCP the connect is suddenly changed to DVI (and i can select resolutions in both PC and HD etc mode).
    I suppose this is because i deleted the HDMI support line.
    Btw: all of these actions have NO EFFECT :-(
    What i also noticed is that in CRU i can change the timing for a particular resolution (for example to: automatic PC) but if i ok the change and reopen the resolution again, it is back to manual again.
    Btw2: I tried to add the native resolution in the HDMI support section (that i now removed), but it requires a binary code for other resolutions than the two displayed. Neither is supported by my monitor. I suppose i need to know the binary code (0-255) for 1920x1080@60Hz?
    Any next suggestions are welcome. It is just amazing i can change so many things and see no difference.
     

    Attached Files:

Share This Page